summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-15 18:17:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-15 18:17:33 +0000
commitc6fb08b14fb717475809737fb09949646b88c57f (patch)
treecd831f7baf0d139128541a9c04d0c1cf11446cb5 /sys-fs
parentadded to sys-fs (diff)
downloadgentoo-2-c6fb08b14fb717475809737fb09949646b88c57f.tar.gz
gentoo-2-c6fb08b14fb717475809737fb09949646b88c57f.tar.bz2
gentoo-2-c6fb08b14fb717475809737fb09949646b88c57f.zip
added to sys-fs
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfsprogs/ChangeLog32
-rw-r--r--sys-fs/ntfsprogs/Manifest4
-rw-r--r--sys-fs/ntfsprogs/files/digest-ntfsprogs-1.7.11
-rw-r--r--sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild39
4 files changed, 74 insertions, 2 deletions
diff --git a/sys-fs/ntfsprogs/ChangeLog b/sys-fs/ntfsprogs/ChangeLog
new file mode 100644
index 000000000000..1c3d2c43688e
--- /dev/null
+++ b/sys-fs/ntfsprogs/ChangeLog
@@ -0,0 +1,32 @@
+# ChangeLog for sys-fs/ntfsprogs
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ChangeLog,v 1.1 2003/09/15 18:17:31 seemant Exp $
+
+*ntfsprogs-1.7.1 (15 Sep 2003)
+
+ 15 Sep 2003; Seemant Kulleen <seemant@gentoo.org> ntfsprogs-1.7.1.ebuild:
+ moved from sys-apps to sys-fs
+
+ 06 Aug 2003; Martin Holzer <mholzer@gentoo.org> ntfsprogs-1.7.1.ebuild:
+ need gcc-2.96+
+
+ 10 Jun 2003; <msterret@gentoo.org> ntfsprogs-1.7.1.ebuild:
+ DEPEND on sed >= 4
+
+*ntfsprogs-1.7.1 (31 May 2003)
+
+ 31 May 2003; Brandon Low <lostlogic@gentoo.org> ntfsprogs-1.7.1.ebuild:
+ Move package to new name, and bump version thangs to bug 18713
+
+*linux-ntfs-1.6.0 (02 Nov 2002)
+
+ 02 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Compile the project ourselves, thanks to cory@visi.name; #9810.
+
+*linux-ntfs-1.5.0-r1 (1 Feb 2002)
+
+ 21 Jul 2002; Mark Guertin <gerk@gentoo.org> :
+ updated keywords (-ppc -sparc -sparc64) - this is a binary pkg for x86.
+
+ 14 Jul 2002; phoen][x <phoenix@gentoo.org> :
+ Added LICENSE, KEYWORDS, SLOT.
diff --git a/sys-fs/ntfsprogs/Manifest b/sys-fs/ntfsprogs/Manifest
index 57248e392595..75045a23c613 100644
--- a/sys-fs/ntfsprogs/Manifest
+++ b/sys-fs/ntfsprogs/Manifest
@@ -1,3 +1,3 @@
+MD5 f06ce9d22efd5db278bf72bf48f89396 ChangeLog 1093
+MD5 ccdafefa1cb480a9c6eab41e76c7a5b2 ntfsprogs-1.7.1.ebuild 1238
MD5 9c54070c93405b7ad66d548e7fa2e2a4 files/digest-ntfsprogs-1.7.1 67
-MD5 fd353cd9b0f75e89e3180b00192e0e90 ChangeLog 956
-MD5 21abfc968aefbdb60d3944851d057cd7 ntfsprogs-1.7.1.ebuild 1239
diff --git a/sys-fs/ntfsprogs/files/digest-ntfsprogs-1.7.1 b/sys-fs/ntfsprogs/files/digest-ntfsprogs-1.7.1
new file mode 100644
index 000000000000..49d1df8bca9a
--- /dev/null
+++ b/sys-fs/ntfsprogs/files/digest-ntfsprogs-1.7.1
@@ -0,0 +1 @@
+MD5 3bac306e0923b142bb82b4592e49d239 ntfsprogs-1.7.1.tar.gz 416883
diff --git a/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild b/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild
new file mode 100644
index 000000000000..e89e43dc1612
--- /dev/null
+++ b/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-1.7.1.ebuild,v 1.1 2003/09/15 18:17:32 seemant Exp $
+
+DESCRIPTION="Utilities and library for accessing NTFS filesystems"
+HOMEPAGE="http://linux-ntfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-ntfs/${P}.tar.gz"
+
+DEPEND=">sys-devel/gcc-2.95
+ >=sys-apps/sed-4"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64"
+
+src_compile() {
+ sed -i 's:head -1:head -n 1:' configure
+ econf || die "Configure failed"
+
+ # I've added only this Makefile tweak, and we don't need
+ # the gcc patch - Quequero
+ sed -i -e "s:CFLAGS = -g -O2:CFLAGS = ${CFLAGS}:" \
+ -e "s:CPPFLAGS =:CPPFLAGS = ${CXXFLAGS}:" Makefile
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Install failed"
+
+ # lot's of docs (a good thing :)
+ dodoc CREDITS ChangeLog NEWS README TODO.include TODO.mkntfs TODO.ntfsfix \
+ doc/attribute_definitions doc/attributes.txt doc/compression.txt \
+ doc/system_files.txt doc/system_security_descriptors.txt \
+ doc/tunable_settings
+
+ # a normal user cannot run ntfsfix
+ cd ${D}
+ mv usr/bin/ntfsfix usr/sbin
+ rmdir usr/bin
+}