summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-09-02 10:25:23 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-09-02 10:25:23 +0000
commitd17408932f82b1ce5421573b0f934507d740d067 (patch)
treeebb5dbe798446108d21c26de5f8c37fec144628f /sys-fs
parentStable on amd64 (diff)
downloadgentoo-2-d17408932f82b1ce5421573b0f934507d740d067.tar.gz
gentoo-2-d17408932f82b1ce5421573b0f934507d740d067.tar.bz2
gentoo-2-d17408932f82b1ce5421573b0f934507d740d067.zip
Also doing lib install cleanup for stable version.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog5
-rw-r--r--sys-fs/udev/udev-114.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 71074fff273e..ba3592841a72 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.341 2007/09/02 09:53:03 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.342 2007/09/02 10:25:23 zzam Exp $
+
+ 02 Sep 2007; Matthias Schwarzott <zzam@gentoo.org> udev-114.ebuild:
+ Also doing lib install cleanup for stable version.
02 Sep 2007; Matthias Schwarzott <zzam@gentoo.org> udev-115.ebuild:
Cleaning up libvolume_id installation. Now die if dolib fails to prevent
diff --git a/sys-fs/udev/udev-114.ebuild b/sys-fs/udev/udev-114.ebuild
index 8044a04486c6..73b377eaa463 100644
--- a/sys-fs/udev/udev-114.ebuild
+++ b/sys-fs/udev/udev-114.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-114.ebuild,v 1.11 2007/08/25 14:43:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-114.ebuild,v 1.12 2007/09/02 10:25:23 zzam Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -126,9 +126,10 @@ src_install() {
# vol_id library (needed by mount and HAL)
into /
- dolib extras/volume_id/lib/*.so*
+ rm ${D}/lib/libvolume_id.so* 2>/dev/null
+ dolib extras/volume_id/lib/*.so* || die "Failed installing libvolume_id.so"
into /usr
- dolib extras/volume_id/lib/*.a
+ dolib extras/volume_id/lib/*.a || die "Failed installing libvolume_id.a"
# handle static linking bug #4411
rm -f "${D}/usr/$(get_libdir)/libvolume_id.so"
@@ -247,7 +248,7 @@ pkg_postinst() {
# Removing some old file
if has_version "<sys-fs/udev-104-r5"; then
rm -f "${ROOT}"/etc/dev.d/net/hotplug.dev
- rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/net
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/net 2>/dev/null
fi
if has_version "<sys-fs/udev-106-r5"; then
@@ -258,7 +259,7 @@ pkg_postinst() {
# Try to remove /etc/dev.d as that is obsolete
if [[ -d "${ROOT}"/etc/dev.d ]]; then
- rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/default "${ROOT}"/etc/dev.d
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/default "${ROOT}"/etc/dev.d 2>/dev/null
if [[ -d "${ROOT}"/etc/dev.d ]]; then
ewarn "You still have the directory /etc/dev.d on your system."
ewarn "This is no longer used by udev and can be removed."