summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-07 11:09:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-07 11:09:57 +0000
commitd241637779bb895574a34e50aafc2ae2ab6a389f (patch)
treef83cb6a54f185f7f56bcbd5962e861c3a6035786 /sys-fs
parentNew ebuild for x11-themes/mate-icon-theme, MATE default icon themes; imported... (diff)
downloadgentoo-2-d241637779bb895574a34e50aafc2ae2ab6a389f.tar.gz
gentoo-2-d241637779bb895574a34e50aafc2ae2ab6a389f.tar.bz2
gentoo-2-d241637779bb895574a34e50aafc2ae2ab6a389f.zip
Overwrite libudev.so symlink (for now) because upstream commit http://cgit.freedesktop.org/systemd/systemd/commit/Makefile.am?id=e2438b7a321de8050f5db6793599a1668c91ccf5 broke it by introducing use of --relative for ln. The bug is only visible when setting eg. --with-rootlibdir=/lib away from /usr to alternative location together with the use of $(DESTDIR) with multiple directory levels.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog10
-rw-r--r--sys-fs/udev/udev-9999.ebuild14
2 files changed, 18 insertions, 6 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index b5de71406b22..917709eb4b13 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.1007 2014/03/07 06:08:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.1008 2014/03/07 11:09:57 ssuominen Exp $
+
+ 07 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> udev-9999.ebuild:
+ Overwrite libudev.so symlink (for now) because upstream commit http://cgit.fre
+ edesktop.org/systemd/systemd/commit/Makefile.am?id=e2438b7a321de8050f5db679359
+ 9a1668c91ccf5 broke it by introducing use of --relative for ln. The bug is
+ only visible when setting eg. --with-rootlibdir=/lib away from /usr to
+ alternative location together with the use of $(DESTDIR) with multiple
+ directory levels.
07 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> udev-9999.ebuild:
Punt kdbus documentation which are irrelevant to sys-fs/udev.
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 868c480093df..a419a07c24bc 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.281 2014/03/07 06:08:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.282 2014/03/07 11:09:57 ssuominen Exp $
EAPI=5
@@ -135,10 +135,7 @@ src_prepare() {
eval export INTLTOOL_{EXTRACT,MERGE,UPDATE}=/bin/true
eval export {MSG{FMT,MERGE},XGETTEXT}=/bin/true
fi
-
- # apply user patches
- epatch_user
-
+
# compile with older versions of gcc #451110
version_is_at_least 4.6 $(gcc-version) || \
sed -i 's:static_assert:alsdjflkasjdfa:' src/shared/macro.h
@@ -146,6 +143,9 @@ src_prepare() {
# change rules back to group uucp instead of dialout for now wrt #454556
sed -i -e 's/GROUP="dialout"/GROUP="uucp"/' rules/*.rules || die
+ # apply user patches
+ epatch_user
+
if [[ ! -e configure ]]; then
if use doc; then
gtkdocize --docdir docs || die "gtkdocize failed"
@@ -343,6 +343,10 @@ multilib_src_install() {
else
doman "${S}"/man/{systemd.link.5,udev.7,udevadm.8,systemd-udevd.service.8}
fi
+
+ # Use of --relative doesn't work with $(DESTDIR). The broken commit is:
+ # http://cgit.freedesktop.org/systemd/systemd/commit/Makefile.am?id=e2438b7a321de8050f5db6793599a1668c91ccf5
+ ln -s -f "${D}"/usr/$(get_libdir)/libudev.so ../../$(readlink "${D}"/$(get_libdir)/libudev.so.1)
else
local lib_LTLIBRARIES="libudev.la" \
pkgconfiglib_DATA="src/libudev/libudev.pc" \