summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-23 07:57:14 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-23 07:57:14 +0000
commitef7012339d9359d7cd33e8ef4ab5d4a3136adc2b (patch)
tree9f5622ac18e84d767e921a62756514dc0b887c0d /sys-fs
parentx86 stable wrt bug #429612 (diff)
downloadgentoo-2-ef7012339d9359d7cd33e8ef4ab5d4a3136adc2b.tar.gz
gentoo-2-ef7012339d9359d7cd33e8ef4ab5d4a3136adc2b.tar.bz2
gentoo-2-ef7012339d9359d7cd33e8ef4ab5d4a3136adc2b.zip
Add requirements for gcc 4.6 or higher wrt bug #427602
(Portage version: 2.2.0_alpha129/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/leechcraft-vrooby/ChangeLog7
-rw-r--r--sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.75.ebuild11
-rw-r--r--sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.80.ebuild11
-rw-r--r--sys-fs/leechcraft-vrooby/leechcraft-vrooby-9999.ebuild11
4 files changed, 36 insertions, 4 deletions
diff --git a/sys-fs/leechcraft-vrooby/ChangeLog b/sys-fs/leechcraft-vrooby/ChangeLog
index 60cdd25918b6..81943bcf09c8 100644
--- a/sys-fs/leechcraft-vrooby/ChangeLog
+++ b/sys-fs/leechcraft-vrooby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/leechcraft-vrooby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/ChangeLog,v 1.4 2012/08/13 14:14:33 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/ChangeLog,v 1.5 2012/09/23 07:57:14 pinkbyte Exp $
+
+ 23 Sep 2012; Sergey Popov <pinkbyte@gentoo.org>
+ leechcraft-vrooby-0.5.75.ebuild, leechcraft-vrooby-0.5.80.ebuild,
+ leechcraft-vrooby-9999.ebuild:
+ Add requirements for gcc 4.6 or higher wrt bug #427602
*leechcraft-vrooby-0.5.80 (13 Aug 2012)
diff --git a/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.75.ebuild b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.75.ebuild
index 6edba2c9a90b..78dc09fc28f8 100644
--- a/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.75.ebuild
+++ b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.75.ebuild,v 1.1 2012/07/19 20:14:01 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.75.ebuild,v 1.2 2012/09/23 07:57:14 pinkbyte Exp $
EAPI="4"
@@ -16,3 +16,12 @@ DEPEND="~net-misc/leechcraft-core-${PV}
x11-libs/qt-dbus:4"
RDEPEND="${DEPEND}
sys-fs/udisks:0"
+
+# TODO: Maybe simplify this or add apropriate function to leechcraft eclass?
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
+ && die "Sorry, but gcc 4.6 or higher is required."
+ fi
+}
diff --git a/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.80.ebuild b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.80.ebuild
index eebf11ab5c37..a27ddfedda0f 100644
--- a/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.80.ebuild
+++ b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.80.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.80.ebuild,v 1.1 2012/08/13 14:14:33 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.80.ebuild,v 1.2 2012/09/23 07:57:14 pinkbyte Exp $
EAPI="4"
@@ -16,3 +16,12 @@ DEPEND="~net-misc/leechcraft-core-${PV}
x11-libs/qt-dbus:4"
RDEPEND="${DEPEND}
sys-fs/udisks:0"
+
+# TODO: Maybe simplify this or add apropriate function to leechcraft eclass?
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
+ && die "Sorry, but gcc 4.6 or higher is required."
+ fi
+}
diff --git a/sys-fs/leechcraft-vrooby/leechcraft-vrooby-9999.ebuild b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-9999.ebuild
index a0d5e4fba0dc..a0b1e48aba99 100644
--- a/sys-fs/leechcraft-vrooby/leechcraft-vrooby-9999.ebuild
+++ b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/leechcraft-vrooby-9999.ebuild,v 1.2 2012/07/15 15:41:08 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/leechcraft-vrooby-9999.ebuild,v 1.3 2012/09/23 07:57:14 pinkbyte Exp $
EAPI="4"
@@ -16,3 +16,12 @@ DEPEND="~net-misc/leechcraft-core-${PV}
x11-libs/qt-dbus:4"
RDEPEND="${DEPEND}
sys-fs/udisks:0"
+
+# TODO: Maybe simplify this or add apropriate function to leechcraft eclass?
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
+ && die "Sorry, but gcc 4.6 or higher is required."
+ fi
+}