summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-01 23:10:54 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-01 23:10:54 +0000
commitfb66dc07929fc10c631d6134fc67c504e81a15f7 (patch)
treee5ae8359aba50b57e8f25cbebb1ba18be64faa69 /sys-fs
parentRemoved older versions, all were the same slot 0. 1.4.5 is stable on archs th... (diff)
downloadgentoo-2-fb66dc07929fc10c631d6134fc67c504e81a15f7.tar.gz
gentoo-2-fb66dc07929fc10c631d6134fc67c504e81a15f7.tar.bz2
gentoo-2-fb66dc07929fc10c631d6134fc67c504e81a15f7.zip
Version bump
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.6.13
-rw-r--r--sys-fs/fuse/fuse-2.6.1.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 09a8e76b3b52..7325ba3215b1 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.67 2006/11/24 18:01:29 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.68 2006/12/01 23:10:54 genstef Exp $
+
+*fuse-2.6.1 (01 Dec 2006)
+
+ 01 Dec 2006; Stefan Schweizer <genstef@gentoo.org> +fuse-2.6.1.ebuild:
+ Version bump
24 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
-fuse-2.6.0_pre2.ebuild, fuse-2.6.0_rc1.ebuild, -fuse-2.6.0_rc3.ebuild,
diff --git a/sys-fs/fuse/files/digest-fuse-2.6.1 b/sys-fs/fuse/files/digest-fuse-2.6.1
new file mode 100644
index 000000000000..1ef700c6df42
--- /dev/null
+++ b/sys-fs/fuse/files/digest-fuse-2.6.1
@@ -0,0 +1,3 @@
+MD5 13e1873086a1d7a95f470bbc7428c528 fuse-2.6.1.tar.gz 472606
+RMD160 99624de23edb634b5e92c86fb75fa266aeff5a65 fuse-2.6.1.tar.gz 472606
+SHA256 e5d039f1adcb5fcc16f5f3eb1c7d95918b62ace79f75d327c72707cafdd8be7c fuse-2.6.1.tar.gz 472606
diff --git a/sys-fs/fuse/fuse-2.6.1.ebuild b/sys-fs/fuse/fuse-2.6.1.ebuild
new file mode 100644
index 000000000000..f0fb5008ea17
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.6.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.1.ebuild,v 1.1 2006/12/01 23:10:54 genstef Exp $
+
+inherit linux-mod eutils libtool
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+MODULE_NAMES="fuse(fs:${S}/kernel)"
+CONFIG_CHECK="@FUSE_FS:fuse"
+BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
+BUILD_TARGETS="all"
+ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
+FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+We will continue, but we wont build the module this time."
+
+pkg_setup() {
+ use kernel_linux && linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --disable-kernel-module \
+ --disable-example \
+ || die "econf failed for fuse userland"
+ emake || die "emake failed"
+
+ if use kernel_linux ; then
+ cd "${S}"
+ sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
+ convert_to_m kernel/Makefile.in
+ linux-mod_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README README-2.4 \
+ README.NFS NEWS doc/how-fuse-works
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux ; then
+ linux-mod_src_install
+ else
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ fi
+
+ rm -f "${D}/dev"
+}
+
+pkg_postinst() {
+ use kernel_linux && linux-mod_pkg_postinst
+}