summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-11-17 06:46:09 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-11-17 06:46:09 +0000
commit00dd5bc996ac5c4a63bc3321aaece83db107e7f7 (patch)
treecc7d2fd9e9fc007d404b7317871354820a6c65fc /sys-kernel/cell-sources/cell-sources-2.6.19_rc6-r1.ebuild
parentAdded ~amd64 keyword, bug #153514 (diff)
downloadgentoo-2-00dd5bc996ac5c4a63bc3321aaece83db107e7f7.tar.gz
gentoo-2-00dd5bc996ac5c4a63bc3321aaece83db107e7f7.tar.bz2
gentoo-2-00dd5bc996ac5c4a63bc3321aaece83db107e7f7.zip
Updated Cell support (Ps3 and Toshiba)
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'sys-kernel/cell-sources/cell-sources-2.6.19_rc6-r1.ebuild')
-rw-r--r--sys-kernel/cell-sources/cell-sources-2.6.19_rc6-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/cell-sources/cell-sources-2.6.19_rc6-r1.ebuild b/sys-kernel/cell-sources/cell-sources-2.6.19_rc6-r1.ebuild
new file mode 100644
index 000000000000..8bbe6b0e23c0
--- /dev/null
+++ b/sys-kernel/cell-sources/cell-sources-2.6.19_rc6-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/cell-sources/cell-sources-2.6.19_rc6-r1.ebuild,v 1.1 2006/11/17 06:46:09 lu_zero Exp $
+
+ETYPE="sources"
+IUSE=""
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+KEYWORDS="~ppc ~ppc64"
+HOMEPAGE="http://kernel.org/pub/linux/kernel/people/arnd/patches/"
+
+DESCRIPTION="Full sources including the arnd patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+
+ARND_VER="${PV/_/-}-arnd${PR//r}"
+
+CELLPATCHES_URI="http://kernel.org/pub/linux/kernel/people/arnd/patches/${ARND_VER}/${ARND_VER}.diff.bz2"
+
+SRC_URI="${KERNEL_URI} ${ARCH_URI} ${CELLPATCHES_URI}"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ cd ${S}
+ epatch ${DISTDIR}/${ARND_VER}.diff.bz2
+}
+
+pkg_postinst() {
+ postinst_sources
+
+ echo
+
+ if [ "${ARCH}" = "sparc" ]; then
+ if [ x"`cat /proc/openprom/name 2>/dev/null`" \
+ = x"'SUNW,Ultra-1'" ]; then
+ einfo "For users with an Enterprise model Ultra 1 using the HME"
+ einfo "network interface, please emerge the kernel using the"
+ einfo "following command: USE=ultra1 emerge ${PN}"
+ fi
+ fi
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}