summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-08-31 16:22:31 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-08-31 16:22:31 +0000
commit811f3763fcd15c63075d6447d211d7e31672ba76 (patch)
tree2f36585705b2175daef89b1981bd05488247c296 /sys-kernel/ck-sources
parentRevision bump for new genpatches. (diff)
downloadgentoo-2-811f3763fcd15c63075d6447d211d7e31672ba76.tar.gz
gentoo-2-811f3763fcd15c63075d6447d211d7e31672ba76.tar.bz2
gentoo-2-811f3763fcd15c63075d6447d211d7e31672ba76.zip
Revision bump for new genpatches.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog8
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.34-r3.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index d6c38e6cef55..d4f7e3dd2a46 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.179 2010/08/31 11:37:26 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.180 2010/08/31 16:22:31 nelchael Exp $
+
+*ck-sources-2.6.34-r3 (31 Aug 2010)
+
+ 31 Aug 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +ck-sources-2.6.34-r3.ebuild:
+ Revision bump for new genpatches.
*ck-sources-2.6.35-r2 (31 Aug 2010)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.34-r3.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.34-r3.ebuild
new file mode 100644
index 000000000000..146416555ef8
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.34-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.34-r3.ebuild,v 1.1 2010/08/31 16:22:31 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+CK_REVISION="1"
+K_SECURITY_UNSUPPORTED="1"
+
+if [[ -z "${CK_REVISION}" ]]; then
+ CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+else
+ # This is ck${CK_VERSION} but resynced to apply cleanly to stable kernel
+ # release:
+ CK_URI="mirror://gentoo/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+ UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}-r${CK_REVISION}.bz2"
+fi
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}