summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-05-02 13:14:43 +0000
committerBen de Groot <yngwin@gentoo.org>2015-05-02 13:14:43 +0000
commite03de2e8a5a1bde45d2bf8f77114f21e13e79d9c (patch)
treee0336f459ad904aa9f389c23a87dd13be9cd5e8b /sys-kernel/ck-sources
parentEAPI bump. Use bumped Debian patch level in PV. Clean up patches. (diff)
downloadgentoo-2-e03de2e8a5a1bde45d2bf8f77114f21e13e79d9c.tar.gz
gentoo-2-e03de2e8a5a1bde45d2bf8f77114f21e13e79d9c.tar.bz2
gentoo-2-e03de2e8a5a1bde45d2bf8f77114f21e13e79d9c.zip
Linux patch 4.0.1
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog7
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.0.1.ebuild105
2 files changed, 111 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 85f715ab3157..9b3ab3ebd877 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.245 2015/04/19 14:41:15 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.246 2015/05/02 13:14:43 yngwin Exp $
+
+*ck-sources-4.0.1 (02 May 2015)
+
+ 02 May 2015; Ben de Groot <yngwin@gentoo.org> +ck-sources-4.0.1.ebuild:
+ Linux patch 4.0.1
19 Apr 2015; Ben de Groot <yngwin@gentoo.org> metadata.xml:
Take over maintainership, since proxied maintainers no longer wish to do so.
diff --git a/sys-kernel/ck-sources/ck-sources-4.0.1.ebuild b/sys-kernel/ck-sources/ck-sources-4.0.1.ebuild
new file mode 100644
index 000000000000..439864b125ee
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-4.0.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-4.0.1.ebuild,v 1.1 2015/05/02 13:14:43 yngwin Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+IUSE="bfsonly"
+
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_EXP_GENPATCHES_PULL="1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_GENPATCHES_VER="2"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with Con Kolivas' high performance patchset and Gentoo's genpatches"
+
+#-- If Gentoo-Sources don't follow then extra incremental patches are needed -
+
+XTRA_INCP_MIN=""
+XTRA_INCP_MAX=""
+
+#--
+
+CK_VERSION="1"
+BFS_VERSION="462"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.bz2"
+BFS_FILE="${K_BRANCH_ID}-sched-bfs-${BFS_VERSION}.patch"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/4.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+BFS_URI="${CK_LVER_URL}/patches/${BFS_FILE}"
+
+#-- Build extra incremental patches list --------------------------------------
+
+LX_INCP_URI=""
+LX_INCP_LIST=""
+if [ -n "${XTRA_INCP_MIN}" ]; then
+ LX_INCP_URL="${KERNEL_BASE_URI}/incr"
+ for i in `seq ${XTRA_INCP_MIN} ${XTRA_INCP_MAX}`; do
+ LX_INCP[i]="patch-${K_BRANCH_ID}.${i}-$(($i+1)).bz2"
+ LX_INCP_URI="${LX_INCP_URI} ${LX_INCP_URL}/${LX_INCP[i]}"
+ LX_INCP_LIST="${LX_INCP_LIST} ${DISTDIR}/${LX_INCP[i]}"
+ done
+fi
+
+#-- CK needs sometimes to patch itself... (3.7/3.13)---------------------------
+
+CK_INCP_URI=""
+CK_INCP_LIST=""
+
+#-- Local patches needed for the ck-patches to apply smoothly (3.4/3.5) -------
+
+PRE_CK_FIX=""
+POST_CK_FIX=""
+
+#--
+
+SRC_URI="${KERNEL_URI} ${LX_INCP_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_INCP_URI}
+ !bfsonly? ( ${CK_URI} )
+ bfsonly? ( ${BFS_URI} )"
+
+UNIPATCH_LIST="${LX_INCP_LIST} ${PRE_CK_FIX} ${DISTDIR}"
+
+if ! use bfsonly ; then
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${CK_FILE}"
+else
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${BFS_FILE}"
+fi
+
+UNIPATCH_LIST="${UNIPATCH_LIST} ${CK_INCP_LIST} ${POST_CK_FIX}"
+
+UNIPATCH_STRICTORDER="yes"
+
+#-- Since experimental genpatches && we want BFQ irrespective of experimental -
+
+K_EXP_GENPATCHES_LIST="50*_*.patch*"
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+
+ kernel-2_pkg_postinst
+
+ elog
+ elog "For more info on this patchset, see: http://forums.gentoo.org/viewtopic-t-941030-start-0.html"
+ elog
+}