summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-04-18 13:37:10 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-04-18 13:37:10 +0000
commit7d5d8db8639b6d2029a7708902c4aa7c5a8a00a5 (patch)
treedbbb6adb3969947801c307542dd8c49a0a391d8e /sys-kernel/dracut
parentfix #399011, version bump (diff)
downloadgentoo-2-7d5d8db8639b6d2029a7708902c4aa7c5a8a00a5.tar.gz
gentoo-2-7d5d8db8639b6d2029a7708902c4aa7c5a8a00a5.tar.bz2
gentoo-2-7d5d8db8639b6d2029a7708902c4aa7c5a8a00a5.zip
Rev-bump. Fixes bug #465518.
Thanks to Enrico Tagliavini <enrico.tagliavini@gmail.com> for report and handling it and to Harald Hoyer for fixing it. (Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'sys-kernel/dracut')
-rw-r--r--sys-kernel/dracut/ChangeLog13
-rw-r--r--sys-kernel/dracut/dracut-027-r1.ebuild302
-rw-r--r--sys-kernel/dracut/files/027-0003-Do-not-call-plymouth-with-full-path.patch167
-rw-r--r--sys-kernel/dracut/files/027-0004-plymouth-plymouth-pretrigger.sh-fixup-.patch25
4 files changed, 506 insertions, 1 deletions
diff --git a/sys-kernel/dracut/ChangeLog b/sys-kernel/dracut/ChangeLog
index 03f8ea1caeff..43a929ae7b9c 100644
--- a/sys-kernel/dracut/ChangeLog
+++ b/sys-kernel/dracut/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-kernel/dracut
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.118 2013/04/09 10:09:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.119 2013/04/18 13:37:10 aidecoe Exp $
+
+*dracut-027-r1 (18 Apr 2013)
+
+ 18 Apr 2013; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +files/027-0003-Do-not-call-plymouth-with-full-path.patch,
+ +files/027-0004-plymouth-plymouth-pretrigger.sh-fixup-.patch,
+ +dracut-027-r1.ebuild:
+ Rev-bump. Fixes bug #465518.
+
+ Thanks to Enrico Tagliavini <enrico.tagliavini@gmail.com> for report and
+ handling it and to Harald Hoyer for fixing it.
09 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> dracut-014-r3.ebuild,
dracut-018-r3.ebuild, dracut-019-r6.ebuild, dracut-022-r6.ebuild,
diff --git a/sys-kernel/dracut/dracut-027-r1.ebuild b/sys-kernel/dracut/dracut-027-r1.ebuild
new file mode 100644
index 000000000000..ec8aea37ba3c
--- /dev/null
+++ b/sys-kernel/dracut/dracut-027-r1.ebuild
@@ -0,0 +1,302 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-027-r1.ebuild,v 1.1 2013/04/18 13:37:10 aidecoe Exp $
+
+EAPI=4
+
+inherit bash-completion-r1 eutils linux-info
+
+add_req_use_for() {
+ local dep="$1"; shift
+ local f
+
+ for f in "$@"; do
+ REQUIRED_USE+="${f}? ( ${dep} )
+"
+ done
+}
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="http://dracut.wiki.kernel.org"
+SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+REQUIRED_USE="
+ dracut_modules_bootchart? ( !dracut_modules_systemd )
+ dracut_modules_crypt-gpg? ( dracut_modules_crypt )
+ dracut_modules_crypt-loop? ( dracut_modules_crypt )
+ dracut_modules_livenet? ( dracut_modules_dmsquash-live )
+ "
+COMMON_MODULES="
+ dracut_modules_biosdevname
+ dracut_modules_bootchart
+ dracut_modules_btrfs
+ dracut_modules_caps
+ dracut_modules_crypt-gpg
+ dracut_modules_crypt-loop
+ dracut_modules_gensplash
+ dracut_modules_mdraid
+ dracut_modules_multipath
+ dracut_modules_plymouth
+ dracut_modules_syslog
+ dracut_modules_systemd
+ "
+DM_MODULES="
+ dracut_modules_crypt
+ dracut_modules_dmraid
+ dracut_modules_dmsquash-live
+ dracut_modules_livenet
+ dracut_modules_lvm
+ "
+NETWORK_MODULES="
+ dracut_modules_cifs
+ dracut_modules_iscsi
+ dracut_modules_livenet
+ dracut_modules_nbd
+ dracut_modules_nfs
+ dracut_modules_ssh-client
+ "
+add_req_use_for device-mapper ${DM_MODULES}
+add_req_use_for net ${NETWORK_MODULES}
+IUSE_DRACUT_MODULES="${COMMON_MODULES} ${DM_MODULES} ${NETWORK_MODULES}"
+IUSE="debug device-mapper optimization net selinux ${IUSE_DRACUT_MODULES}"
+
+RESTRICT="test"
+
+CDEPEND="virtual/udev
+ dracut_modules_systemd? ( >=sys-apps/systemd-199 )
+ "
+RDEPEND="${CDEPEND}
+ app-arch/cpio
+ >=app-shells/bash-4.0
+ >=app-shells/dash-0.5.4.11
+ >=sys-apps/baselayout-1.12.14-r1
+ || ( >=sys-apps/module-init-tools-3.8 >sys-apps/kmod-5[tools] )
+ >=sys-apps/sysvinit-2.87-r3
+ >=sys-apps/util-linux-2.21
+ virtual/pkgconfig
+
+ debug? ( dev-util/strace )
+ device-mapper? ( >=sys-fs/lvm2-2.02.33 )
+ net? ( net-misc/curl >=net-misc/dhcp-4.2.4_p2-r1[client] sys-apps/iproute2 )
+ selinux? ( sys-libs/libselinux sys-libs/libsepol )
+ dracut_modules_biosdevname? ( sys-apps/biosdevname )
+ dracut_modules_bootchart? ( app-benchmarks/bootchart2 sys-apps/usleep
+ sys-process/acct )
+ dracut_modules_btrfs? ( sys-fs/btrfs-progs )
+ dracut_modules_caps? ( sys-libs/libcap )
+ dracut_modules_cifs? ( net-fs/cifs-utils )
+ dracut_modules_crypt? ( sys-fs/cryptsetup )
+ dracut_modules_crypt-gpg? ( app-crypt/gnupg )
+ dracut_modules_dmraid? ( sys-fs/dmraid sys-fs/multipath-tools )
+ dracut_modules_gensplash? ( media-gfx/splashutils )
+ dracut_modules_iscsi? ( >=sys-block/open-iscsi-2.0.871.3 )
+ dracut_modules_lvm? ( >=sys-fs/lvm2-2.02.33 )
+ dracut_modules_mdraid? ( sys-fs/mdadm )
+ dracut_modules_multipath? ( sys-fs/multipath-tools )
+ dracut_modules_nbd? ( sys-block/nbd )
+ dracut_modules_nfs? ( net-fs/nfs-utils net-nds/rpcbind )
+ dracut_modules_plymouth? ( >=sys-boot/plymouth-0.8.3-r1 )
+ dracut_modules_ssh-client? ( dev-libs/openssl )
+ dracut_modules_syslog? ( || ( app-admin/syslog-ng app-admin/rsyslog ) )
+ "
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ "
+
+DOCS=( AUTHORS HACKING NEWS README README.generic README.kernel README.modules
+ README.testsuite TODO )
+MY_LIBDIR="/usr/lib"
+
+#
+# Helper functions
+#
+
+# Returns true if any of specified modules is enabled by USE flag and false
+# otherwise.
+# $1 = list of modules (which have corresponding USE flags of the same name)
+any_module() {
+ local m modules=" $@ "
+
+ for m in ${modules}; do
+ ! use $m && modules=${modules/ $m / }
+ done
+
+ shopt -s extglob
+ modules=${modules%%+( )}
+ shopt -u extglob
+
+ [[ ${modules} ]]
+}
+
+# Removes module from modules.d.
+# $1 = module name
+# Module name can be specified without number prefix.
+rm_module() {
+ local force m
+ [[ $1 = -f ]] && force=-f
+
+ for m in $@; do
+ if [[ $m =~ ^[0-9][0-9][^\ ]*$ ]]; then
+ rm ${force} --interactive=never -r "${modules_dir}"/$m
+ else
+ rm ${force} --interactive=never -r "${modules_dir}"/[0-9][0-9]$m
+ fi
+ done
+}
+
+#
+# ebuild functions
+#
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-0000-fix-version-print.patch"
+ epatch "${FILESDIR}/${PV}-0001-dracut-functions.sh-support-for-altern.patch"
+ epatch "${FILESDIR}/${PV}-0002-gentoo.conf-let-udevdir-be-handled-by-.patch"
+ epatch "${FILESDIR}/${PV}-0003-Do-not-call-plymouth-with-full-path.patch"
+ epatch "${FILESDIR}/${PV}-0004-plymouth-plymouth-pretrigger.sh-fixup-.patch"
+
+ if use dracut_modules_systemd; then
+ local systemdutildir="$($(tc-getPKG_CONFIG) systemd \
+ --variable=systemdutildir)"
+ local systemdsystemunitdir="$($(tc-getPKG_CONFIG) systemd \
+ --variable=systemdsystemunitdir)"
+ [[ ${systemdutildir} ]] || die "Couldn't detect systemdutildir"
+ [[ ${systemdsystemunitdir} ]] \
+ || die "Couldn't detect systemdsystemunitdir"
+ einfo "Setting systemdutildir to ${systemdutildir} and ..."
+ sed -e "4asystemdutildir=\"${systemdutildir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ einfo "Setting systemdsystemunitdir to ${systemdsystemunitdir}..."
+ sed -e "5asystemdsystemunitdir=\"${systemdsystemunitdir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ fi
+}
+
+src_configure() {
+ econf --libdir="${MY_LIBDIR}"
+}
+
+src_compile() {
+ emake doc
+
+ if use optimization; then
+ ewarn "Enabling experimental optimization!"
+ tc-export CC
+ emake install/dracut-install
+ fi
+}
+
+src_install() {
+ default
+
+ newbashcomp "${PN}-bash-completion.sh" "${PN}"
+
+ local dracutlibdir="${MY_LIBDIR#/}/dracut"
+
+ echo "DRACUT_VERSION=$PVR" > "${D%/}/${dracutlibdir}/dracut-version.sh"
+
+ insinto "${dracutlibdir}/dracut.conf.d/"
+ newins dracut.conf.d/gentoo.conf.example gentoo.conf
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ dodir /var/lib/dracut/overlay
+
+ dohtml dracut.html
+
+ #
+ # Modules
+ #
+ local module
+ modules_dir="${D%/}/${dracutlibdir}/modules.d"
+
+ # Remove modules not enabled by USE flags
+ for module in ${IUSE_DRACUT_MODULES} ; do
+ ! use ${module} && rm_module -f ${module#dracut_modules_}
+ done
+
+ # Those flags are specific, and even are corresponding to modules, they need
+ # to be declared as regular USE flags.
+ use debug || rm_module 95debug
+ use selinux || rm_module 98selinux
+
+ # Following flags define set of helper modules which are base dependencies
+ # for others and as so have no practical use, so remove these modules.
+ use device-mapper || rm_module 90dm
+ use net || rm_module 40network 45ifcfg 45url-lib
+
+ if use dracut_modules_systemd; then
+ # With systemd following modules do not make sense
+ rm_module 96securityfs 98selinux
+ else
+ # Without systemd following modules do not make sense
+ rm_module 00systemd-bootchart
+ fi
+
+ # Remove S/390 modules which are not tested at all
+ rm_module 80cms 95dasd 95dasd_mod 95zfcp 95znet
+
+ # Remove modules which won't work for sure
+ rm_module 95fcoe # no tools
+ # fips module depends on masked app-crypt/hmaccalc
+ rm_module 01fips 02fips-aesni
+
+ # Remove extra modules which go to future dracut-extras
+ rm_module 05busybox 97masterkey 98ecryptfs 98integrity
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_src_exists; then
+ ewarn ""
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ ewarn ""
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
+
+ # Kernel configuration options descriptions:
+ local desc_DEVTMPFS="Maintain a devtmpfs filesystem to mount at /dev"
+ local desc_BLK_DEV_INITRD="Initial RAM filesystem and RAM disk "\
+"(initramfs/initrd) support"
+
+ local opt desc
+
+ # Generate ERROR_* variables for check_extra_config.
+ for opt in ${CONFIG_CHECK}; do
+ opt=${opt#\~}
+ desc=desc_${opt}
+ eval "local ERROR_${opt}='CONFIG_${opt}: \"${!desc}\"" \
+ "is missing and REQUIRED'"
+ done
+
+ check_extra_config
+ echo
+ else
+ ewarn ""
+ ewarn "Your kernel configuration couldn't be checked. Do you have"
+ ewarn "/usr/src/linux/.config file there? Please check manually if"
+ ewarn "following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn ""
+ fi
+
+ if use dracut_modules_crypt || use dracut_modules_dmraid || use \
+ dracut_modules_mdraid || use dracut_modules_lvm; then
+
+ if ! [[ $(</proc/cmdline) =~ rd.auto[\ =] ]]; then
+ ewarn "Autoassembly of special devices like cryptoLUKS, dmraid, "
+ ewarn "mdraid or lvm is off for default as of >=dracut-024."
+ ewarn "Use rd.auto option to turn it on."
+ fi
+ fi
+}
diff --git a/sys-kernel/dracut/files/027-0003-Do-not-call-plymouth-with-full-path.patch b/sys-kernel/dracut/files/027-0003-Do-not-call-plymouth-with-full-path.patch
new file mode 100644
index 000000000000..55a6630969d8
--- /dev/null
+++ b/sys-kernel/dracut/files/027-0003-Do-not-call-plymouth-with-full-path.patch
@@ -0,0 +1,167 @@
+From d084ce382e70723854f960daa8b0e486ee1ce97f Mon Sep 17 00:00:00 2001
+From: Harald Hoyer <harald@redhat.com>
+Date: Thu, 11 Apr 2013 16:08:26 +0200
+Subject: [PATCH 3/4] Do not call plymouth with full path
+
+---
+ modules.d/50plymouth/module-setup.sh | 2 +-
+ modules.d/50plymouth/plymouth-emergency.sh | 2 +-
+ modules.d/50plymouth/plymouth-newroot.sh | 4 ++--
+ modules.d/50plymouth/plymouth-populate-initrd.sh | 5 ++---
+ modules.d/50plymouth/plymouth-pretrigger.sh | 6 +++---
+ modules.d/90crypt/crypt-lib.sh | 4 ++--
+ modules.d/90dmsquash-live/dmsquash-live-root.sh | 4 ++--
+ modules.d/98systemd/dracut-emergency.sh | 2 +-
+ modules.d/99base/dracut-lib.sh | 4 ++--
+ 9 files changed, 16 insertions(+), 17 deletions(-)
+
+diff --git a/modules.d/50plymouth/module-setup.sh b/modules.d/50plymouth/module-setup.sh
+index f754e24..ae35b11 100755
+--- a/modules.d/50plymouth/module-setup.sh
++++ b/modules.d/50plymouth/module-setup.sh
+@@ -4,7 +4,7 @@
+
+ check() {
+ [[ "$mount_needs" ]] && return 1
+- [[ -x /sbin/plymouthd && -x /bin/plymouth && -x /usr/sbin/plymouth-set-default-theme ]]
++ type -P plymouthd >/dev/null && type -P plymouth >/dev/null
+ }
+
+ depends() {
+diff --git a/modules.d/50plymouth/plymouth-emergency.sh b/modules.d/50plymouth/plymouth-emergency.sh
+index 68955b8..ed0b0ac 100755
+--- a/modules.d/50plymouth/plymouth-emergency.sh
++++ b/modules.d/50plymouth/plymouth-emergency.sh
+@@ -1,4 +1,4 @@
+ #!/bin/sh
+ # -*- mode: shell-script; indent-tabs-mode: nil; sh-basic-offset: 4; -*-
+ # ex: ts=8 sw=4 sts=4 et filetype=sh
+-[ -x /bin/plymouth ] && /bin/plymouth --hide-splash
++plymouth --hide-splash 2>/dev/null || :
+diff --git a/modules.d/50plymouth/plymouth-newroot.sh b/modules.d/50plymouth/plymouth-newroot.sh
+index 2311b47..96cd138 100755
+--- a/modules.d/50plymouth/plymouth-newroot.sh
++++ b/modules.d/50plymouth/plymouth-newroot.sh
+@@ -2,6 +2,6 @@
+ # -*- mode: shell-script; indent-tabs-mode: nil; sh-basic-offset: 4; -*-
+ # ex: ts=8 sw=4 sts=4 et filetype=sh
+
+-if [ -x /bin/plymouth -a -z "$DRACUT_SYSTEMD" ]; then
+- /bin/plymouth --newroot=$NEWROOT
++if type plymouth >/dev/null 2>&1 && [ -z "$DRACUT_SYSTEMD" ]; then
++ plymouth --newroot=$NEWROOT
+ fi
+diff --git a/modules.d/50plymouth/plymouth-populate-initrd.sh b/modules.d/50plymouth/plymouth-populate-initrd.sh
+index 1e2ffe7..6e0f561 100755
+--- a/modules.d/50plymouth/plymouth-populate-initrd.sh
++++ b/modules.d/50plymouth/plymouth-populate-initrd.sh
+@@ -4,15 +4,14 @@
+ PLYMOUTH_LOGO_FILE="/usr/share/pixmaps/system-logo-white.png"
+ PLYMOUTH_THEME=$(plymouth-set-default-theme)
+
+-inst /sbin/plymouthd /bin/plymouthd
+-dracut_install /bin/plymouth \
++dracut_install plymouthd plymouth \
+ "${PLYMOUTH_LOGO_FILE}" \
+ /etc/system-release
+
+ mkdir -m 0755 -p "${initdir}/usr/share/plymouth"
+
+ inst_libdir_file "plymouth/text.so" "plymouth/details.so"
+-
++
+ if [[ $hostonly ]]; then
+ dracut_install \
+ "/usr/share/plymouth/themes/details/details.plymouth" \
+diff --git a/modules.d/50plymouth/plymouth-pretrigger.sh b/modules.d/50plymouth/plymouth-pretrigger.sh
+index 0e3cb02..8087bf6 100755
+--- a/modules.d/50plymouth/plymouth-pretrigger.sh
++++ b/modules.d/50plymouth/plymouth-pretrigger.sh
+@@ -2,7 +2,7 @@
+ # -*- mode: shell-script; indent-tabs-mode: nil; sh-basic-offset: 4; -*-
+ # ex: ts=8 sw=4 sts=4 et filetype=sh
+
+-if [ -x /bin/plymouthd -a -z "$DRACUT_SYSTEMD" ]; then
++if type plymouthd >/dev/null 2>&1 && [-z "$DRACUT_SYSTEMD" ]; then
+ if getargbool 1 plymouth.enable && getargbool 1 rd.plymouth -d -n rd_NO_PLYMOUTH; then
+ # first trigger graphics subsystem
+ udevadm trigger --action=add --attr-match=class=0x030000 >/dev/null 2>&1
+@@ -16,8 +16,8 @@ if [ -x /bin/plymouthd -a -z "$DRACUT_SYSTEMD" ]; then
+ read consoledev rest < /sys/class/tty/console/active
+ consoledev=${consoledev:-tty0}
+ [ -x /lib/udev/console_init -a -e "/dev/$consoledev" ] && /lib/udev/console_init "/dev/$consoledev"
+- [ -x /bin/plymouthd ] && /bin/plymouthd --attach-to-session --pid-file /run/plymouth/pid
+- /bin/plymouth --show-splash 2>&1 | vinfo
++ plymouthd --attach-to-session --pid-file /run/plymouth/pid
++ plymouth --show-splash 2>&1 | vinfo
+ # reset tty after plymouth messed with it
+ [ -x /lib/udev/console_init -a -e "/dev/$consoledev" ] && /lib/udev/console_init "/dev/$consoledev"
+ fi
+diff --git a/modules.d/90crypt/crypt-lib.sh b/modules.d/90crypt/crypt-lib.sh
+index d66ba88..ebe09f8 100755
+--- a/modules.d/90crypt/crypt-lib.sh
++++ b/modules.d/90crypt/crypt-lib.sh
+@@ -47,8 +47,8 @@ ask_for_password() {
+
+ { flock -s 9;
+ # Prompt for password with plymouth, if installed and running.
+- if [ -x /bin/plymouth ] && /bin/plymouth --ping; then
+- /bin/plymouth ask-for-password \
++ if type plymouth >/dev/null 2>&1 && plymouth --ping 2>/dev/null; then
++ plymouth ask-for-password \
+ --prompt "$ply_prompt" --number-of-tries=$ply_tries \
+ --command="$ply_cmd"
+ ret=$?
+diff --git a/modules.d/90dmsquash-live/dmsquash-live-root.sh b/modules.d/90dmsquash-live/dmsquash-live-root.sh
+index a79b0d9..07e41f0 100755
+--- a/modules.d/90dmsquash-live/dmsquash-live-root.sh
++++ b/modules.d/90dmsquash-live/dmsquash-live-root.sh
+@@ -31,7 +31,7 @@ if [ "$fs" = "iso9660" -o "$fs" = "udf" ]; then
+ fi
+ getarg rd.live.check -d check || check=""
+ if [ -n "$check" ]; then
+- [ -x /bin/plymouth ] && /bin/plymouth --hide-splash
++ type plymouth >/dev/null 2>&1 && plymouth --hide-splash
+ if [ -n "$DRACUT_SYSTEMD" ]; then
+ p=$(str_replace "$livedev" "-" '\x2d')
+ systemctl start checkisomd5@${p}.service
+@@ -42,7 +42,7 @@ if [ -n "$check" ]; then
+ die "CD check failed!"
+ exit 1
+ fi
+- [ -x /bin/plymouth ] && /bin/plymouth --show-splash
++ type plymouth >/dev/null 2>&1 && plymouth --show-splash
+ fi
+
+ ln -s $livedev /run/initramfs/livedev
+diff --git a/modules.d/98systemd/dracut-emergency.sh b/modules.d/98systemd/dracut-emergency.sh
+index a0a4b12..8ab045e 100755
+--- a/modules.d/98systemd/dracut-emergency.sh
++++ b/modules.d/98systemd/dracut-emergency.sh
+@@ -10,7 +10,7 @@ type getarg >/dev/null 2>&1 || . /lib/dracut-lib.sh
+
+ source_conf /etc/conf.d
+
+-[ -x /bin/plymouth ] && /bin/plymouth quit
++type plymouth >/dev/null 2>&1 && plymouth quit
+
+ export _rdshell_name="dracut" action="Boot" hook="emergency"
+
+diff --git a/modules.d/99base/dracut-lib.sh b/modules.d/99base/dracut-lib.sh
+index e456b01..b8919f3 100755
+--- a/modules.d/99base/dracut-lib.sh
++++ b/modules.d/99base/dracut-lib.sh
+@@ -952,8 +952,8 @@ emergency_shell()
+ shift 2
+ elif [ "$1" = "--shutdown" ]; then
+ _rdshell_name=$2; action="Shutdown"; hook="shutdown-emergency"
+- if [ -x /bin/plymouth ]; then
+- /bin/plymouth --hide-splash
++ if type plymouth >/dev/null 2>&1; then
++ plymouth --hide-splash
+ elif [ -x /oldroot/bin/plymouth ]; then
+ /oldroot/bin/plymouth --hide-splash
+ fi
+--
+1.8.2.1
+
diff --git a/sys-kernel/dracut/files/027-0004-plymouth-plymouth-pretrigger.sh-fixup-.patch b/sys-kernel/dracut/files/027-0004-plymouth-plymouth-pretrigger.sh-fixup-.patch
new file mode 100644
index 000000000000..52e5b295c524
--- /dev/null
+++ b/sys-kernel/dracut/files/027-0004-plymouth-plymouth-pretrigger.sh-fixup-.patch
@@ -0,0 +1,25 @@
+From 331ebcb5f3530597f49a344c7392c7f330838fdd Mon Sep 17 00:00:00 2001
+From: Harald Hoyer <harald@redhat.com>
+Date: Fri, 12 Apr 2013 15:25:44 +0200
+Subject: [PATCH 4/4] plymouth/plymouth-pretrigger.sh: fixup of ca2c6936
+
+---
+ modules.d/50plymouth/plymouth-pretrigger.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/modules.d/50plymouth/plymouth-pretrigger.sh b/modules.d/50plymouth/plymouth-pretrigger.sh
+index 8087bf6..196f2f9 100755
+--- a/modules.d/50plymouth/plymouth-pretrigger.sh
++++ b/modules.d/50plymouth/plymouth-pretrigger.sh
+@@ -2,7 +2,7 @@
+ # -*- mode: shell-script; indent-tabs-mode: nil; sh-basic-offset: 4; -*-
+ # ex: ts=8 sw=4 sts=4 et filetype=sh
+
+-if type plymouthd >/dev/null 2>&1 && [-z "$DRACUT_SYSTEMD" ]; then
++if type plymouthd >/dev/null 2>&1 && [ -z "$DRACUT_SYSTEMD" ]; then
+ if getargbool 1 plymouth.enable && getargbool 1 rd.plymouth -d -n rd_NO_PLYMOUTH; then
+ # first trigger graphics subsystem
+ udevadm trigger --action=add --attr-match=class=0x030000 >/dev/null 2>&1
+--
+1.8.2.1
+