summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2011-12-24 11:06:46 +0000
committerMike Pagano <mpagano@gentoo.org>2011-12-24 11:06:46 +0000
commit5b413f9505de4b83211756a34b28fbc91b889ea0 (patch)
tree50da6aa2f5d1732fb61c665f7987569d65a837da /sys-kernel/git-sources
parentpam_mount requires mount / util-linux 2.20 or later. (diff)
downloadgentoo-2-5b413f9505de4b83211756a34b28fbc91b889ea0.tar.gz
gentoo-2-5b413f9505de4b83211756a34b28fbc91b889ea0.tar.bz2
gentoo-2-5b413f9505de4b83211756a34b28fbc91b889ea0.zip
Version bump
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/ChangeLog7
-rw-r--r--sys-kernel/git-sources/git-sources-3.2_rc7.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-kernel/git-sources/ChangeLog b/sys-kernel/git-sources/ChangeLog
index 87a441d22c4f..08d8824f2459 100644
--- a/sys-kernel/git-sources/ChangeLog
+++ b/sys-kernel/git-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/git-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1280 2011/12/17 11:27:29 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1281 2011/12/24 11:06:46 mpagano Exp $
+
+*git-sources-3.2_rc7 (24 Dec 2011)
+
+ 24 Dec 2011; Michael Pagano <mpagano@gentoo.org> +git-sources-3.2_rc7.ebuild:
+ Version bump
*git-sources-3.2_rc6 (17 Dec 2011)
diff --git a/sys-kernel/git-sources/git-sources-3.2_rc7.ebuild b/sys-kernel/git-sources/git-sources-3.2_rc7.ebuild
new file mode 100644
index 000000000000..2d1d0058e156
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-3.2_rc7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-3.2_rc7.ebuild,v 1.1 2011/12/24 11:06:46 mpagano Exp $
+
+EAPI="4"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2 git-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git"
+EGIT_COMMIT="v${PV/_/-}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+pkg_postinst() {
+ postinst_sources
+}