summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2004-01-20 02:49:50 +0000
committerBob Johnson <livewire@gentoo.org>2004-01-20 02:49:50 +0000
commit37212aa778df20902f5cf4eef4f85a76591bcf56 (patch)
tree9734406188740572bdc2dd97c00d30d7137cfa94 /sys-kernel/gs-sources
parentver bump (diff)
downloadgentoo-2-37212aa778df20902f5cf4eef4f85a76591bcf56.tar.gz
gentoo-2-37212aa778df20902f5cf4eef4f85a76591bcf56.tar.bz2
gentoo-2-37212aa778df20902f5cf4eef4f85a76591bcf56.zip
bumped to 2.4.25_pre6
Diffstat (limited to 'sys-kernel/gs-sources')
-rw-r--r--sys-kernel/gs-sources/ChangeLog7
-rw-r--r--sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre62
-rw-r--r--sys-kernel/gs-sources/gs-sources-2.4.25_pre6.ebuild56
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-kernel/gs-sources/ChangeLog b/sys-kernel/gs-sources/ChangeLog
index 299683a247f0..07ca2761351a 100644
--- a/sys-kernel/gs-sources/ChangeLog
+++ b/sys-kernel/gs-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/gs-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.30 2004/01/06 19:32:38 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/ChangeLog,v 1.31 2004/01/20 02:49:49 livewire Exp $
+
+*gs-sources-2.4.25_pre6 (19 Jan 2004)
+
+ 19 Jan 2004; <livewire@gentoo.org> gs-sources-2.4.24_pre6.ebuild
+ bump to 2.4.25_pre6
*gs-sources-2.4.23_pre8-r2 (06 Jan 2004)
diff --git a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre6 b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre6
new file mode 100644
index 000000000000..c671b29070d3
--- /dev/null
+++ b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.25_pre6
@@ -0,0 +1,2 @@
+MD5 1e055c42921b2396a559d84df4c3d9aa linux-2.4.24.tar.bz2 29837818
+MD5 e0df5228437aa4ba10587740dd20d9da patches-2.4.25_pre6-gss.tar.bz2 2658619
diff --git a/sys-kernel/gs-sources/gs-sources-2.4.25_pre6.ebuild b/sys-kernel/gs-sources/gs-sources-2.4.25_pre6.ebuild
new file mode 100644
index 000000000000..cf8f7fd47521
--- /dev/null
+++ b/sys-kernel/gs-sources/gs-sources-2.4.25_pre6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.25_pre6.ebuild,v 1.1 2004/01/20 02:49:49 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel
+PROVIDE="virtual/linux-sources virtual/winkernel"
+OKV=2.4.24
+EXTRAVERSION=_pre6-gss
+KV=2.4.25_pre6-gss
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="This kernel stays up to date with current kernel -pres,
+ with recent acpi,evms,win3lin ,futexes,aic79xx,
+ superfreeswan,preempt/ll, and various hw fixes."
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+ cd ${KV} || die
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}