summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-08-21 22:59:47 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-08-21 22:59:47 +0000
commit6daaf4a5b34e345af2b6969ca9842e88cb55e7c4 (patch)
tree8aa0747f5827fcb12a80b0466c47c624a22e7bde /sys-kernel/hppa-sources/hppa-sources-2.4.21_p13.ebuild
parentVersion bump. (diff)
downloadgentoo-2-6daaf4a5b34e345af2b6969ca9842e88cb55e7c4.tar.gz
gentoo-2-6daaf4a5b34e345af2b6969ca9842e88cb55e7c4.tar.bz2
gentoo-2-6daaf4a5b34e345af2b6969ca9842e88cb55e7c4.zip
Version bump.
Diffstat (limited to 'sys-kernel/hppa-sources/hppa-sources-2.4.21_p13.ebuild')
-rw-r--r--sys-kernel/hppa-sources/hppa-sources-2.4.21_p13.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-kernel/hppa-sources/hppa-sources-2.4.21_p13.ebuild b/sys-kernel/hppa-sources/hppa-sources-2.4.21_p13.ebuild
new file mode 100644
index 000000000000..dda7b8c848ad
--- /dev/null
+++ b/sys-kernel/hppa-sources/hppa-sources-2.4.21_p13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hppa-sources/hppa-sources-2.4.21_p13.ebuild,v 1.1 2003/08/21 22:59:36 gmsoft Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+inherit kernel
+OKV="${PV/_p*/}"
+PATCH_LEVEL="${PV/${OKV}_p/}"
+KV=${OKV}-pa${PATCH_LEVEL}
+EXTRAVERSION="-pa${PATCH_LEVEL}"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# stock 2.4.20 kernel sources
+# patches for hppa
+
+PATCH_SET="`seq 7 11` `seq 13 ${PATCH_LEVEL}`"
+PATCH_COUNT="$(( `echo ${PATCH_SET} | wc -w` - 1 ))"
+
+
+DESCRIPTION="Full sources for the Linux kernel with patch for hppa"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://ftp.parisc-linux.org/cvs/linux-2.4/patch-${OKV}-pa`echo ${PATCH_SET} | awk '{ print $1 }'`.diff.gz
+`for i in \`seq 1 ${PATCH_COUNT}\`; do echo http://ftp.parisc-linux.org/cvs/linux-2.4/patch-${OKV}-pa\`echo ${PATCH_SET} | awk \"{ print \\\\\$$i }\"\`-pa\`echo ${PATCH_SET} | awk \"{ print \\\\\$$((i + 1)) }\"\`.gz; done`"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://parisc-linux.org"
+KEYWORDS="hppa -*"
+SLOT="${KV}"
+
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv ${WORKDIR}/linux-${OKV} ${WORKDIR}/linux-${KV}
+ cd ${S}
+
+ einfo Applying ${OKV}-pa`echo ${PATCH_SET} | awk '{ print $1 }'`
+ zcat ${DISTDIR}/patch-${OKV}-pa`echo ${PATCH_SET} | awk '{ print $1 }'`.diff.gz | patch -sp 1
+
+ for i in `seq 1 ${PATCH_COUNT}`
+ do
+ a=`echo ${PATCH_SET} | awk "{ print \\\$$i }"`
+ b=`echo ${PATCH_SET} | awk "{ print \\\$$((i + 1)) }"`
+ einfo Applying patch from ${OKV}-pa${a} to ${OKV}-pa${b}
+ zcat ${DISTDIR}/patch-${OKV}-pa${a}-pa${b}.gz | patch -sp 1
+ done
+
+ einfo Please ignore any "Hunk failed" above error if any
+
+ kernel_universal_unpack
+}