summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-11-03 16:42:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-11-03 16:42:18 +0000
commitda08920fd3c6f2f228b05930fb083eaa5311686c (patch)
treee8c05e8820911699a0860c8f5f2509b159cd1c27 /sys-kernel/mips-sources
parentversion bump as per bug #241866 thanks Craig and Justin (diff)
downloadgentoo-2-da08920fd3c6f2f228b05930fb083eaa5311686c.tar.gz
gentoo-2-da08920fd3c6f2f228b05930fb083eaa5311686c.tar.bz2
gentoo-2-da08920fd3c6f2f228b05930fb083eaa5311686c.zip
whitespace
(Portage version: 2.1.4.5)
Diffstat (limited to 'sys-kernel/mips-sources')
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.6.27.4.ebuild44
1 files changed, 1 insertions, 43 deletions
diff --git a/sys-kernel/mips-sources/mips-sources-2.6.27.4.ebuild b/sys-kernel/mips-sources/mips-sources-2.6.27.4.ebuild
index 3782e12bb719..580ca137f8c8 100644
--- a/sys-kernel/mips-sources/mips-sources-2.6.27.4.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-2.6.27.4.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.27.4.ebuild,v 1.1 2008/10/30 07:53:10 kumba Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.27.4.ebuild,v 1.2 2008/11/03 16:42:18 mr_bones_ Exp $
# INCLUDED:
# 1) linux sources from kernel.org
@@ -12,11 +11,8 @@
# 6) Patch for IP28 Graphics Support (SolidImpact)
# 7) Experimental patches (if needed)
-
#//------------------------------------------------------------------------------
-
-
# Version Data
OKV=${PV/_/-}
GITDATE="20081028" # Date of diff between kernel.org and lmo GIT
@@ -43,7 +39,6 @@ KEYWORDS="-* ~mips"
IUSE="cobalt ip27 ip28 ip30 ip32r10k"
DEPEND=">=sys-devel/gcc-4.1.1"
-
# Version Control Variables
USE_RC="no" # If set to "yes", then attempt to use an RC kernel
USE_PNT="yes" # If set to "yes", then attempt to use a point-release (2.6.x.y)
@@ -64,7 +59,6 @@ SV_IP30="" # DO_IP30 == "no", IP30
SV_IP32="" # DO_IP32 == "no", IP32
SV_CBLT="" # DO_CBLT == "no", Cobalt
-
# If USE_RC == "yes", use a release candidate kernel (2.6.X-rcY)
if [ "${USE_RC}" = "yes" ]; then
KVXY="$(get_version_component_range 1-2)" # Kernel Major/Minor
@@ -88,19 +82,14 @@ if [ "${USE_PNT}" = "yes" ]; then
USE_RC="no"
fi
-
DESCRIPTION="Linux-Mips GIT sources for MIPS-based machines, dated ${GITDATE}"
SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${STABLEVER}.tar.bz2
mirror://gentoo/mipsgit-${F_KV}-${GITDATE}.diff.bz2
mirror://gentoo/${PN}-generic_patches-${GENPATCHVER}.tar.bz2
${PATCHVER}"
-
-
#//------------------------------------------------------------------------------
-
-
# Error/Warning messages
err_only_one_mach_allowed() {
echo -e ""
@@ -147,12 +136,8 @@ err_disabled_mach() {
return 0
}
-
-
#//------------------------------------------------------------------------------
-
-
# Machine Information Messages
#
# If needing to whitespace for formatting in 'einfo', 'ewarn', or 'eerror', use
@@ -264,12 +249,8 @@ show_cobalt_info() {
echo -e ""
}
-
-
#//------------------------------------------------------------------------------
-
-
# Check our USE flags for machine-specific flags and give appropriate warnings/errors.
# Hope the user isn't crazy enough to try using combinations of these flags.
# Only use one machine-specific flag at a time for each type of desired machine-support.
@@ -341,12 +322,8 @@ pkg_setup() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
# Generic Patches - Safe to use globally
do_generic_patches() {
echo -e ""
@@ -368,7 +345,6 @@ do_generic_patches() {
eend
}
-
# NOT safe for production systems
# Use at own risk, do _not_ file bugs on effects of these patches
do_sekrit_patches() {
@@ -387,12 +363,8 @@ do_sekrit_patches() {
# /* EXPERIMENTAL - DO NOT USE IN PRODUCTION KERNELS */
}
-
-
#//------------------------------------------------------------------------------
-
-
# Exclusive Machine Patchsets
# SGI Origin (IP27)
@@ -410,7 +382,6 @@ do_ip28_support() {
epatch ${MIPS_PATCHES}/misc-2.6.27-ip28-solidimpact-gfx.patch
}
-
# SGI Octane 'Speedracer' (IP30)
do_ip30_support() {
echo -e ""
@@ -420,12 +391,8 @@ do_ip30_support() {
epatch ${MIPS_PATCHES}/misc-2.6.22-ioc3-revert_commit_691cd0c.patch
}
-
-
#//------------------------------------------------------------------------------
-
-
# Renames source trees for the few machines that we have separate patches for
rename_source_tree() {
if [ ! -z "${1}" ]; then
@@ -436,12 +403,8 @@ rename_source_tree() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
src_unpack() {
local x
@@ -449,7 +412,6 @@ src_unpack() {
mv ${WORKDIR}/linux-${STABLEVER} ${WORKDIR}/linux-${OKV}-${GITDATE}
cd ${S}
-
# If USE_RC == "yes", use a release candidate kernel (2.6.x-rcy)
# OR
# if USE_PNT == "yes", use a point-release kernel (2.6.x.y)
@@ -459,7 +421,6 @@ src_unpack() {
epatch ${WORKDIR}/patch-${OKV}
fi
-
# Update the vanilla sources with linux-mips GIT changes
echo -e ""
einfo ">>> linux-${OKV} --> linux-${OKV}-${GITDATE} patch ..."
@@ -476,12 +437,10 @@ src_unpack() {
# Patches for experimental use
do_sekrit_patches
-
# All done, resume normal portage work
kernel_universal_unpack
}
-
src_install() {
# Rename the source trees for exclusive machines
local x
@@ -505,5 +464,4 @@ pkg_postinst() {
fi
}
-
#//------------------------------------------------------------------------------