summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-10-26 10:33:11 +0000
committerMichael Imhof <tantive@gentoo.org>2002-10-26 10:33:11 +0000
commit003dd23947886c3373986195d8408ed83c5acac5 (patch)
treee2dcf3f2234c21faee475cb3572e36c9c82bc453 /sys-kernel/mosix-sources
parentbug #4411 (diff)
downloadgentoo-2-003dd23947886c3373986195d8408ed83c5acac5.tar.gz
gentoo-2-003dd23947886c3373986195d8408ed83c5acac5.tar.bz2
gentoo-2-003dd23947886c3373986195d8408ed83c5acac5.zip
Inital release.
Diffstat (limited to 'sys-kernel/mosix-sources')
-rw-r--r--sys-kernel/mosix-sources/ChangeLog9
-rw-r--r--sys-kernel/mosix-sources/files/digest-mosix-sources-2.4.193
-rw-r--r--sys-kernel/mosix-sources/mosix-sources-2.4.19.ebuild110
3 files changed, 122 insertions, 0 deletions
diff --git a/sys-kernel/mosix-sources/ChangeLog b/sys-kernel/mosix-sources/ChangeLog
new file mode 100644
index 000000000000..6da783f1810d
--- /dev/null
+++ b/sys-kernel/mosix-sources/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-kernel/openmosix-sources
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mosix-sources/ChangeLog,v 1.1 2002/10/26 10:33:11 tantive Exp $
+
+*mosix-sources-2.4.19 (26 Oct 2002)
+
+ 26 Oct 2002; Michael Imhof <tantive@gentoo.org>
+ Initial release; Including mosix-2.4.19 patches (MOSKRN-1.8.0).
+ \ No newline at end of file
diff --git a/sys-kernel/mosix-sources/files/digest-mosix-sources-2.4.19 b/sys-kernel/mosix-sources/files/digest-mosix-sources-2.4.19
new file mode 100644
index 000000000000..2d6b07f653b9
--- /dev/null
+++ b/sys-kernel/mosix-sources/files/digest-mosix-sources-2.4.19
@@ -0,0 +1,3 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 006e71fa3963f3f161470a8f5c09ecb2 linux-gentoo-2.4.19-mosix.patch.bz2 236614
+MD5 deeb285ed6754146306564fbdca65ddc linux-gentoo-2.4.19-mosix-gcc3.patch.bz2 362
diff --git a/sys-kernel/mosix-sources/mosix-sources-2.4.19.ebuild b/sys-kernel/mosix-sources/mosix-sources-2.4.19.ebuild
new file mode 100644
index 000000000000..b6cde5c0b7c5
--- /dev/null
+++ b/sys-kernel/mosix-sources/mosix-sources-2.4.19.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mosix-sources/mosix-sources-2.4.19.ebuild,v 1.1 2002/10/26 10:33:11 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.19
+[ "${PR}" == "r0" ] && KV=${OKV}-mosix || KV=${OKV}-mosix-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19, plus:
+# 2.4.19 mosix-2.4.19
+
+DESCRIPTION="Full sources for the Gentoo Mosix Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}-gcc3.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.mosix.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #if the used gcc is gcc3 there is a seperate patch applied.
+ if [ `gcc -dumpversion | cut -d. -f1` == 3 ]; then
+ cat ${DISTDIR}/linux-gentoo-${KV}-gcc3.patch.bz2 | bzip2 -d | patch -p1 || die
+ fi
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig > Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}