summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-11-20 07:43:56 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-11-20 07:43:56 +0000
commit0bdf060df2fb6e113f2470574d8b0c8d68c1d110 (patch)
treec9e7f8f691132e1678638f8687a41c8fdd5d1b58 /sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild
parentminor fix in the r5 patch (diff)
downloadgentoo-2-0bdf060df2fb6e113f2470574d8b0c8d68c1d110.tar.gz
gentoo-2-0bdf060df2fb6e113f2470574d8b0c8d68c1d110.tar.bz2
gentoo-2-0bdf060df2fb6e113f2470574d8b0c8d68c1d110.zip
All version setting for kernels is now handled by ebuilds on an individual basis, there were only about 15 which were doing none of it before, so this way we are consistent, the eclass will now simply utilize the variables as they are set in the kernel ebuilds.
Diffstat (limited to 'sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild')
-rw-r--r--sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild b/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild
index 937875436071..1ac4c6763d4d 100644
--- a/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild
+++ b/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild,v 1.5 2003/03/24 23:34:01 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources-benh/ppc-sources-benh-2.4.20-r7.ebuild,v 1.6 2003/11/20 07:43:38 lostlogic Exp $
IUSE=""
@@ -8,6 +8,12 @@ ETYPE="sources"
inherit kernel
# OKV=original kernel version, KV=patched kernel version. They can be the same.
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+S=${WORKDIR}/linux-${KV}
MY_R=`echo $PR | sed "s:r:ben:g"`
#bad hack for wierd rev number on this patch