summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-11-30 15:18:05 +0000
committerPacho Ramos <pacho@gentoo.org>2011-11-30 15:18:05 +0000
commit0bfcdd3ed2916d4eb7fe9842371123fced31081f (patch)
tree716259d452a272e8aa0397c0cdbf2fdff72ca642 /sys-kernel/tuxonice-sources
parentVersion bump, bug #392317 by José Romildo Malaquias. (diff)
downloadgentoo-2-0bfcdd3ed2916d4eb7fe9842371123fced31081f.tar.gz
gentoo-2-0bfcdd3ed2916d4eb7fe9842371123fced31081f.tar.bz2
gentoo-2-0bfcdd3ed2916d4eb7fe9842371123fced31081f.zip
Version bump.
(Portage version: 2.1.10.38/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog7
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.0.11.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index 358d433e2d85..3c048e58be09 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.126 2011/11/20 16:23:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.127 2011/11/30 15:18:05 pacho Exp $
+
+*tuxonice-sources-3.0.11 (30 Nov 2011)
+
+ 30 Nov 2011; Pacho Ramos <pacho@gentoo.org> +tuxonice-sources-3.0.11.ebuild:
+ Version bump.
*tuxonice-sources-3.0.9 (20 Nov 2011)
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.11.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.11.ebuild
new file mode 100644
index 000000000000..5184f7197677
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.11.ebuild,v 1.1 2011/11/30 15:18:05 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="11"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20111012"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.0"
+
+# Because "current" patches can change without notifying, we need to supply them
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="http://dev.gentoo.org/~pacho/tuxonice/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch"
+ UNIPATCH_LIST="${DISTDIR}/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch.bz2"
+else
+ TUXONICE_SRC="http://www.tuxonice.net/files/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+ UNIPATCH_LIST="${DISTDIR}/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch.bz2"
+fi
+
+TUXONICE_URI="${TUXONICE_SRC}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}