summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-05-24 14:11:20 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-05-24 14:11:20 +0000
commitb9de42a78fbdc8609e3c480dcc55980c86a8a96d (patch)
treeb69f16b61b4232cc89e421a13c303826212893a7 /sys-kernel/tuxonice-sources
parentnet-analyzer/ipac-ng: hardmasked for year now, does not work/build with recen... (diff)
downloadgentoo-2-b9de42a78fbdc8609e3c480dcc55980c86a8a96d.tar.gz
gentoo-2-b9de42a78fbdc8609e3c480dcc55980c86a8a96d.tar.bz2
gentoo-2-b9de42a78fbdc8609e3c480dcc55980c86a8a96d.zip
Revision bump for latest genpatches.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog9
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.37-r2.ebuild48
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.38-r1.ebuild48
3 files changed, 104 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index 440b17de2971..3e19aaec8094 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.117 2011/05/11 19:52:43 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.118 2011/05/24 14:11:20 nelchael Exp $
+
+*tuxonice-sources-2.6.38-r1 (24 May 2011)
+*tuxonice-sources-2.6.37-r2 (24 May 2011)
+
+ 24 May 2011; Krzysztof Pawlik <nelchael@gentoo.org>
+ +tuxonice-sources-2.6.37-r2.ebuild, +tuxonice-sources-2.6.38-r1.ebuild:
+ Revision bump for latest genpatches.
11 May 2011; Christoph Mende <angelos@gentoo.org>
tuxonice-sources-2.6.37.ebuild:
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.37-r2.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.37-r2.ebuild
new file mode 100644
index 000000000000..b8ca1e05cc69
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.37-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.37-r2.ebuild,v 1.1 2011/05/24 14:11:20 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="7"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.2"
+TUXONICE_TARGET="2.6.37"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch_${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+
+TUXONICE_URI="http://www.tuxonice.net/files/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.38-r1.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.38-r1.ebuild
new file mode 100644
index 000000000000..1b67c74045c9
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.38-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.38-r1.ebuild,v 1.1 2011/05/24 14:11:20 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="7"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.2"
+TUXONICE_TARGET="2.6.38"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch_${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+
+TUXONICE_URI="http://www.tuxonice.net/files/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}