summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 18:32:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 18:32:31 +0000
commit2cead03ad70ee3d336d17db72406242e0934afa9 (patch)
tree139a1e3c1adfec5b65def0ceb0c509522d1c883e /sys-kernel/vanilla-sources/vanilla-sources-2.0.39.ebuild
parentInitial ebuild submitted by Josh Glover <josh.glover@tfcci.com> in bug #35871... (diff)
downloadgentoo-2-2cead03ad70ee3d336d17db72406242e0934afa9.tar.gz
gentoo-2-2cead03ad70ee3d336d17db72406242e0934afa9.tar.bz2
gentoo-2-2cead03ad70ee3d336d17db72406242e0934afa9.zip
ver bump
Diffstat (limited to 'sys-kernel/vanilla-sources/vanilla-sources-2.0.39.ebuild')
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-2.0.39.ebuild100
1 files changed, 0 insertions, 100 deletions
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-2.0.39.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-2.0.39.ebuild
deleted file mode 100644
index 4be6b0fe780d..000000000000
--- a/sys-kernel/vanilla-sources/vanilla-sources-2.0.39.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.0.39.ebuild,v 1.11 2004/01/05 19:03:56 scox Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=2.0.39
-KV=2.0.39
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# stock 2.0.39 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="mirror://kernel/linux/kernel/v2.0/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc sparc "
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
- mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
- make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0:0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- cd ${S}
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux ]
- then
- rm -f ${ROOT}usr/src/linux
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
- fi
-}