summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2003-05-30 01:56:16 +0000
committerBryon Roche <kain@gentoo.org>2003-05-30 01:56:16 +0000
commit239e9566d2c78b540eecd1ad6c30e45f3c25b43e (patch)
tree2f1a759566199fdcef06061261eae76af2481481 /sys-kernel
parentppc-headers to fix gcc3.3 stuffs (diff)
downloadgentoo-2-239e9566d2c78b540eecd1ad6c30e45f3c25b43e.tar.gz
gentoo-2-239e9566d2c78b540eecd1ad6c30e45f3c25b43e.tar.bz2
gentoo-2-239e9566d2c78b540eecd1ad6c30e45f3c25b43e.zip
ppc-headers to fix gcc3.3 stuffs
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ppc-headers/ChangeLog9
-rw-r--r--sys-kernel/ppc-headers/Manifest4
-rw-r--r--sys-kernel/ppc-headers/files/digest-ppc-headers-2.4.21-r12
-rw-r--r--sys-kernel/ppc-headers/ppc-headers-2.4.21-r1.ebuild63
4 files changed, 76 insertions, 2 deletions
diff --git a/sys-kernel/ppc-headers/ChangeLog b/sys-kernel/ppc-headers/ChangeLog
new file mode 100644
index 000000000000..4e9dbb18b3bb
--- /dev/null
+++ b/sys-kernel/ppc-headers/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-kernel/ppc-headers
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-headers/ChangeLog,v 1.1 2003/05/30 01:56:10 kain Exp $
+
+*ppc-headers-2.4.21-r1 (29 May 2003)
+
+ 29 May 2003; Kain <kain@gentoo.org> ppc-headers-2.4.21-r1.ebuild:
+ PPC kernel headers for 2.4.21-based kernels
+
diff --git a/sys-kernel/ppc-headers/Manifest b/sys-kernel/ppc-headers/Manifest
index 6b724896a1d6..4f5205e2c61b 100644
--- a/sys-kernel/ppc-headers/Manifest
+++ b/sys-kernel/ppc-headers/Manifest
@@ -1,3 +1,3 @@
-MD5 4f9d440ef99d82516b0a3f0886f85fc9 ppc-headers-2.4.21-r1.ebuild 2049
-MD5 3487177983396096ec7aa9fb3c76c3fc ChangeLog 284
+MD5 a6b59745b7b6afab309763e624ff45d1 ppc-headers-2.4.21-r1.ebuild 2040
+MD5 791c76d40a883712f97008b1932fc3e6 ChangeLog 377
MD5 7e495d102909604f1af87a10949ee8ae files/digest-ppc-headers-2.4.21-r1 142
diff --git a/sys-kernel/ppc-headers/files/digest-ppc-headers-2.4.21-r1 b/sys-kernel/ppc-headers/files/digest-ppc-headers-2.4.21-r1
new file mode 100644
index 000000000000..b836131185a3
--- /dev/null
+++ b/sys-kernel/ppc-headers/files/digest-ppc-headers-2.4.21-r1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 dc45392da067ccc446e324325941112e patches-2.4.21-ppc-r1.tar.bz2 4154442
diff --git a/sys-kernel/ppc-headers/ppc-headers-2.4.21-r1.ebuild b/sys-kernel/ppc-headers/ppc-headers-2.4.21-r1.ebuild
new file mode 100644
index 000000000000..217a42f44b67
--- /dev/null
+++ b/sys-kernel/ppc-headers/ppc-headers-2.4.21-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-headers/ppc-headers-2.4.21-r1.ebuild,v 1.1 2003/05/30 01:56:10 kain Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="headers"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gentoo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Kernel."
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+HOMEPAGE="http://www.gentoo.org/ http://www.kernel.org/"
+LICENSE="GPL-2"
+KEYWORDS="-x86 ~ppc -sparc -alpha -hppa -mips -arm"
+SLOT="${KV}"
+
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+
+ cd ${WORKDIR}/${KV}
+
+ # This is the crypt USE flag, keeps {USAGI/superfreeswan/patch-int/loop-jari}
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8* ;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic patches will be applied"
+ fi
+
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ ewarn "There is no xfs support in this kernel."
+ echo
+ ewarn "If iptables/netfilter behaves abnormally, such as 'Invalid Argument',"
+ ewarn "you will need to re-emerge iptables to restore proper functionality."
+}