summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-10-08 18:22:35 +0000
committerMichael Imhof <tantive@gentoo.org>2002-10-08 18:22:35 +0000
commit30836903230cd149fc33fcfcf66324e670cfd192 (patch)
treeee9db76847bd869bf4a56d7422a942c2d3d60709 /sys-kernel
parentMasking version bumped usermode-sources (diff)
downloadgentoo-2-30836903230cd149fc33fcfcf66324e670cfd192.tar.gz
gentoo-2-30836903230cd149fc33fcfcf66324e670cfd192.tar.bz2
gentoo-2-30836903230cd149fc33fcfcf66324e670cfd192.zip
Version bumped usermode-sources
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r102
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r112
-rw-r--r--sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r122
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r10.ebuild63
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r11.ebuild63
-rw-r--r--sys-kernel/usermode-sources/usermode-sources-2.4.19-r12.ebuild63
6 files changed, 195 insertions, 0 deletions
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r10 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r10
new file mode 100644
index 000000000000..1b63a0a68604
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r10
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 5d2d2c81a40eb16eb51da09f232f410a uml-patch-2.4.19-10.bz2 145006
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r11 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r11
new file mode 100644
index 000000000000..126db4389aa6
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r11
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 43d5ca811c7356ca58fb0e0286a51848 uml-patch-2.4.19-11.bz2 145673
diff --git a/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r12 b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r12
new file mode 100644
index 000000000000..3fce51775545
--- /dev/null
+++ b/sys-kernel/usermode-sources/files/digest-usermode-sources-2.4.19-r12
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 6bb4d66a39b9b85c4fd753a176bbf422 uml-patch-2.4.19-12.bz2 146080
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r10.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r10.ebuild
new file mode 100644
index 000000000000..d4f7421d954f
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r10.ebuild,v 1.1 2002/10/08 18:22:35 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r11.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r11.ebuild
new file mode 100644
index 000000000000..c87ea350ce02
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r11.ebuild,v 1.1 2002/10/08 18:22:35 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+
diff --git a/sys-kernel/usermode-sources/usermode-sources-2.4.19-r12.ebuild b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r12.ebuild
new file mode 100644
index 000000000000..69584fe3cacd
--- /dev/null
+++ b/sys-kernel/usermode-sources/usermode-sources-2.4.19-r12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/usermode-sources/usermode-sources-2.4.19-r12.ebuild,v 1.1 2002/10/08 18:22:35 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+UML_PATCH="uml-patch-${PV}-`echo ${PR}|sed -e 's:r\+:\1:'`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# User mode linux patch
+# http://user-mode-linux.sourceforge.net
+# UML clashes with the current Gentoo patch, so I've ignored it for now.
+
+DESCRIPTION="Full (vanilla) sources for the User Mode Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://uml-pub.ists.dartmouth.edu/uml/${UML_PATCH}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://user-mode-linux.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+#console-tools is needed to solve the loadkeys fiasco.
+#binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-devel/perl"
+RDEPEND=">=sys-libs/ncurses-5.2"
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/${UML_PATCH}.bz2 | patch -d ${S} -p1
+ echo "Preparing for compilation..."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ echo "Nothing to compile. That's up to the user"
+}
+
+src_install() {
+ dodir /usr/src/uml
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src/uml
+ cd ${D}/usr/src/uml
+ ln -sf linux-${KV} linux
+}
+
+