summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-01-26 17:48:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-01-26 17:48:12 +0000
commit39f404accf228ef54429a4d4835afb788b317cc0 (patch)
tree3c895f18b0c8d90bdaf76bea92d89ab797c8f382 /sys-kernel
parentDrop unrecognised --without-tomcrypt from configure call. (diff)
downloadgentoo-2-39f404accf228ef54429a4d4835afb788b317cc0.tar.gz
gentoo-2-39f404accf228ef54429a4d4835afb788b317cc0.tar.bz2
gentoo-2-39f404accf228ef54429a4d4835afb788b317cc0.zip
Version bump
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.7.3.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 8283db43a626..9ac7f0f88172 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.86 2013/01/13 03:14:33 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.87 2013/01/26 17:48:12 hwoarang Exp $
+
+*pf-sources-3.7.3 (26 Jan 2013)
+
+ 26 Jan 2013; Markos Chandras <hwoarang@gentoo.org> +pf-sources-3.7.3.ebuild:
+ Version bump
*pf-sources-3.7.2 (13 Jan 2013)
diff --git a/sys-kernel/pf-sources/pf-sources-3.7.3.ebuild b/sys-kernel/pf-sources/pf-sources-3.7.3.ebuild
new file mode 100644
index 000000000000..012a9f810843
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.7.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.7.3.ebuild,v 1.1 2013/01/26 17:48:12 hwoarang Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and UKSM"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="" # experimental
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog
+ elog "${P} has the following optional runtime dependencies:"
+ elog " sys-apps/tuxonice-userui"
+ elog " provides minimal userspace progress information related to"
+ elog " suspending and resuming process"
+ elog " sys-power/hibernate-script or sys-power/pm-utils"
+ elog " runtime utilites for hibernating and suspending your computer"
+ elog
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."