summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-11-15 19:18:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-11-15 19:18:49 +0000
commit44fb5f3cdc1489580af13399f27a7c8fd3606247 (patch)
tree115efa46fdff973716c91b77488c3d0d8aa3e32a /sys-kernel
parentUpdate postinst message for more recent locations of tex packages, fixing bug... (diff)
downloadgentoo-2-44fb5f3cdc1489580af13399f27a7c8fd3606247.tar.gz
gentoo-2-44fb5f3cdc1489580af13399f27a7c8fd3606247.tar.bz2
gentoo-2-44fb5f3cdc1489580af13399f27a7c8fd3606247.zip
Version bump. Thanks to Eric F. GARIOUD <eric-f.garioud@wanadoo.fr>. Bug #491262
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ck-sources/ChangeLog8
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.4.68.ebuild111
2 files changed, 118 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index ee95d0f034f8..0da0f3ea561b 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.223 2013/07/23 15:46:47 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.224 2013/11/15 19:18:49 hwoarang Exp $
+
+*ck-sources-3.4.68 (15 Nov 2013)
+
+ 15 Nov 2013; Markos Chandras <hwoarang@gentoo.org> +ck-sources-3.4.68.ebuild:
+ Version bump. Thanks to Eric F. GARIOUD <eric-f.garioud@wanadoo.fr>. Bug
+ #491262
*ck-sources-3.4.54 (23 Jul 2013)
*ck-sources-3.9.11 (23 Jul 2013)
diff --git a/sys-kernel/ck-sources/ck-sources-3.4.68.ebuild b/sys-kernel/ck-sources/ck-sources-3.4.68.ebuild
new file mode 100644
index 000000000000..642a7fe77d33
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.4.68.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.4.68.ebuild,v 1.1 2013/11/15 19:18:49 hwoarang Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+IUSE="bfsonly experimental urwlocks"
+
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="49"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with Con Kolivas' high performance patchset and Gentoo's genpatches"
+
+#-- If Gentoo-Sources don't follow then extra incremental patches are needed -
+
+XTRA_INCP_MIN=""
+XTRA_INCP_MAX=""
+
+#--
+
+CK_VERSION="3"
+BFS_VERSION="424"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.bz2"
+BFS_FILE="${K_BRANCH_ID}-sched-bfs-${BFS_VERSION}.patch"
+XPR_1_FILE="bfs${BFS_VERSION}-grq_urwlocks.patch"
+XPR_2_FILE="urw-locks.patch"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/3.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+BFS_URI="${CK_LVER_URL}/patches/${BFS_FILE}"
+XPR_1_URI="${CK_LVER_URL}/patches/${XPR_1_FILE}"
+XPR_2_URI="${CK_LVER_URL}/patches/${XPR_2_FILE}"
+
+#-- Build extra incremental patches list --------------------------------------
+
+LX_INCP_URI=""
+LX_INCP_LIST=""
+if [ -n "${XTRA_INCP_MIN}" ]; then
+ LX_INCP_URL="${KERNEL_BASE_URI}/incr"
+ for i in `seq ${XTRA_INCP_MIN} ${XTRA_INCP_MAX}`; do
+ LX_INCP[i]="patch-${K_BRANCH_ID}.${i}-$(($i+1)).bz2"
+ LX_INCP_URI="${LX_INCP_URI} ${LX_INCP_URL}/${LX_INCP[i]}"
+ LX_INCP_LIST="${LX_INCP_LIST} ${DISTDIR}/${LX_INCP[i]}"
+ done
+fi
+
+#-- CK needs sometimes to patch itself... -------------------------------------
+
+CK_INCP_URI=""
+CK_INCP_LIST=""
+
+#-- Local patches needed for the ck-patches to apply smoothly -----------------
+
+PRE_CK_FIX="${FILESDIR}/${PN}-3.4-3.5-PreCK-Sched_Fix_Race_In_Task_Group-aCOSwt_P4.patch"
+POST_CK_FIX="${FILESDIR}/${PN}-3.4-3.5-PostCK-Sched_Fix_Race_In_Task_Group-aCOSwt_P5.patch ${FILESDIR}/${PN}-3.4.9-calc_load_idle-aCOSwt_P3.patch"
+
+#--
+
+SRC_URI="${KERNEL_URI} ${LX_INCP_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_INCP_URI}
+ !bfsonly? ( ${CK_URI} )
+ bfsonly? ( ${BFS_URI} )
+ experimental? (
+ urwlocks? ( ${XPR_1_URI} ${XPR_2_URI} ) )"
+
+UNIPATCH_LIST="${LX_INCP_LIST} ${PRE_CK_FIX} ${DISTDIR}"
+
+if ! use bfsonly ; then
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${CK_FILE}"
+else
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${BFS_FILE}"
+fi
+
+UNIPATCH_LIST="${UNIPATCH_LIST} ${CK_INCP_LIST} ${POST_CK_FIX}"
+
+if use experimental ; then
+ if use urwlocks ; then
+ UNIPATCH_LIST="${UNIPATCH_LIST} ${DISTDIR}/${XPR_1_FILE} ${DISTDIR}/${XPR_2_FILE}:1"
+ fi
+fi
+
+UNIPATCH_STRICTORDER="yes"
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+
+ kernel-2_pkg_postinst
+
+ elog
+ elog "For more info on this patchset, see: http://forums.gentoo.org/viewtopic-t-941030-start-0.html"
+ elog
+}