summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-21 18:34:59 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-21 18:34:59 +0000
commit6300ab3e74a9a17283e940cc72120b44f6858f5c (patch)
treea94032e65c8ce2b140f1703a5b868f48b65c9f1f /sys-kernel
parentVersion bump wrt #427512 by Pacho Ramos (diff)
downloadgentoo-2-6300ab3e74a9a17283e940cc72120b44f6858f5c.tar.gz
gentoo-2-6300ab3e74a9a17283e940cc72120b44f6858f5c.tar.bz2
gentoo-2-6300ab3e74a9a17283e940cc72120b44f6858f5c.zip
Version bump with support for 3.2, 3.3 and 3.4 kernels. Thanks a lot to people in bug #409379 for keeping an eye on upstream updates.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog11
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.2.21.ebuild38
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.3.8.ebuild38
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.4.5.ebuild38
4 files changed, 124 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index 356fe796b9a1..df6b748ed8b9 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.144 2012/07/08 12:11:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.145 2012/07/21 18:34:59 pacho Exp $
+
+*tuxonice-sources-3.3.8 (21 Jul 2012)
+*tuxonice-sources-3.4.5 (21 Jul 2012)
+*tuxonice-sources-3.2.21 (21 Jul 2012)
+
+ 21 Jul 2012; Pacho Ramos <pacho@gentoo.org> +tuxonice-sources-3.2.21.ebuild,
+ +tuxonice-sources-3.3.8.ebuild, +tuxonice-sources-3.4.5.ebuild:
+ Version bump with support for 3.2, 3.3 and 3.4 kernels. Thanks a lot to people
+ in bug #409379 for keeping an eye on upstream updates.
*tuxonice-sources-3.0.36 (08 Jul 2012)
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.2.21.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.2.21.ebuild
new file mode 100644
index 000000000000..6612be1dce34
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.2.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.2.21.ebuild,v 1.1 2012/07/21 18:34:59 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="16"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20120721"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.2"
+TUXONICE_URI="http://dev.gentoo.org/~pacho/tuxonice/${TUXONICE_SNAPSHOT}-TuxOnIce-for-Linux-${TUXONICE_TARGET}.patch.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SNAPSHOT}-TuxOnIce-for-Linux-${TUXONICE_TARGET}.patch.bz2"
+UNIPATCH_STRICTORDER="yes"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.3.8.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.3.8.ebuild
new file mode 100644
index 000000000000..8096163bafad
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.3.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.3.8.ebuild,v 1.1 2012/07/21 18:34:59 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20120721"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.3"
+TUXONICE_URI="http://dev.gentoo.org/~pacho/tuxonice/${TUXONICE_SNAPSHOT}-TuxOnIce-for-Linux-${TUXONICE_TARGET}.patch.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SNAPSHOT}-TuxOnIce-for-Linux-${TUXONICE_TARGET}.patch.bz2"
+UNIPATCH_STRICTORDER="yes"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.5.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.5.ebuild
new file mode 100644
index 000000000000..1dace6a92496
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.5.ebuild,v 1.1 2012/07/21 18:34:59 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="6"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20120721"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.4"
+TUXONICE_URI="http://dev.gentoo.org/~pacho/tuxonice/${TUXONICE_SNAPSHOT}-TuxOnIce-for-Linux-${TUXONICE_TARGET}.patch.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SNAPSHOT}-TuxOnIce-for-Linux-${TUXONICE_TARGET}.patch.bz2"
+UNIPATCH_STRICTORDER="yes"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"