summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-12-02 00:23:45 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-12-02 00:23:45 +0000
commit728d1ea143dfaa9ab206ff909e68bbbb462006f6 (patch)
treec218f996f7c1bfb02e6d325951a7c9b6a3659124 /sys-kernel
parentDeps and rc3 fixes (diff)
downloadgentoo-2-728d1ea143dfaa9ab206ff909e68bbbb462006f6.tar.gz
gentoo-2-728d1ea143dfaa9ab206ff909e68bbbb462006f6.tar.bz2
gentoo-2-728d1ea143dfaa9ab206ff909e68bbbb462006f6.zip
linux kernel update
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-sources/files/digest-linux-sources-2.4.0_rc10-r410
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.0_rc10-r4.ebuild (renamed from sys-kernel/linux-sources/linux-sources-2.4.0_rc10-r3.ebuild)36
-rw-r--r--sys-kernel/linux/files/digest-linux-2.4.0_rc10-r32
-rw-r--r--sys-kernel/linux/linux-2.4.0_rc10-r4.ebuild (renamed from sys-kernel/linux/linux-2.4.0_rc10-r3.ebuild)34
4 files changed, 62 insertions, 20 deletions
diff --git a/sys-kernel/linux-sources/files/digest-linux-sources-2.4.0_rc10-r4 b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.0_rc10-r4
new file mode 100644
index 000000000000..2a125a0c4164
--- /dev/null
+++ b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.0_rc10-r4
@@ -0,0 +1,10 @@
+MD5 3fb3759c30a51bf230a231815413d433 patch-2.4.0-test10.bz2
+MD5 3878cd9f9f9e45bddb625dd4059e7e32 patch-2.4.0-test9.bz2
+MD5 8f281617879cf79c44561fb8fb90caec linux-2.4.0-test8.tar.bz2
+MD5 d13b07faf36f5c7452c99913ec0b1fe3 linux-2.4.0-test10-reiserfs-3.6.19-patch.gz
+MD5 c16f3df6b5f9e56b146071edfa5ec5d4 lm_sensors-2.5.4.tar.gz
+MD5 039fb223e361d343e8d40c54f0a317e6 i2c-2.5.4.tar.gz
+MD5 b2cf95e1189e63b44e6f7ae7fc27ae19 jfs-0.0.18-patch.tar.gz
+MD5 5d4983ad745464954aa770196167ad06 alsa-driver-0.5.9d.tar.bz2
+MD5 130d1e7bf56eda1a93a831189b4c6420 NVIDIA_kernel-0.9-5.tar.gz
+MD5 3e20d89a759dac0c43f3a39570116e49 lvm_0.9.tar.gz
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.0_rc10-r3.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.0_rc10-r4.ebuild
index 2003e5c37933..077c25bf6e78 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.0_rc10-r3.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.0_rc10-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.0_rc10-r3.ebuild,v 1.1 2000/11/25 03:36:12 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.0_rc10-r4.ebuild,v 1.1 2000/12/02 00:23:45 drobbins Exp $
S=${WORKDIR}/linux
if [ "$PN" = "linux" ]
@@ -12,9 +12,9 @@ else
fi
SRC_URI="
http://www.kernel.org/pub/linux/kernel/v2.4/patch-2.4.0-test10.bz2
-hhttp://www.kernel.org/pub/linux/kernel/v2.4/patch-2.4.0-test9.bz2
-hhttp://www.kernel.org/pub/linux/kernel/v2.4/linux-2.4.0-test8.tar.bz2
-http://devlinux.com/pub/namesys/2.4-beta/linux-2.4.0-test9-reiserfs-3.6.18-patch.gz
+http://www.kernel.org/pub/linux/kernel/v2.4/patch-2.4.0-test9.bz2
+http://www.kernel.org/pub/linux/kernel/v2.4/linux-2.4.0-test8.tar.bz2
+ftp://ftp.reiserfs.org/pub/2.4/linux-2.4.0-test10-reiserfs-3.6.19-patch.gz
http://www.netroedge.com/~lm78/archive/lm_sensors-2.5.4.tar.gz
http://www.netroedge.com/~lm78/archive/i2c-2.5.4.tar.gz
http://oss.software.ibm.com/developerworks/opensource/jfs/project/pub/jfs-0.0.18-patch.tar.gz
@@ -29,6 +29,11 @@ HOMEPAGE="http://www.kernel.org/
http://www.nvidia.com"
src_compile() {
+ #time to do the special symlink tweak
+ readlink /usr/src/linux > ${T}/linuxlink
+ rm /usr/src/linux
+ ( cd /usr/src; ln -s ${S} linux )
+ #symlink tweak in place
cd ${S}/fs/reiserfs/utils
try make
cd ${S}/lm_sensors-2.5.2
@@ -44,24 +49,35 @@ src_compile() {
make NVdriver
cd ${S}/extras/alsa-driver-0.5.9d
try ./configure --with-kernel=${S} --with-isapnp=yes --with-sequencer=yes --with-oss=yes --with-cards=all
- try make
+ #try make
fi
cd ${S}/extras/LVM/0.9
try ./configure --prefix=/
try make
+ #untweak the symlink
+ ( cd /usr/src; rm linux; ln -s `cat ${T}/linuxlink` linux )
}
src_unpack() {
- cd ${WORKDIR}
+ if [ ! -L /usr/src/linux ]
+ then
+ echo '!!!' /usr/src/linux is not a symbolic link.
+ echo '!!!' For ${PF} to compile correctly, /usr/src/linux
+ echo '!!!' needs to be temporarily modified to point to
+ echo '!!!' a temporary build directory. Please rename your
+ echo '!!!' current directory and restart this build process.
+ exit 1
+ fi
+ cd ${WORKDIR}
unpack linux-2.4.0-test8.tar.bz2
- cd ${S}
+ cd ${S}
echo "Applying test9 patch..."
cat ${DISTDIR}/patch-2.4.0-test9.bz2 | bzip2 -d | patch -p1
- echo "Applying ReiserFS patch..."
- gzip -dc ${DISTDIR}/linux-2.4.0-test9-reiserfs-3.6.18-patch.gz | patch -p1
echo "Applying test10 patch..."
cat ${DISTDIR}/patch-2.4.0-test10.bz2 | bzip2 -d | patch -p1
- cd ${S}
+ echo "Applying ReiserFS patch..."
+ gzip -dc ${DISTDIR}/linux-2.4.0-test10-reiserfs-3.6.19-patch.gz | patch -p1
+ cd ${S}
mkdir extras
echo "Applying IBM JFS patch..."
cd extras
diff --git a/sys-kernel/linux/files/digest-linux-2.4.0_rc10-r3 b/sys-kernel/linux/files/digest-linux-2.4.0_rc10-r3
index 222423395ea6..2a125a0c4164 100644
--- a/sys-kernel/linux/files/digest-linux-2.4.0_rc10-r3
+++ b/sys-kernel/linux/files/digest-linux-2.4.0_rc10-r3
@@ -1,7 +1,7 @@
MD5 3fb3759c30a51bf230a231815413d433 patch-2.4.0-test10.bz2
MD5 3878cd9f9f9e45bddb625dd4059e7e32 patch-2.4.0-test9.bz2
MD5 8f281617879cf79c44561fb8fb90caec linux-2.4.0-test8.tar.bz2
-MD5 33f1208d6b07e42937de92b0be14fc99 linux-2.4.0-test9-reiserfs-3.6.18-patch.gz
+MD5 d13b07faf36f5c7452c99913ec0b1fe3 linux-2.4.0-test10-reiserfs-3.6.19-patch.gz
MD5 c16f3df6b5f9e56b146071edfa5ec5d4 lm_sensors-2.5.4.tar.gz
MD5 039fb223e361d343e8d40c54f0a317e6 i2c-2.5.4.tar.gz
MD5 b2cf95e1189e63b44e6f7ae7fc27ae19 jfs-0.0.18-patch.tar.gz
diff --git a/sys-kernel/linux/linux-2.4.0_rc10-r3.ebuild b/sys-kernel/linux/linux-2.4.0_rc10-r4.ebuild
index 46dd581d1246..d8ea33077d65 100644
--- a/sys-kernel/linux/linux-2.4.0_rc10-r3.ebuild
+++ b/sys-kernel/linux/linux-2.4.0_rc10-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux/linux-2.4.0_rc10-r3.ebuild,v 1.2 2000/11/27 14:49:48 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux/linux-2.4.0_rc10-r4.ebuild,v 1.1 2000/12/02 00:23:45 drobbins Exp $
S=${WORKDIR}/linux
if [ "$PN" = "linux" ]
@@ -12,9 +12,9 @@ else
fi
SRC_URI="
http://www.kernel.org/pub/linux/kernel/v2.4/patch-2.4.0-test10.bz2
-hhttp://www.kernel.org/pub/linux/kernel/v2.4/patch-2.4.0-test9.bz2
-hhttp://www.kernel.org/pub/linux/kernel/v2.4/linux-2.4.0-test8.tar.bz2
-http://devlinux.com/pub/namesys/2.4-beta/linux-2.4.0-test9-reiserfs-3.6.18-patch.gz
+http://www.kernel.org/pub/linux/kernel/v2.4/patch-2.4.0-test9.bz2
+http://www.kernel.org/pub/linux/kernel/v2.4/linux-2.4.0-test8.tar.bz2
+ftp://ftp.reiserfs.org/pub/2.4/linux-2.4.0-test10-reiserfs-3.6.19-patch.gz
http://www.netroedge.com/~lm78/archive/lm_sensors-2.5.4.tar.gz
http://www.netroedge.com/~lm78/archive/i2c-2.5.4.tar.gz
http://oss.software.ibm.com/developerworks/opensource/jfs/project/pub/jfs-0.0.18-patch.tar.gz
@@ -29,6 +29,11 @@ HOMEPAGE="http://www.kernel.org/
http://www.nvidia.com"
src_compile() {
+ #time to do the special symlink tweak
+ readlink /usr/src/linux > ${T}/linuxlink
+ rm /usr/src/linux
+ ( cd /usr/src; ln -s ${S} linux )
+ #symlink tweak in place
cd ${S}/fs/reiserfs/utils
try make
cd ${S}/lm_sensors-2.5.2
@@ -49,19 +54,30 @@ src_compile() {
cd ${S}/extras/LVM/0.9
try ./configure --prefix=/
try make
+ #untweak the symlink
+ ( cd /usr/src; rm linux; ln -s `cat ${T}/linuxlink` linux )
}
src_unpack() {
- cd ${WORKDIR}
+ if [ ! -L /usr/src/linux ]
+ then
+ echo '!!!' /usr/src/linux is not a symbolic link.
+ echo '!!!' For ${PF} to compile correctly, /usr/src/linux
+ echo '!!!' needs to be temporarily modified to point to
+ echo '!!!' a temporary build directory. Please rename your
+ echo '!!!' current directory and restart this build process.
+ exit 1
+ fi
+ cd ${WORKDIR}
unpack linux-2.4.0-test8.tar.bz2
- cd ${S}
+ cd ${S}
echo "Applying test9 patch..."
cat ${DISTDIR}/patch-2.4.0-test9.bz2 | bzip2 -d | patch -p1
- echo "Applying ReiserFS patch..."
- gzip -dc ${DISTDIR}/linux-2.4.0-test9-reiserfs-3.6.18-patch.gz | patch -p1
echo "Applying test10 patch..."
cat ${DISTDIR}/patch-2.4.0-test10.bz2 | bzip2 -d | patch -p1
- cd ${S}
+ echo "Applying ReiserFS patch..."
+ gzip -dc ${DISTDIR}/linux-2.4.0-test10-reiserfs-3.6.19-patch.gz | patch -p1
+ cd ${S}
mkdir extras
echo "Applying IBM JFS patch..."
cd extras