summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-06-29 19:29:41 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-06-29 19:29:41 +0000
commit9dbc952b7b9558a3bd8bb85465b70f9446fe9383 (patch)
tree73f9823725e7085c1d06bd63c892e26d4d280996 /sys-kernel
parent*** empty log message *** (diff)
downloadgentoo-2-9dbc952b7b9558a3bd8bb85465b70f9446fe9383.tar.gz
gentoo-2-9dbc952b7b9558a3bd8bb85465b70f9446fe9383.tar.bz2
gentoo-2-9dbc952b7b9558a3bd8bb85465b70f9446fe9383.zip
meep
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-sources/files/digest-linux-sources-2.4.5-r15
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.4.9.ebuild42
2 files changed, 21 insertions, 26 deletions
diff --git a/sys-kernel/linux-sources/files/digest-linux-sources-2.4.5-r1 b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.5-r1
index 47394b20c1df..d134aefe0eb7 100644
--- a/sys-kernel/linux-sources/files/digest-linux-sources-2.4.5-r1
+++ b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.5-r1
@@ -1,8 +1,5 @@
MD5 ff807499928379c4274a307855b9eeeb alsa-driver-0.5.11.tar.bz2
MD5 a9ce06abf3f7155b6c51b36af7060196 bigpatch-2.4.5.diff.bz2
-MD5 5c8144c6543b1900dd9b99dde700d4ae i2c-20010530-gentoo.tar.gz
MD5 a7aff5d9f57055594250f7452b258176 linux-2.4.5-reiserfs-umount-fix.patch
+MD5 1441c7209b77cc3eb5b994f589cf41a3 linux-2.4.5-xfs-20010530-gentoo.diff.gz
MD5 923e94a6a4af9c8265bc1d66906659e4 linux-2.4.5.tar.bz2
-MD5 85be98dae125cb3d9398ba10cb595fc9 lm_sensors-20010530-gentoo.tar.gz
-MD5 1ce6fb607f26dc20d4c77461057acb3c lvm_0.9.1_beta7.tar.gz
-MD5 4ec7264c95d17bb86c3a94f0a12ed11d pcmcia-cs-3.1.25.tar.gz
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.4.9.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.4.9.ebuild
index e8c4228a092b..d0e5e7109ca9 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.4.9.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.4.9.ebuild
@@ -175,14 +175,19 @@ src_unpack() {
cd ${S}
#sometimes we have icky kernel symbols; this seems to get rid of them
try make mrproper
- if [ "${PN}" = "linux" ]
+
+ #linux-sources needs to be fully configured, too. Not just linux
+ if [ "${PN}" != "linux-extras" ]
then
#this is the configuration for the default kernel
try cp ${FILESDIR}/${KV}/config.bootcomp .config
try yes \"\" \| make oldconfig
echo "Ignore any errors from the yes command above."
try make include/linux/version.h
+ try make HOSTCFLAGS=\""${LINUX_HOSTCFLAGS}"\" dep
+ try make symlinks
fi
+
#fix silly permissions in tarball
cd ${WORKDIR}
chown -R 0.0 ${S}
@@ -193,20 +198,18 @@ src_unpack() {
src_compile() {
- if [ ! "${PN}" = "linux-sources" ] ; then
- if [ $PN = "linux-extras" ] ; then
- KS=/usr/src/linux
- else
- KS=${S}
- fi
- if [ "$PN" = "linux" ] ; then
- try make symlinks
- fi
-
- if [ "`use lvm`" ]
+ if [ "${PN}" != "linux-sources" ]
then
- #LVM tools are included in the linux and linux-extras pakcages
- cd ${KS}/extras/LVM/${LVMV}
+ if [ $PN = "linux-extras" ]
+ then
+ KS=/usr/src/linux
+ else
+ KS=${S}
+ fi
+ if [ "`use lvm`" ]
+ then
+ #LVM tools are included in the linux and linux-extras pakcages
+ cd ${KS}/extras/LVM/${LVMV}
# This is needed for linux-extras
if [ -f "Makefile" ] ; then
@@ -237,7 +240,6 @@ src_compile() {
if [ "$PN" == "linux" ]
then
- try make HOSTCFLAGS=\""${LINUX_HOSTCFLAGS}"\" dep
try make HOSTCFLAGS=\""${LINUX_HOSTCFLAGS}"\" bzImage
#LEX=\""flex -l"\" bzImage
try make HOSTCFLAGS=\""${LINUX_HOSTCFLAGS}"\" modules
@@ -378,7 +380,9 @@ src_install() {
echo ">>> Copying sources..."
cp -ax ${S} ${D}/usr/src
fi
-
+ fi
+ if [ "$PN" != "linux-extras" ]
+ then
#don't overwrite existing .config if present
cd ${D}/usr/src/linux-${KV}
if [ -e .config ]
@@ -399,9 +403,3 @@ pkg_postinst() {
cp -a .config.eg .config
fi
}
-
-#pkg_postrm() {
-#
-# rm -f ${ROOT}/usr/src/linux
-# rm -rf ${ROOT}/usr/src/linux-${KV}
-#}