summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-10-26 11:39:33 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-10-26 11:39:33 +0000
commite5537480a315c93a5585318e686fa63b87e3bb44 (patch)
tree38621be111d9af3fb023057fb92c876b1bc9b26f /sys-kernel
parentversion bump (diff)
downloadgentoo-2-e5537480a315c93a5585318e686fa63b87e3bb44.tar.gz
gentoo-2-e5537480a315c93a5585318e686fa63b87e3bb44.tar.bz2
gentoo-2-e5537480a315c93a5585318e686fa63b87e3bb44.zip
version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/development-sources/Manifest2
-rw-r--r--sys-kernel/development-sources/development-sources-2.6.0_beta9.ebuild142
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.6.0_beta92
3 files changed, 145 insertions, 1 deletions
diff --git a/sys-kernel/development-sources/Manifest b/sys-kernel/development-sources/Manifest
index d7a79b969e5c..abdb947d3a1f 100644
--- a/sys-kernel/development-sources/Manifest
+++ b/sys-kernel/development-sources/Manifest
@@ -1,4 +1,4 @@
-MD5 fd51ed408069086c547feaed84757e94 development-sources-2.6.0_beta9.ebuild 4047
+MD5 0af0ada92d1ae6f89202c9a4bd8502d6 development-sources-2.6.0_beta9.ebuild 4045
MD5 604d42c212f50361df9694448b7a3bdb development-sources-2.6.0_beta7-r5.ebuild 3533
MD5 854abf2bdb617fe8c7de18312a60bb85 metadata.xml 442
MD5 06f2893907e8728d6c6891df493dc091 development-sources-2.6.0_beta7-r3.ebuild 3281
diff --git a/sys-kernel/development-sources/development-sources-2.6.0_beta9.ebuild b/sys-kernel/development-sources/development-sources-2.6.0_beta9.ebuild
new file mode 100644
index 000000000000..01f5c053868c
--- /dev/null
+++ b/sys-kernel/development-sources/development-sources-2.6.0_beta9.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.6.0_beta9.ebuild,v 1.1 2003/10/26 11:39:29 jhhudso Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#Original Kernel Version before Patches
+# eg: 2.6.0-test8
+OKV=${PV/_beta/-test}
+OKV=${OKV/-r*//}
+
+#Kernel version after patches
+# eg: 2.6.0-test8-bk1
+KV=${PF/_beta/-test}
+KV=${KV/-r/-bk}
+KV=${KV//${PN}-}
+
+#version of gentoo patchset
+# eg: 2.6.0-test8-r1-patchset-1
+# this gets added on right at the end before it links
+# if you dont want to apply these patches, set GPV=0
+GPV=0.1
+
+S=${WORKDIR}/linux-${OKV}
+ETYPE="sources"
+
+DESCRIPTION="Full sources for the Development Branch of the Linux kernel"
+
+[ ! ${GPV} == 0 ] && GPATCH_URI="mirror://gentoo/distfiles/genpatches-2.6-${GPV}.tar.bz2"
+[ -z ${KV/*-bk*/} ] && PATCH_URI="http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-${KV}.bz2"
+
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2 ${PATCH_URI} ${GPATCH_URI}"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="-* x86 amd64"
+PROVIDE="virtual/linux-sources virtual/alsa"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl
+ sys-devel/make
+ sys-apps/module-init-tools"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ # apply bk pulls
+ if [ -z ${KV/*-bk*/} ]
+ then
+ cd ${S}
+ epatch ${DISTDIR}/patch-${KV}.bz2
+ cd ${WORKDIR}
+ fi
+
+ # apply gentoo patches
+ if [ ! ${GPV} == 0 ]
+ then
+ cd ${S}
+ epatch ${DISTDIR}/genpatches-2.6-${GPV}.tar.bz2
+ KV="${KV}-patchset-${GPV}"
+ cd ${WORKDIR}
+ fi
+
+ # move to appropriate src dir
+ if [ ! ${KV} == ${OKV} ]
+ then
+ mv linux-${OKV} linux-${KV}
+ S=${WORKDIR}/linux-${KV}
+ fi
+
+ cd ${S}
+ unset ARCH
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0:0 *
+ chmod -R a+r-w+X,u+w *
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ [ ! ${GPV} == 0 ] && KV="${KV}-patchset-${GPV}"
+ [ ! -e ${ROOT}usr/src/linux-beta ] && ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+
+ echo
+ ewarn "Please note that ptyfs support has been removed from devfs"
+ ewarn "and you have to compile it in now, or else you will get"
+ ewarn "errors when trying to open a pty. The option is:"
+ ewarn "File systems -> Pseudo filesystems -> /dev/pts filesystem."
+ echo
+ ewarn "Also, note that you must compile in support for"
+ ewarn "input devices (Input device support->Input devices),"
+ ewarn "the virtual terminal (Character Devices->Virtual terminal),"
+ ewarn "vga_console (Graphics Support->Console...->VGA text console)"
+ ewarn "and the vt_console (Character Devices->Support for console...)."
+ ewarn "Otherwise, you will get the dreaded \"Uncompressing the Kernel\""
+ ewarn "error."
+ echo
+ ewarn "PLEASE NOTE THIS IS NOT OFFICIALLY SUPPORTED BY GENTOO."
+ sleep 5
+}
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.6.0_beta9 b/sys-kernel/development-sources/files/digest-development-sources-2.6.0_beta9
new file mode 100644
index 000000000000..49d44ae3090a
--- /dev/null
+++ b/sys-kernel/development-sources/files/digest-development-sources-2.6.0_beta9
@@ -0,0 +1,2 @@
+MD5 52eef08a43aa28689213b8ab5674f73b linux-2.6.0-test9.tar.bz2 33226512
+MD5 6cda84427c9ae066bdafd0e9c86fec4c genpatches-2.6-0.1.tar.bz2 16981