summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-12-27 16:37:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-12-27 16:37:15 +0000
commitece7c9192c24c6ccb75ae34caa351e2b33d38828 (patch)
tree76c4b2d6889bcb96ce4b048f763a41bb64f1e884 /sys-kernel
parentUpdate the live ebuild to use git from now on. (diff)
downloadgentoo-2-ece7c9192c24c6ccb75ae34caa351e2b33d38828.tar.gz
gentoo-2-ece7c9192c24c6ccb75ae34caa351e2b33d38828.tar.bz2
gentoo-2-ece7c9192c24c6ccb75ae34caa351e2b33d38828.zip
Based on vanilla 2.6.36.2 + genpatches-2.6.36-7 + grsecurity-2.2.1-2.6.36.2-201012221906
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.36-r7.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index c3a09ff2a31a..e182f00fcedb 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.373 2010/12/27 16:32:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.374 2010/12/27 16:37:15 blueness Exp $
+
+*hardened-sources-2.6.36-r7 (27 Dec 2010)
+
+ 27 Dec 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.36-r7.ebuild:
+ Based on vanilla 2.6.36.2 + genpatches-2.6.36-7 +
+ grsecurity-2.2.1-2.6.36.2-201012221906
*hardened-sources-2.6.32-r32 (27 Dec 2010)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.36-r7.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.36-r7.ebuild
new file mode 100644
index 000000000000..fc3843172048
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.36-r7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.36-r7.ebuild,v 1.1 2010/12/27 16:37:15 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="7"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-8"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}