summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-24 20:09:06 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-24 20:09:06 +0000
commitfa20ffdbda19303eceaeeb1faaf67274f95963e0 (patch)
tree9df43b177eee27f1cf795a7cfb4cb613827201a1 /sys-kernel
parentRemove old. (diff)
downloadgentoo-2-fa20ffdbda19303eceaeeb1faaf67274f95963e0.tar.gz
gentoo-2-fa20ffdbda19303eceaeeb1faaf67274f95963e0.tar.bz2
gentoo-2-fa20ffdbda19303eceaeeb1faaf67274f95963e0.zip
sys-kernel/aufs-sources: Version Bump
(Portage version: 2.2.0_alpha160/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/aufs-sources/ChangeLog7
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.7.4.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-kernel/aufs-sources/ChangeLog b/sys-kernel/aufs-sources/ChangeLog
index 471ae1497536..634365a171fa 100644
--- a/sys-kernel/aufs-sources/ChangeLog
+++ b/sys-kernel/aufs-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/aufs-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.12 2013/01/18 12:06:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.13 2013/01/24 20:09:06 jlec Exp $
+
+*aufs-sources-3.7.4 (24 Jan 2013)
+
+ 24 Jan 2013; Justin Lecher <jlec@gentoo.org> +aufs-sources-3.7.4.ebuild:
+ Version Bump
*aufs-sources-3.7.3 (18 Jan 2013)
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.7.4.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.7.4.ebuild
new file mode 100644
index 000000000000..96acf90be3e3
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.7.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.7.4.ebuild,v 1.1 2013/01/24 20:09:06 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="6"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+AUFS_VERSION=3.7.3
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git aufs3.7 > ${AUFS_TARBALL}
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob module proc"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${AUFS_URI}"
+
+UNIPATCH_LIST="
+ "${WORKDIR}"/aufs3-kbuild.patch
+ "${WORKDIR}"/aufs3-base.patch"
+
+PDEPEND=">=sys-fs/aufs-util-3.7"
+
+src_unpack() {
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+ use proc && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-proc.patch"
+ unpack ${AUFS_TARBALL}
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ if ! use proc; then
+ sed '/config AUFS_PROC_MAP/,/^$/d' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -i "${WORKDIR}"/include/linux/aufs_type.h include/linux/aufs_type.h || die
+ cp -i "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -ri "${WORKDIR}"/{Documentation,fs} . || die
+ sed -i "s:__user::g" include/uapi/linux/aufs_type.h || die
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ if ! has_version sys-fs/aufs-util; then
+ einfo "In order to use aufs FS you need to install sys-fs/aufs-util"
+ fi
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}