summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-28 16:58:01 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-28 16:58:01 +0000
commitfa6cca0f3ce6707fee1db0d2b5299b81e0fab092 (patch)
treea6c1609e8a06a0f6b55f7243ffba6c5374a906eb /sys-kernel
parentBased on 3.2.18 + genpatches-3.2-14 + grsecurity-2.9-3.2.18-201205271952 (diff)
downloadgentoo-2-fa6cca0f3ce6707fee1db0d2b5299b81e0fab092.tar.gz
gentoo-2-fa6cca0f3ce6707fee1db0d2b5299b81e0fab092.tar.bz2
gentoo-2-fa6cca0f3ce6707fee1db0d2b5299b81e0fab092.zip
Based on 3.3.7 + genpatches-3.3-8 + grsecurity-2.9-3.3.7-201205271953
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.3.7.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 5c61a4f2e6c8..cb6de899405a 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.591 2012/05/28 16:55:15 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.592 2012/05/28 16:58:01 blueness Exp $
+
+*hardened-sources-3.3.7 (28 May 2012)
+
+ 28 May 2012; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.3.7.ebuild:
+ Based on 3.3.7 + genpatches-3.3-8 + grsecurity-2.9-3.3.7-201205271953
*hardened-sources-3.2.18 (28 May 2012)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.3.7.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.3.7.ebuild
new file mode 100644
index 000000000000..d0d323aab3ee
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.3.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.3.7.ebuild,v 1.1 2012/05/28 16:58:01 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="8"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="1800_nohz-load-acct-fix.patch 4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.9"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]. Those who intend to"
+ ewarn "use one of these predefined grsecurity levels should read the help"
+ ewarn "associated with the level. Because some options require >=gcc-4.5,"
+ ewarn "users with more, than one version of gcc installed should use gcc-config"
+ ewarn "to select a compatible version."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}*"
+ ewarn
+}