summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-17 09:47:05 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-17 09:47:05 +0000
commit387bb40b256be0323eca86b4e69af3a464b66b8b (patch)
treea1918b3ea250055a181a1a2c26aaa4bee1bf166c /sys-libs/cracklib/cracklib-2.9.1.ebuild
parentAdd missing dependency on x11-libs/libXcomposite (diff)
downloadgentoo-2-387bb40b256be0323eca86b4e69af3a464b66b8b.tar.gz
gentoo-2-387bb40b256be0323eca86b4e69af3a464b66b8b.tar.bz2
gentoo-2-387bb40b256be0323eca86b4e69af3a464b66b8b.zip
Version bump, migrate to distutils-r1.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-libs/cracklib/cracklib-2.9.1.ebuild')
-rw-r--r--sys-libs/cracklib/cracklib-2.9.1.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/sys-libs/cracklib/cracklib-2.9.1.ebuild b/sys-libs/cracklib/cracklib-2.9.1.ebuild
new file mode 100644
index 000000000000..6d17913e7c05
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.9.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.9.1.ebuild,v 1.1 2013/12/17 09:47:05 radhermit Exp $
+
+EAPI="4"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils distutils-r1 libtool toolchain-funcs
+
+MY_P=${P/_}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="http://sourceforge.net/projects/cracklib"
+SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="nls python static-libs test zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+do_python() {
+ use python || return 0
+ pushd python > /dev/null || die
+ distutils-r1_src_${EBUILD_PHASE}
+ popd > /dev/null
+}
+
+pkg_setup() {
+ # workaround #195017
+ if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
+ eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
+ eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ fi
+}
+
+src_prepare() {
+ elibtoolize #269003
+ do_python
+}
+
+src_configure() {
+ export ac_cv_header_zlib_h=$(usex zlib)
+ export ac_cv_search_gzopen=$(usex zlib -lz no)
+ econf \
+ --with-default-dict='$(libdir)/cracklib_dict' \
+ --without-python \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ do_python
+}
+
+src_test() {
+ do_python
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}"/usr -name libcrack.la -delete
+ rm -r "${ED}"/usr/share/cracklib
+
+ do_python
+
+ # move shared libs to /
+ gen_usr_ldscript -a crack
+
+ insinto /usr/share/dict
+ doins dicts/cracklib-small || die
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
+ eend $?
+ fi
+}