summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-29 22:34:23 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-29 22:34:23 +0000
commite33401cf68f099d00fa321838df223a4fd2e5b71 (patch)
tree0bf7d2aea72edf6a3ddf5507c8474c7d456e33bb /sys-libs/cracklib
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-e33401cf68f099d00fa321838df223a4fd2e5b71.tar.gz
gentoo-2-e33401cf68f099d00fa321838df223a4fd2e5b71.tar.bz2
gentoo-2-e33401cf68f099d00fa321838df223a4fd2e5b71.zip
old
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/cracklib-2.8.15.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/sys-libs/cracklib/cracklib-2.8.15.ebuild b/sys-libs/cracklib/cracklib-2.8.15.ebuild
deleted file mode 100644
index 678f8352cc40..000000000000
--- a/sys-libs/cracklib/cracklib-2.8.15.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.8.15.ebuild,v 1.10 2010/06/05 20:46:31 vapier Exp $
-
-inherit eutils toolchain-funcs multilib libtool
-
-MY_P=${P/_}
-DESCRIPTION="Password Checking Library"
-HOMEPAGE="http://sourceforge.net/projects/cracklib"
-SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls python"
-
-DEPEND="python? ( <dev-lang/python-3 )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- # workaround #195017
- if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
- eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
- eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.8.13-python-linkage.patch #246747
- epatch "${FILESDIR}"/${P}-no-nls.patch
- sed -i '/PYTHON/s:\(print\) \([^"]*\):\1(\2):' configure #302908
- elibtoolize #269003
-}
-
-src_compile() {
- econf \
- --with-default-dict='$(libdir)/cracklib_dict' \
- $(use_enable nls) \
- $(use_with python) \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- rm -r "${D}"/usr/share/cracklib
-
- # move shared libs to /
- gen_usr_ldscript -a crack
-
- insinto /usr/share/dict
- doins dicts/cracklib-small || die "word dict"
-
- dodoc AUTHORS ChangeLog NEWS README*
-}
-
-pkg_postinst() {
- if [[ ${ROOT} == "/" ]] ; then
- ebegin "Regenerating cracklib dictionary"
- create-cracklib-dict /usr/share/dict/* > /dev/null
- eend $?
- fi
-}