summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-08-15 12:17:11 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-08-15 12:17:11 +0000
commit2588ae4aad77c2da18c8c830d0833302e4755e62 (patch)
tree02f9fe15b6b7c68f36f8b88f20f63ec1ad43fd08 /sys-libs/db
parentAdd sys-libs/db-4.6 to package.mask for now (diff)
downloadgentoo-2-2588ae4aad77c2da18c8c830d0833302e4755e62.tar.gz
gentoo-2-2588ae4aad77c2da18c8c830d0833302e4755e62.tar.bz2
gentoo-2-2588ae4aad77c2da18c8c830d0833302e4755e62.zip
Next major revision of db. package.mask'd for now for further testing
(Portage version: 2.1.3.5)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog10
-rw-r--r--sys-libs/db/db-3.2.9-r10.ebuild4
-rw-r--r--sys-libs/db/db-4.6.18.ebuild145
-rw-r--r--sys-libs/db/files/db-4.6-jarlocation.patch16
-rw-r--r--sys-libs/db/files/db-4.6-jni-check-prefix-first.patch30
-rw-r--r--sys-libs/db/files/db-4.6-libtool.patch47
-rw-r--r--sys-libs/db/files/digest-db-4.6.183
7 files changed, 252 insertions, 3 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 71f21f0738dc..bf9e27d475f4 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.221 2007/08/09 03:02:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.222 2007/08/15 12:17:11 caleb Exp $
+
+*db-4.6.18 (15 Aug 2007)
+
+ 15 Aug 2007; Caleb Tennis <caleb@gentoo.org>
+ +files/db-4.6-jarlocation.patch,
+ +files/db-4.6-jni-check-prefix-first.patch, +files/db-4.6-libtool.patch,
+ +db-4.6.18.ebuild:
+ Next major revision of db. package.mask'd for now for further testing
09 Aug 2007; Jeroen Roovers <jer@gentoo.org> db-4.5.20_p2.ebuild:
Stable for HPPA (bug #178750).
diff --git a/sys-libs/db/db-3.2.9-r10.ebuild b/sys-libs/db/db-3.2.9-r10.ebuild
index 2f5252482089..dfaf99a1cc6f 100644
--- a/sys-libs/db/db-3.2.9-r10.ebuild
+++ b/sys-libs/db/db-3.2.9-r10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.27 2007/07/15 02:08:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.28 2007/08/15 12:17:11 caleb Exp $
inherit gnuconfig libtool eutils db java-pkg
diff --git a/sys-libs/db/db-4.6.18.ebuild b/sys-libs/db/db-4.6.18.ebuild
new file mode 100644
index 000000000000..08600fa18a04
--- /dev/null
+++ b/sys-libs/db/db-4.6.18.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.18.ebuild,v 1.1 2007/08/15 12:17:11 caleb Exp $
+
+inherit eutils db flag-o-matic java-pkg-opt-2
+
+#Number of official patches
+#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+PATCHNO=${PV/*.*.*_p}
+if [[ ${PATCHNO} == "${PV}" ]] ; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S="${WORKDIR}/${MY_P}/build_unix"
+DESCRIPTION="Oracle Berkeley DB"
+HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
+SRC_URI="http://download-west.oracle.com/berkeley-db/${MY_P}.tar.gz"
+for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
+ export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+LICENSE="OracleDB"
+SLOT="4.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="tcl java doc nocxx bootstrap"
+
+DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
+ java? ( >=virtual/jdk-1.4 )
+ >=sys-devel/binutils-2.16.1"
+RDEPEND="tcl? ( dev-lang/tcl )
+ java? ( >=virtual/jre-1.4 )"
+
+src_unpack() {
+ unpack "${MY_P}".tar.gz
+ cd "${WORKDIR}"/"${MY_P}"
+ for (( i=1 ; i<=${PATCHNO} ; i++ ))
+ do
+ epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
+ done
+ epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
+
+ # use the includes from the prefix
+ epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-jni-check-prefix-first.patch
+ epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
+
+ sed -i \
+ -e "s,\(ac_compiler\|\${MAKEFILE_CC}\|\${MAKEFILE_CXX}\|\$CC\)\( *--version\),\1 -dumpversion,g" \
+ "${S}"/../dist/configure
+}
+
+src_compile() {
+ # compilation with -O0 fails on amd64, see bug #171231
+ if use amd64; then
+ replace-flags -O0 -O2
+ is-flag -O[s123] || append-flags -O2
+ fi
+
+ local myconf=""
+
+ use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
+
+ use bootstrap \
+ && myconf="${myconf} --disable-cxx" \
+ || myconf="${myconf} $(use_enable !nocxx cxx)"
+
+ use tcl \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
+ || myconf="${myconf} --disable-tcl"
+
+ myconf="${myconf} $(use_enable java)"
+ if use java; then
+ myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
+ # Can't get this working any other way, since it returns spaces, and
+ # bash doesn't seem to want to pass correctly in any way i try
+ local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
+ fi
+
+ [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
+
+ # the entire testsuite needs the TCL functionality
+ if use tcl && has test $FEATURES ; then
+ myconf="${myconf} --enable-test"
+ else
+ myconf="${myconf} --disable-test"
+ fi
+
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU; then
+ append-ldflags -Wl,--default-symver
+ fi
+
+ cd ${S} && ECONF_SOURCE="${S}"/../dist econf \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libdir=/usr/"$(get_libdir)" \
+ --enable-compat185 \
+ --without-uniquename \
+ --enable-rpc \
+ --host="${CHOST}" \
+ ${myconf} "${javaconf}" || die "configure failed"
+
+ sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
+ && mv Makefile.cpy Makefile
+
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ einstall libdir="${D}/usr/$(get_libdir)" STRIP="none" || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+
+ dodir /usr/sbin
+ mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db46_svc
+
+ if use java; then
+ java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
+ java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
+ rm -f "${D}"/usr/"$(get_libdir)"/*.jar
+ fi
+}
+
+pkg_postinst() {
+ db_fix_so
+}
+
+pkg_postrm() {
+ db_fix_so
+}
diff --git a/sys-libs/db/files/db-4.6-jarlocation.patch b/sys-libs/db/files/db-4.6-jarlocation.patch
new file mode 100644
index 000000000000..c0d689f43691
--- /dev/null
+++ b/sys-libs/db/files/db-4.6-jarlocation.patch
@@ -0,0 +1,16 @@
+diff -ur db-4.1.25.old/dist/Makefile.in db-4.1.25/dist/Makefile.in
+--- db-4.1.25.old/dist/Makefile.in 2003-10-18 02:15:45.000000000 -0700
++++ db-4.1.25/dist/Makefile.in 2003-10-18 02:13:47.000000000 -0700
+@@ -107,9 +107,9 @@
+ JAVA_EXDIR= $(JAVA_SRCDIR)/$(JAVA_EXREL)
+ JAVA_RPCDIR= $(srcdir)/rpc_server/java
+
+-libj_jarfile= db.jar
+-libj_exjarfile= dbexamples.jar
+-rpc_jarfile= dbsvc.jar
++libj_jarfile= db-4.4.jar
++libj_exjarfile= dbexamples-4.4.jar
++rpc_jarfile= dbsvc-4.4.jar
+ libjso_base= libdb_java
+ libjso= $(libjso_base)-$(SOVERSION).@JMODSUFFIX@
+ libjso_static= $(libjso_base)-$(SOVERSION).a
diff --git a/sys-libs/db/files/db-4.6-jni-check-prefix-first.patch b/sys-libs/db/files/db-4.6-jni-check-prefix-first.patch
new file mode 100644
index 000000000000..63735e62469f
--- /dev/null
+++ b/sys-libs/db/files/db-4.6-jni-check-prefix-first.patch
@@ -0,0 +1,30 @@
+--- dist/aclocal_java/ac_jni_include_dirs.m4 2003-10-06 20:41:38.000000000 +0200
++++ dist/aclocal_java/ac_jni_include_dirs.m4 2005-09-23 21:31:26.000000000 +0200
+@@ -43,14 +43,19 @@
+ *) AC_MSG_ERROR([$_ACJNI_JAVAC is not an absolute path name]);;
+ esac
+
+-_ACJNI_FOLLOW_SYMLINKS("$_ACJNI_JAVAC")
+-_JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[[^/]]*$::'`
+-case "$host_os" in
+- darwin*) _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[[^/]]*$::'`
+- _JINC="$_JTOPDIR/Headers";;
+- *) _JINC="$_JTOPDIR/include";;
+-esac
+-
++# If JAVAPREFIX is defined, look there first
++if test -r "$JAVAPREFIX/include/jni.h"; then
++ _JTOPDIR="$JAVAPREFIX"
++ _JINC="$JAVAPREFIX/include"
++else
++ _ACJNI_FOLLOW_SYMLINKS("$_ACJNI_JAVAC")
++ _JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[[^/]]*$::'`
++ case "$host_os" in
++ darwin*) _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[[^/]]*$::'`
++ _JINC="$_JTOPDIR/Headers";;
++ *) _JINC="$_JTOPDIR/include";;
++ esac
++fi
+ # If we find jni.h in /usr/include, then it's not a java-only tree, so
+ # don't add /usr/include or subdirectories to the list of includes.
+ # An extra -I/usr/include can foul things up with newer gcc's.
diff --git a/sys-libs/db/files/db-4.6-libtool.patch b/sys-libs/db/files/db-4.6-libtool.patch
new file mode 100644
index 000000000000..3d86b88f86b3
--- /dev/null
+++ b/sys-libs/db/files/db-4.6-libtool.patch
@@ -0,0 +1,47 @@
+--- dist/configure.orig 2006-01-31 10:23:58.000000000 +0100
++++ dist/configure 2006-01-31 10:26:43.000000000 +0100
+@@ -5765,7 +5765,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ # I'd rather use --version here, but apparently some GNU lds only accept -v.
+-case `$LD -v 2>&1 </dev/null` in
++case `"$LD" -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+ lt_cv_prog_gnu_ld=yes
+ ;;
+@@ -8753,7 +8753,7 @@
+ whole_archive_flag_spec=
+ fi
+ supports_anon_versioning=no
+- case `$LD -v 2>/dev/null` in
++ case `"$LD" -v 2>/dev/null` in
+ *\ [01].* | *\ 2.[0-9].* | *\ 2.10.*) ;; # catch versions < 2.11
+ *\ 2.11.93.0.2\ *) supports_anon_versioning=yes ;; # RH7.3 ...
+ *\ 2.11.92.0.12\ *) supports_anon_versioning=yes ;; # Mandrake 8.2 ...
+@@ -11855,7 +11855,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ # I'd rather use --version here, but apparently some GNU lds only accept -v.
+-case `$LD -v 2>&1 </dev/null` in
++case `"$LD" -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+ lt_cv_prog_gnu_ld=yes
+ ;;
+@@ -15842,7 +15842,7 @@
+ whole_archive_flag_spec_F77=
+ fi
+ supports_anon_versioning=no
+- case `$LD -v 2>/dev/null` in
++ case `"$LD" -v 2>/dev/null` in
+ *\ [01].* | *\ 2.[0-9].* | *\ 2.10.*) ;; # catch versions < 2.11
+ *\ 2.11.93.0.2\ *) supports_anon_versioning=yes ;; # RH7.3 ...
+ *\ 2.11.92.0.12\ *) supports_anon_versioning=yes ;; # Mandrake 8.2 ...
+@@ -18300,7 +18300,7 @@
+ whole_archive_flag_spec_GCJ=
+ fi
+ supports_anon_versioning=no
+- case `$LD -v 2>/dev/null` in
++ case `"$LD" -v 2>/dev/null` in
+ *\ [01].* | *\ 2.[0-9].* | *\ 2.10.*) ;; # catch versions < 2.11
+ *\ 2.11.93.0.2\ *) supports_anon_versioning=yes ;; # RH7.3 ...
+ *\ 2.11.92.0.12\ *) supports_anon_versioning=yes ;; # Mandrake 8.2 ...
diff --git a/sys-libs/db/files/digest-db-4.6.18 b/sys-libs/db/files/digest-db-4.6.18
new file mode 100644
index 000000000000..546b0c4fcc5c
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.6.18
@@ -0,0 +1,3 @@
+MD5 95768bd92fd48951a427fbab37b9088f db-4.6.18.tar.gz 12017762
+RMD160 ea6e6e7d06ab546ce6cbca2091f02566849eaff8 db-4.6.18.tar.gz 12017762
+SHA256 5fc03231ce2d1ac68480fce9821e91d85f132104dc1e16ab7edb6476b2353ef3 db-4.6.18.tar.gz 12017762