summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-10-24 07:07:55 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-10-24 07:07:55 +0000
commitdaec1883e44015ecb95314758a95a31c77ee2562 (patch)
tree462270a0f78efd383313890c2207a4d8e4d1afd7 /sys-libs/db
parentRemoved java gen 1 ebuilds, older versions, and quoted vars (diff)
downloadgentoo-2-daec1883e44015ecb95314758a95a31c77ee2562.tar.gz
gentoo-2-daec1883e44015ecb95314758a95a31c77ee2562.tar.bz2
gentoo-2-daec1883e44015ecb95314758a95a31c77ee2562.zip
Removed java gen 1 ebuild, quoted vars
(Portage version: 2.1.3.15)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog7
-rw-r--r--sys-libs/db/db-1.85-r1.ebuild10
-rw-r--r--sys-libs/db/db-3.2.9-r10.ebuild165
-rw-r--r--sys-libs/db/db-3.2.9-r11.ebuild48
-rw-r--r--sys-libs/db/db-4.4.20_p4.ebuild4
-rw-r--r--sys-libs/db/db-4.5.20_p2.ebuild4
-rw-r--r--sys-libs/db/db-4.6.19.ebuild4
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r103
8 files changed, 41 insertions, 204 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 7c065ae41a92..0c6c6dddf8c0 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.226 2007/09/03 17:07:56 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.227 2007/10/24 07:07:55 wltjr Exp $
+
+ 24 Oct 2007; William L. Thomson Jr. <wltjr@gentoo.org> db-1.85-r1.ebuild,
+ -db-3.2.9-r10.ebuild, db-3.2.9-r11.ebuild, db-4.4.20_p4.ebuild,
+ db-4.5.20_p2.ebuild, db-4.6.19.ebuild:
+ Removed java gen 1 ebuild, quoted vars
03 Sep 2007; Caleb Tennis <caleb@gentoo.org> db-3.2.9-r11.ebuild:
Changing java dep per bug #181832
diff --git a/sys-libs/db/db-1.85-r1.ebuild b/sys-libs/db/db-1.85-r1.ebuild
index f118b79454ea..87612a137fe9 100644
--- a/sys-libs/db/db-1.85-r1.ebuild
+++ b/sys-libs/db/db-1.85-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85-r1.ebuild,v 1.33 2007/08/20 11:40:20 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85-r1.ebuild,v 1.34 2007/10/24 07:07:55 wltjr Exp $
inherit eutils
@@ -20,17 +20,17 @@ S=${WORKDIR}/db.${PV}
src_unpack() {
unpack db.${PV}.tar.gz
- cd ${S}
+ cd "${S}"
epatch ${DISTDIR}/db.${PV}.patch
}
src_compile() {
- cd ${S}/PORT/linux
+ cd "${S}"/PORT/linux
make ${MAKEOPTS} OORG="${CFLAGS} -fomit-frame-pointer" prefix=/usr || die
}
src_install () {
- cd ${S}/PORT/linux
+ cd "${S}"/PORT/linux
newlib.a libdb.a libdb1.a || die "newlib.a failed"
newlib.so libdb.so.2 libdb1.so.2 || die "newlib.so failed"
@@ -49,7 +49,7 @@ src_install () {
dosym db1/ndbm.h /usr/include/ndbm.h
newbin db_dump185 db1_dump185
- cd ${S}
+ cd "${S}"
dodoc changelog README
docinto ps
dodoc docs/*.ps
diff --git a/sys-libs/db/db-3.2.9-r10.ebuild b/sys-libs/db/db-3.2.9-r10.ebuild
deleted file mode 100644
index dfaf99a1cc6f..000000000000
--- a/sys-libs/db/db-3.2.9-r10.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.28 2007/08/15 12:17:11 caleb Exp $
-
-inherit gnuconfig libtool eutils db java-pkg
-
-DESCRIPTION="Berkeley DB for transaction support in MySQL"
-HOMEPAGE="http://www.sleepycat.com/"
-SRC_URI="ftp://ftp.sleepycat.com/releases/${P}.tar.gz"
-
-LICENSE="DB"
-SLOT="3"
-# This ebuild is to be the compatibility ebuild for when db4 is put
-# in the tree.
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="doc java"
-
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- =sys-libs/db-1.85*
- sys-devel/libtool
- sys-devel/m4
- java? ( virtual/jdk )"
-# We need m4 too else build fails without config.guess
-
-# This doesn't build without exceptions
-export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
-
-pkg_setup() {
- use java && java-pkg_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
-
- chmod -R ug+w *
-
- cd ${WORKDIR}/${P}
- epatch ${FILESDIR}/patch.3.2.9.1
- epatch ${FILESDIR}/patch.3.2.9.2
-
- # Get db to link libdb* to correct dependencies ... for example if we use
- # NPTL or NGPT, db detects usable mutexes, and should link against
- # libpthread, but does not do so ...
- # <azarah@gentoo.org> (23 Feb 2003)
- epatch ${FILESDIR}/${P}-fix-dep-link.patch
-
- # We should get dump185 to link against system db1 ..
- # <azarah@gentoo.org> (23 Feb 2003)
- mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
- sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
- -e 's:DB185LIB=:DB185LIB= -ldb1:' \
- ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
-
- # Fix invalid .la files
- cd ${WORKDIR}/${P}/dist
- rm -f ltversion.sh
- # remove config.guess else we have problems with gcc-3.2
- rm -f config.guess
- sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
-
- cd ${S}
- epatch ${FILESDIR}/${P}-jarlocation.patch
- epatch ${FILESDIR}/db-3.2.9-java15.patch
- gnuconfig_update
-}
-
-src_compile() {
- local conf=
- local conf_shared=
- local conf_static=
-
- use java && export JAVACABS="${JAVAC}"
-
- conf="${conf}
- --host=${CHOST} \
- --build=${CHOST} \
- --enable-cxx \
- --enable-compat185 \
- --enable-dump185 \
- --prefix=/usr"
-
- # --enable-rpc DOES NOT BUILD
- # Robin H. Johnson <robbat2@gentoo.org> (18 Oct 2003)
-
- conf_shared="${conf_shared}
- `use_enable java`
- --enable-dynamic"
-
- # TCL support is also broken
- # Robin H. Johnson <robbat2@gentoo.org> (18 Oct 2003)
- # conf_shared="${conf_shared}
- # `use_enable tcl tcl`
- # `use_with tcl tcl /usr/lib`"
-
- # NOTE: we should not build both shared and static versions
- # of the libraries in the same build root!
-
- einfo "Configuring ${P} (static)..."
- mkdir -p ${S}/build-static
- cd ${S}/build-static
- ../dist/configure ${conf} ${conf_static} \
- --libdir=/usr/$(get_libdir) \
- --enable-static || die
-
- einfo "Configuring ${P} (shared)..."
- mkdir -p ${S}/build-shared
- cd ${S}/build-shared
- ../dist/configure ${conf} ${conf_shared} \
- --libdir=/usr/$(get_libdir) \
- --enable-shared || die
-
- # Parallel make does not work
- MAKEOPTS="${MAKEOPTS} -j1"
- einfo "Building ${P} (static)..."
- cd ${S}/build-static
- emake || die "Static build failed"
- einfo "Building ${P} (shared)..."
- cd ${S}/build-shared
- emake || die "Shared build failed"
-}
-
-src_install () {
- cd ${S}/build-shared
- make libdb=libdb-3.2.a \
- libcxx=libcxx_3.2.a \
- prefix=${D}/usr \
- libdir=${D}/usr/$(get_libdir) \
- install || die
-
- cd ${S}/build-static
- newlib.a libdb.a libdb-3.2.a || die "failed to package static libraries!"
- newlib.a libdb_cxx.a libdb_cxx-3.2.a || die "failed to package static libraries!"
-
- db_src_install_headerslot || die "db_src_install_headerslot failed!"
-
- # this is now done in the db eclass, function db_fix_so and db_src_install_usrlibcleanup
- #cd ${D}/usr/lib
- #ln -s libdb-3.2.so libdb.so.3
-
- # For some reason, db.so's are *not* readable by group or others,
- # resulting in no one but root being able to use them!!!
- # This fixes it -- DR 15 Jun 2001
- cd ${D}/usr/$(get_libdir)
- chmod go+rx *.so
- # The .la's aren't readable either
- chmod go+r *.la
-
- cd ${S}
- dodoc README LICENSE
-
- db_src_install_doc || die "db_src_install_doc failed!"
-
- db_src_install_usrbinslot || die "db_src_install_usrbinslot failed!"
-
- db_src_install_usrlibcleanup || die "db_src_install_usrlibcleanup failed!"
-}
-
-pkg_postinst () {
- db_fix_so
-}
-
-pkg_postrm () {
- db_fix_so
-}
diff --git a/sys-libs/db/db-3.2.9-r11.ebuild b/sys-libs/db/db-3.2.9-r11.ebuild
index 61e02b4a7d53..73517280802c 100644
--- a/sys-libs/db/db-3.2.9-r11.ebuild
+++ b/sys-libs/db/db-3.2.9-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r11.ebuild,v 1.12 2007/09/03 17:07:56 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r11.ebuild,v 1.13 2007/10/24 07:07:55 wltjr Exp $
inherit gnuconfig libtool eutils db java-pkg-opt-2
@@ -33,33 +33,33 @@ src_unpack() {
chmod -R ug+w *
- cd ${WORKDIR}/${P}
- epatch ${FILESDIR}/patch.3.2.9.1
- epatch ${FILESDIR}/patch.3.2.9.2
+ cd "${WORKDIR}"/${P}
+ epatch "${FILESDIR}"/patch.3.2.9.1
+ epatch "${FILESDIR}"/patch.3.2.9.2
# Get db to link libdb* to correct dependencies ... for example if we use
# NPTL or NGPT, db detects usable mutexes, and should link against
# libpthread, but does not do so ...
# <azarah@gentoo.org> (23 Feb 2003)
- epatch ${FILESDIR}/${P}-fix-dep-link.patch
+ epatch "${FILESDIR}"/${P}-fix-dep-link.patch
# We should get dump185 to link against system db1 ..
# <azarah@gentoo.org> (23 Feb 2003)
- mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
+ mv "${S}"/dist/Makefile.in "${S}"/dist/Makefile.in.orig
sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
-e 's:DB185LIB=:DB185LIB= -ldb1:' \
- ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
+ "${S}/dist/Makefile.in.orig > "${S}"/dist/Makefile.in || die "Failed to sed"
# Fix invalid .la files
- cd ${WORKDIR}/${P}/dist
+ cd "${WORKDIR}"/${P}/dist
rm -f ltversion.sh
# remove config.guess else we have problems with gcc-3.2
rm -f config.guess
sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
- cd ${S}
- epatch ${FILESDIR}/${P}-jarlocation.patch
- epatch ${FILESDIR}/db-3.2.9-java15.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-jarlocation.patch
+ epatch "${FILESDIR}"/db-3.2.9-java15.patch
gnuconfig_update
}
@@ -93,16 +93,16 @@ src_compile() {
# of the libraries in the same build root!
einfo "Configuring ${P} (static)..."
- mkdir -p ${S}/build-static
- cd ${S}/build-static
+ mkdir -p "${S}"/build-static
+ cd "${S}"/build-static
strip=/bin/true \
../dist/configure ${conf} ${conf_static} \
--libdir=/usr/$(get_libdir) \
--enable-static || die
einfo "Configuring ${P} (shared)..."
- mkdir -p ${S}/build-shared
- cd ${S}/build-shared
+ mkdir -p "${S}"/build-shared
+ cd "${S}"/build-shared
strip=/bin/true \
../dist/configure ${conf} ${conf_shared} \
--libdir=/usr/$(get_libdir) \
@@ -111,41 +111,41 @@ src_compile() {
# Parallel make does not work
MAKEOPTS="${MAKEOPTS} -j1"
einfo "Building ${P} (static)..."
- cd ${S}/build-static
+ cd "${S}"/build-static
emake strip=/bin/true || die "Static build failed"
einfo "Building ${P} (shared)..."
- cd ${S}/build-shared
+ cd "${S}"/build-shared
emake strip=/bin/true || die "Shared build failed"
}
src_install () {
- cd ${S}/build-shared
+ cd "${S}"/build-shared
make libdb=libdb-3.2.a \
libcxx=libcxx_3.2.a \
- prefix=${D}/usr \
- libdir=${D}/usr/$(get_libdir) \
+ prefix="${D}"/usr \
+ libdir="${D}"/usr/$(get_libdir) \
strip=/bin/true \
install || die
- cd ${S}/build-static
+ cd "${S}"/build-static
newlib.a libdb.a libdb-3.2.a || die "failed to package static libraries!"
newlib.a libdb_cxx.a libdb_cxx-3.2.a || die "failed to package static libraries!"
db_src_install_headerslot || die "db_src_install_headerslot failed!"
# this is now done in the db eclass, function db_fix_so and db_src_install_usrlibcleanup
- #cd ${D}/usr/lib
+ #cd "${D}"/usr/lib
#ln -s libdb-3.2.so libdb.so.3
# For some reason, db.so's are *not* readable by group or others,
# resulting in no one but root being able to use them!!!
# This fixes it -- DR 15 Jun 2001
- cd ${D}/usr/$(get_libdir)
+ cd "${D}"/usr/$(get_libdir)
chmod go+rx *.so
# The .la's aren't readable either
chmod go+r *.la
- cd ${S}
+ cd "${S}"
dodoc README LICENSE
db_src_install_doc || die "db_src_install_doc failed!"
diff --git a/sys-libs/db/db-4.4.20_p4.ebuild b/sys-libs/db/db-4.4.20_p4.ebuild
index 7d387fded979..b2d4540c5270 100644
--- a/sys-libs/db/db-4.4.20_p4.ebuild
+++ b/sys-libs/db/db-4.4.20_p4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.4.20_p4.ebuild,v 1.3 2007/03/02 17:27:15 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.4.20_p4.ebuild,v 1.4 2007/10/24 07:07:55 wltjr Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -89,7 +89,7 @@ src_compile() {
append-ldflags -Wl,--default-symver
fi
- cd ${S} && ECONF_SOURCE="${S}"/../dist econf \
+ cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
--prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
diff --git a/sys-libs/db/db-4.5.20_p2.ebuild b/sys-libs/db/db-4.5.20_p2.ebuild
index ab2ef5d26230..cff37baf7f85 100644
--- a/sys-libs/db/db-4.5.20_p2.ebuild
+++ b/sys-libs/db/db-4.5.20_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2.ebuild,v 1.20 2007/08/27 17:16:58 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2.ebuild,v 1.21 2007/10/24 07:07:55 wltjr Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -95,7 +95,7 @@ src_compile() {
append-ldflags -Wl,--default-symver
fi
- cd ${S} && ECONF_SOURCE="${S}"/../dist econf \
+ cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
--prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
diff --git a/sys-libs/db/db-4.6.19.ebuild b/sys-libs/db/db-4.6.19.ebuild
index ef51427823b4..0a425668522f 100644
--- a/sys-libs/db/db-4.6.19.ebuild
+++ b/sys-libs/db/db-4.6.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.19.ebuild,v 1.1 2007/08/19 12:08:30 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.19.ebuild,v 1.2 2007/10/24 07:07:55 wltjr Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -95,7 +95,7 @@ src_compile() {
append-ldflags -Wl,--default-symver
fi
- cd ${S} && ECONF_SOURCE="${S}"/../dist econf \
+ cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
--prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
diff --git a/sys-libs/db/files/digest-db-3.2.9-r10 b/sys-libs/db/files/digest-db-3.2.9-r10
deleted file mode 100644
index 94bf83c2428a..000000000000
--- a/sys-libs/db/files/digest-db-3.2.9-r10
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
-RMD160 c2c5cdb3ec0e99e5687c0861dfbf76b8878f27cb db-3.2.9.tar.gz 2085238
-SHA256 3eccaec87bca4ca0f5728cf4579650da9d12e331187f1e98321e5c9e9e04b108 db-3.2.9.tar.gz 2085238