summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-12-13 10:10:46 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-12-13 10:10:46 +0000
commit89089634d085c3bf01d3b3945e94529d0fe0dc23 (patch)
tree53e9e2a652d67c9a7f187e048647ce1722cda4a6 /sys-libs/glibc/glibc-2.3.4.20041102.ebuild
parentStable for x86 (Manifest recommit) (diff)
downloadgentoo-2-89089634d085c3bf01d3b3945e94529d0fe0dc23.tar.gz
gentoo-2-89089634d085c3bf01d3b3945e94529d0fe0dc23.tar.bz2
gentoo-2-89089634d085c3bf01d3b3945e94529d0fe0dc23.zip
Added ~sparc to glibc-2.3.4.20040808-r1, but it is masked in the sparc32 and sparc64 PROFILE_ARCHs. Older versions have v9a assembly code that doesn't work with newer binutils. Glibc also isn't quite smart enough to realize that it has v9a assembly, so if it uses the gcc default (v9), it will fail, so we force v9a as flags. I also added the updated logic to 2.3.4.20041102, but as I haven't tested it yet, it hasn't been marked.
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20041102.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild21
1 files changed, 20 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index 25760007ab07..be8139a67465 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.14 2004/12/07 15:17:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.15 2004/12/13 10:10:46 eradicator Exp $
inherit eutils flag-o-matic gcc versionator
@@ -132,6 +132,25 @@ setup_flags() {
export CTARGET="sparcv9-unknown-linux-gnu"
fi
fi
+
+ if [ "${PROFILE_ARCH}" = "sparc64-multilib" ]; then
+ # glibc isn't too smart about guessing our flags. It
+ # also will default to -xarch=v9, but assembly in glibc
+ # needs to be v9a or greater...
+ if is-flag "-mcpu=ultrasparc3"; then
+ append-flags "-Wa,-xarch=v9b"
+ export ASFLAGS="${ASFLAGS} -Wa,-xarch=v9b"
+
+ # Change CHOST to include us3 assembly
+ export CHOST="sparc64b-unknown-linux-gnu"
+ else
+ append-flags "-Wa,-xarch=v9a"
+ export ASFLAGS="${ASFLAGS} -Wa,-xarch=v9a"
+ fi
+
+ # Get rid of flags known to fail
+ replace-flags "-mvis" ""
+ fi
fi
if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]; then