summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-03 04:51:54 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-03 04:51:54 +0000
commitaa298fca6c8955c420fac8a76960996bb9c0a27c (patch)
tree8c2513ebf59cefcaf504c7531d574772921347b0 /sys-libs/glibc/glibc-2.3.4.20041102.ebuild
parentThanks to Joël <numlock (at) freesurf.ch> for the ebuild in Bug #68527. (Man... (diff)
downloadgentoo-2-aa298fca6c8955c420fac8a76960996bb9c0a27c.tar.gz
gentoo-2-aa298fca6c8955c420fac8a76960996bb9c0a27c.tar.bz2
gentoo-2-aa298fca6c8955c420fac8a76960996bb9c0a27c.zip
merge fixes between versions
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20041102.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index 4c407dd2d473..bb88f05efd62 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.6 2004/11/22 16:28:57 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.7 2004/12/03 04:51:54 vapier Exp $
inherit eutils flag-o-matic gcc versionator
@@ -40,7 +40,7 @@ SRC_URI="http://dev.gentoo.org/~lv/${PN}-${BASE_PV}.tar.bz2
LICENSE="LGPL-2"
SLOT="2.2"
-KEYWORDS="~amd64 ppc64 -hppa ~ia64 ~ppc ~x86 ~mips -*"
+KEYWORDS="~amd64 ppc64 -hppa ~ia64 ~ppc ~x86 ~mips"
IUSE="nls pic build nptl nptlonly erandom hardened multilib debug userlocales nomalloccheck"
RESTRICT="nostrip" # we'll handle stripping ourself #46186
@@ -64,10 +64,10 @@ PROVIDE="virtual/glibc virtual/libc"
# (very) Theoretical cross-compiler support
-[ -z "${CTARGET}" ] && CTARGET="${CHOST}"
+export CTARGET="${CTARGET:-${CHOST}}"
-# We need to be able to set alternative headers for compiling for non-native
-# platforms.
+# We need to be able to set alternative headers for
+# compiling for non-native platform
# Will also become useful for testing kernel-headers without screwing up
# the whole system.
# note: intentionally undocumented.
@@ -106,7 +106,7 @@ setup_flags() {
fi
fi
- if version_is_at_least 3.4.0 ; then
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]; then
# broken in 3.4.x
replace-flags -march=pentium-m -mtune=pentium3
fi
@@ -122,7 +122,6 @@ setup_flags() {
# Lock glibc at -O2 -- linuxthreads needs it and we want to be
# conservative here
append-flags -O2
- export LDFLAGS="${LDFLAGS//-Wl,--relax}"
}
@@ -326,8 +325,6 @@ do_arch_hppa_patches() {
use hardened && epatch ${FILESDIR}/2.3.4/glibc-2.3.4-hppa-hardened-disable__init_arrays.patch
- einfo "Done with hppa patches."
-
}
@@ -905,4 +902,3 @@ pkg_postinst() {
einfo "remove the line that disables it (mdns off)."
echo
}
-