summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-18 02:10:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-18 02:10:37 +0000
commit4e73ad68fbc472237ac49955a31a34c9597616c5 (patch)
treecab0678e765f1fc7c18b8741739abf387fefd1cf /sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
parentFix dependency over libvorbis only if encode is requrested. Bug #111739. (diff)
downloadgentoo-2-4e73ad68fbc472237ac49955a31a34c9597616c5.tar.gz
gentoo-2-4e73ad68fbc472237ac49955a31a34c9597616c5.tar.bz2
gentoo-2-4e73ad68fbc472237ac49955a31a34c9597616c5.zip
fix header searching when emerging into an empty ROOT #114923
(Portage version: 2.0.53)
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 4a2c2a518572..71efd3dafbc0 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.64 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.65 2005/12/18 02:10:37 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -884,6 +884,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -891,7 +894,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info