summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-13 03:54:31 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-13 03:54:31 +0000
commit8fc93a3be5d2ebdc062e32414533a07f5b4d8f30 (patch)
tree3f6f49faab3b7d5dfea3b986d968eaa33aa70055 /sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
parenttouchup support for cross-compiling a native compiler (diff)
downloadgentoo-2-8fc93a3be5d2ebdc062e32414533a07f5b4d8f30.tar.gz
gentoo-2-8fc93a3be5d2ebdc062e32414533a07f5b4d8f30.tar.bz2
gentoo-2-8fc93a3be5d2ebdc062e32414533a07f5b4d8f30.zip
fake out a usr symlink so that --with-sysroot works with gcc
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 8da329020187..c97d58411c49 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.57 2005/08/04 19:36:30 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.58 2005/08/13 03:54:31 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -432,6 +432,7 @@ toolchain-glibc_src_install() {
# system headers correctly. See gcc/doc/gccinstall.info
if is_crosscompile ; then
dosym include $(alt_prefix)/sys-include
+ dosym . $(alt_prefix)/usr
return 0
fi