summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-05 18:25:21 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-05 18:25:21 +0000
commitb12e3c81191434c10afc61db45630e9cbad27d32 (patch)
tree632851167faef4132262d5f99fc5379cacd7cffa /sys-libs/glibc
parentStable for ppc64, wrt bug #464366 (diff)
downloadgentoo-2-b12e3c81191434c10afc61db45630e9cbad27d32.tar.gz
gentoo-2-b12e3c81191434c10afc61db45630e9cbad27d32.tar.bz2
gentoo-2-b12e3c81191434c10afc61db45630e9cbad27d32.zip
Force mips float/abi cached vars #464642 by Bertrand Jacquin. Update the logic to log each var (and its value) that it forced to make debugging simpler.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/src_compile.eblit44
2 files changed, 32 insertions, 19 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index fc3f8243c808..5172d4341a0d 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,5 +1,10 @@
# ChangeLog for sys-libs/glibc
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.932 2013/04/05 18:23:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.933 2013/04/05 18:25:21 vapier Exp $
+
+ 05 Apr 2013; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_compile.eblit:
+ Force mips float/abi cached vars #464642 by Bertrand Jacquin. Update the logic
+ to log each var (and its value) that it forced to make debugging simpler.
05 Apr 2013; Mike Frysinger <vapier@gentoo.org> glibc-2.17.ebuild:
Disable mips librt patch as it no longer applies -- lets see if people
diff --git a/sys-libs/glibc/files/eblits/src_compile.eblit b/sys-libs/glibc/files/eblits/src_compile.eblit
index c058e19bde82..b4d3baf9919a 100644
--- a/sys-libs/glibc/files/eblits/src_compile.eblit
+++ b/sys-libs/glibc/files/eblits/src_compile.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.34 2013/04/05 00:33:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.35 2013/04/05 18:25:21 vapier Exp $
glibc_do_configure() {
local myconf=()
@@ -161,24 +161,32 @@ toolchain-glibc_headers_compile() {
# if we don't have a compiler yet, we cant really test it now ...
# hopefully they don't affect header geneation, so let's hope for
# the best here ...
- export \
- ac_cv_header_cpuid_h=yes \
- libc_cv_{386,390,alpha,arm,hppa,ia64,mips,{powerpc,sparc}{,32,64},sh,x86_64}_tls=yes \
- libc_cv_asm_cfi_directives=yes \
- libc_cv_broken_visibility_attribute=no \
- libc_cv_gcc___thread=yes \
- libc_cv_mlong_double_128=yes \
- libc_cv_mlong_double_128ibm=yes \
- libc_cv_ppc_machine=yes \
- libc_cv_ppc_rel16=yes \
- libc_cv_predef_{fortify_source,stack_protector}=no \
- libc_cv_visibility_attribute=yes \
- libc_cv_z_combreloc=yes \
- libc_cv_z_execstack=yes \
- libc_cv_z_initfirst=yes \
- libc_cv_z_nodelete=yes \
- libc_cv_z_nodlopen=yes \
+ local v vars=(
+ ac_cv_header_cpuid_h=yes
+ libc_cv_{386,390,alpha,arm,hppa,ia64,mips,{powerpc,sparc}{,32,64},sh,x86_64}_tls=yes
+ libc_cv_asm_cfi_directives=yes
+ libc_cv_broken_visibility_attribute=no
+ libc_cv_gcc___thread=yes
+ libc_cv_mlong_double_128=yes
+ libc_cv_mlong_double_128ibm=yes
+ libc_cv_ppc_machine=yes
+ libc_cv_ppc_rel16=yes
+ libc_cv_predef_{fortify_source,stack_protector}=no
+ libc_cv_visibility_attribute=yes
+ libc_cv_z_combreloc=yes
+ libc_cv_z_execstack=yes
+ libc_cv_z_initfirst=yes
+ libc_cv_z_nodelete=yes
+ libc_cv_z_nodlopen=yes
libc_cv_z_relro=yes
+ libc_mips_abi=${ABI}
+ libc_mips_float=$([[ $(tc-is-softfloat) == "yes" ]] && echo soft || echo hard)
+ )
+ einfo "Forcing cached settings:"
+ for v in "${vars[@]}" ; do
+ einfo " ${v}"
+ export ${v}
+ done
# Pick out the correct location for build headers
local ports="" myconf=()