summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-19 01:13:40 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-19 01:13:40 +0000
commit4779039a8144efe457bf7b82bf99c42a144003f6 (patch)
tree089bd0a2dbe3e060bf817e4fda9b7b8c4d78ecd0 /sys-libs/gpm
parentold (diff)
downloadgentoo-2-4779039a8144efe457bf7b82bf99c42a144003f6.tar.gz
gentoo-2-4779039a8144efe457bf7b82bf99c42a144003f6.tar.bz2
gentoo-2-4779039a8144efe457bf7b82bf99c42a144003f6.zip
Version bump #228065 by Conrad Kostecki.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog8
-rw-r--r--sys-libs/gpm/files/gpm-1.20.5-abi.patch13
-rw-r--r--sys-libs/gpm/gpm-1.20.5.ebuild59
3 files changed, 79 insertions, 1 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index 35436638541b..963b9ec24940 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.69 2008/06/08 21:17:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.70 2008/06/19 01:13:40 vapier Exp $
+
+*gpm-1.20.5 (19 Jun 2008)
+
+ 19 Jun 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/gpm-1.20.5-abi.patch, +gpm-1.20.5.ebuild:
+ Version bump #228065 by Conrad Kostecki.
08 Jun 2008; Mike Frysinger <vapier@gentoo.org> gpm-1.20.4.ebuild:
Append _GNU_SOURCE to CPPFLAGS to fix building with glibc-2.8 #225375 by
diff --git a/sys-libs/gpm/files/gpm-1.20.5-abi.patch b/sys-libs/gpm/files/gpm-1.20.5-abi.patch
new file mode 100644
index 000000000000..28980151e7a3
--- /dev/null
+++ b/sys-libs/gpm/files/gpm-1.20.5-abi.patch
@@ -0,0 +1,13 @@
+the SONAME upstream was bumped to try and sort out the 1.19.x/1.20.x mess, but
+since we've always had 1.20.x in our tree, we dont care about that breakage.
+
+http://lists.linux.it/pipermail/gpm/2008-June/001026.html
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=473496
+
+--- gpm/configure
++++ gpm/configure
+@@ -1736,2 +1736,2 @@
+-abi_lev="2"
+-abi_age="1"
++abi_lev="1"
++abi_age="20"
diff --git a/sys-libs/gpm/gpm-1.20.5.ebuild b/sys-libs/gpm/gpm-1.20.5.ebuild
new file mode 100644
index 000000000000..8870c14c9046
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.5.ebuild,v 1.1 2008/06/19 01:13:40 vapier Exp $
+
+# emacs support disabled due to Bug 99533
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Console-based mouse driver"
+HOMEPAGE="http://linux.schottelius.org/gpm/"
+SRC_URI="http://linux.schottelius.org/gpm/archives/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="sys-libs/ncurses
+ app-arch/lzma-utils"
+RDEPEND="selinux? ( sec-policy/selinux-gpm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.20.5-abi.patch
+}
+
+src_compile() {
+ econf \
+ --libdir=/$(get_libdir) \
+ --sysconfdir=/etc/gpm \
+ || die "econf failed"
+
+ # workaround broken release
+ find -name '*.o' | xargs rm
+ emake clean || die
+ emake -j1 -C doc || die
+
+ emake EMACS=: || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" EMACS=: ELISP="" || die "make install failed"
+
+ dosym libgpm.so.1.20.0 /$(get_libdir)/libgpm.so.1
+ dosym libgpm.so.1 /$(get_libdir)/libgpm.so
+ dodir /usr/$(get_libdir)
+ mv "${D}"/$(get_libdir)/libgpm.a "${D}"/usr/$(get_libdir)/ || die
+ gen_usr_ldscript libgpm.so
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ dodoc BUGS Changes README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+
+ newinitd "${FILESDIR}"/gpm.rc6 gpm
+ newconfd "${FILESDIR}"/gpm.conf.d gpm
+}