summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-18 04:10:11 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-18 04:10:11 +0000
commit91855501790d543b323b1be843a3cd69eb024c4c (patch)
tree48333e6df4ad913cd9291753c093b39159eb400d /sys-libs/libcap
parentFix byBedOS_Gui for building with USE=debug #234959. (diff)
downloadgentoo-2-91855501790d543b323b1be843a3cd69eb024c4c.tar.gz
gentoo-2-91855501790d543b323b1be843a3cd69eb024c4c.tar.bz2
gentoo-2-91855501790d543b323b1be843a3cd69eb024c4c.zip
Version bump #231688 by Arfrever Frehtes Taifersar Arahesis and fix USE=pam dep #231187.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-libs/libcap')
-rw-r--r--sys-libs/libcap/ChangeLog9
-rw-r--r--sys-libs/libcap/files/2.11/0001-Make-fixes.patch120
-rw-r--r--sys-libs/libcap/libcap-2.11.ebuild47
3 files changed, 175 insertions, 1 deletions
diff --git a/sys-libs/libcap/ChangeLog b/sys-libs/libcap/ChangeLog
index b2cc7669d08f..b2629023cc85 100644
--- a/sys-libs/libcap/ChangeLog
+++ b/sys-libs/libcap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/libcap
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.65 2008/06/01 02:28:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.66 2008/08/18 04:10:11 vapier Exp $
+
+*libcap-2.11 (18 Aug 2008)
+
+ 18 Aug 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/2.11/0001-Make-fixes.patch, +libcap-2.11.ebuild:
+ Version bump #231688 by Arfrever Frehtes Taifersar Arahesis and fix
+ USE=pam dep #231187.
*libcap-2.10 (01 Jun 2008)
diff --git a/sys-libs/libcap/files/2.11/0001-Make-fixes.patch b/sys-libs/libcap/files/2.11/0001-Make-fixes.patch
new file mode 100644
index 000000000000..a599a98b8ebb
--- /dev/null
+++ b/sys-libs/libcap/files/2.11/0001-Make-fixes.patch
@@ -0,0 +1,120 @@
+diff --git a/Make.Rules b/Make.Rules
+index d597fde..26335e7 100644
+--- a/Make.Rules
++++ b/Make.Rules
+@@ -42,26 +42,28 @@ MINOR=11
+
+ # Compilation specifics
+
+-CC := gcc
+-CFLAGS := -O2
+-BUILD_CC := $(CC)
+-BUILD_CFLAGS := $(CFLAGS)
+-AR := ar
+-RANLIB := ranlib
+-DEBUG = -g #-DDEBUG
+-WARNINGS=-fPIC -Wall -Wwrite-strings \
++CC ?= gcc
++CFLAGS ?= -O2 -g
++BUILD_CC ?= $(CC)
++BUILD_CFLAGS ?= $(CFLAGS)
++AR ?= ar
++RANLIB ?= ranlib
++WARNINGS=-Wall -Wwrite-strings \
+ -Wpointer-arith -Wcast-qual -Wcast-align \
+ -Wstrict-prototypes -Wmissing-prototypes \
+ -Wnested-externs -Winline -Wshadow
+ LD=$(CC) -Wl,-x -shared
+-LDFLAGS := #-g
++LDFLAGS ?= #-g
+
+ KERNEL_HEADERS := $(topdir)/libcap/include
+-SYSTEM_HEADERS = /usr/include
+ IPATH += -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
++LIBCAP_CPPFLAGS = -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
++CPPFLAGS += $(LIBCAP_CPPFLAGS)
++BUILD_CLAGS += $(LIBCAP_CPPFLAGS)
+ INCS=$(topdir)/libcap/include/sys/capability.h
+ LDFLAGS += -L$(topdir)/libcap
+-CFLAGS += -Dlinux $(WARNINGS) $(DEBUG) $(IPATH)
++CPPFLAGS += -Dlinux
++CFLAGS += $(WARNINGS)
+ PAM_CAP := $(shell if [ -f /usr/include/security/pam_modules.h ]; then echo yes ; else echo no ; fi)
+ # Global cleanup stuff
+
+diff --git a/libcap/Makefile b/libcap/Makefile
+index da22bd1..55e4fe3 100644
+--- a/libcap/Makefile
++++ b/libcap/Makefile
+@@ -17,7 +17,8 @@ OBJS=$(addsuffix .o, $(FILES))
+ MAJLIBNAME=$(LIBNAME).$(VERSION)
+ MINLIBNAME=$(MAJLIBNAME).$(MINOR)
+ GPERF_OUTPUT = _caps_output.gperf
+-LDFLAGS += -lattr
++LDLIBS += -lattr
++CFLAGS += -fPIC
+
+ all: $(MINLIBNAME) $(STALIBNAME)
+
+@@ -44,15 +45,15 @@ $(STALIBNAME): $(OBJS)
+ $(RANLIB) $@
+
+ $(MINLIBNAME): $(OBJS)
+- $(LD) $(CFLAGS) $(LDFLAGS) -Wl,-soname,$(MAJLIBNAME) -o $@ $^
++ $(LD) $(CFLAGS) $(LDFLAGS) -Wl,-soname,$(MAJLIBNAME) -o $@ $^ $(LDLIBS)
+ ln -sf $(MINLIBNAME) $(MAJLIBNAME)
+ ln -sf $(MAJLIBNAME) $(LIBNAME)
+
+ %.o: %.c $(INCLS)
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ cap_text.o: cap_text.c $(USE_GPERF_OUTPUT) $(INCLS)
+- $(CC) $(CFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
+
+ install: all
+ mkdir -p -m 0755 $(INCDIR)/sys
+diff --git a/pam_cap/Makefile b/pam_cap/Makefile
+index 6483790..bef59d2 100644
+--- a/pam_cap/Makefile
++++ b/pam_cap/Makefile
+@@ -14,13 +14,13 @@ install: all
+ install -m 0755 pam_cap.so $(LIBDIR)/security
+
+ pam_cap.so: pam_cap.o
+- $(LD) $(CFLAGS) -o pam_cap.so $< $(LDLIBS)
++ $(LD) $(CFLAGS) $(LDFLAGS) -o pam_cap.so $< $(LDLIBS)
+
+ pam_cap.o: pam_cap.c
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ testcompile: test.c pam_cap.o
+- $(CC) $(CFLAGS) -o $@ $+ -lpam -ldl $(LDLIBS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $+ -lpam -ldl $(LDLIBS)
+
+ clean:
+ rm -f *.o *.so testcompile *~
+diff --git a/progs/Makefile b/progs/Makefile
+index a8e0e53..f568225 100644
+--- a/progs/Makefile
++++ b/progs/Makefile
+@@ -6,7 +6,7 @@ include $(topdir)/Make.Rules
+ #
+ PROGS=getpcaps getcap setcap capsh
+
+-LDFLAGS += --static
++LDFLAGS += --static
+ LDLIBS += -lcap
+
+ all: $(PROGS)
+@@ -15,7 +15,7 @@ $(PROGS): %: %.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LDLIBS)
+
+ %.o: %.c $(INCS)
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ install: all
+ mkdir -p -m 0755 $(SBINDIR)
diff --git a/sys-libs/libcap/libcap-2.11.ebuild b/sys-libs/libcap/libcap-2.11.ebuild
new file mode 100644
index 000000000000..edfcdbf5effb
--- /dev/null
+++ b/sys-libs/libcap/libcap-2.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-2.11.ebuild,v 1.1 2008/08/18 04:10:11 vapier Exp $
+
+inherit eutils multilib toolchain-funcs pam
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://www.friedhoff.org/posixfilecaps.html"
+SRC_URI="http://www.kernel.org/pub/linux/libs/security/linux-privs/libcap${PV:0:1}/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND="sys-apps/attr
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}/*.patch
+ epatch "${FILESDIR}"/${PN}-2.08-no-static.patch
+ sed -i 's:gperf:false:' libcap/Makefile #210424
+
+ sed -i -e '/cap_setfcap.*morgan/s:^:#:' pam_cap/capability.conf
+}
+
+src_compile() {
+ tc-export BUILD_CC CC AR RANLIB
+ export PAM_CAP=$(use pam && echo yes || echo no)
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" lib=$(get_libdir) || die
+
+ gen_usr_ldscript libcap.so
+ mv "${D}"/$(get_libdir)/libcap.a "${D}"/usr/$(get_libdir)/ || die
+
+ dopammod pam_cap/pam_cap.so
+ dopamsecurity '' pam_cap/capability.conf
+
+ dodoc CHANGELOG README doc/capability.notes
+}