summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2003-08-27 06:10:56 +0000
committerStefan Jones <cretin@gentoo.org>2003-08-27 06:10:56 +0000
commitc8db247c8a1ec5f3457ff040e97f82a703f2f7fa (patch)
tree1779c58b37e3b44bcf00581506520f8364173fed /sys-libs/libcap
parentAdded -fPIC for prelink to work, and fixed compile error (diff)
downloadgentoo-2-c8db247c8a1ec5f3457ff040e97f82a703f2f7fa.tar.gz
gentoo-2-c8db247c8a1ec5f3457ff040e97f82a703f2f7fa.tar.bz2
gentoo-2-c8db247c8a1ec5f3457ff040e97f82a703f2f7fa.zip
Added -fPIC for prelink to work, and fixed compile error
Diffstat (limited to 'sys-libs/libcap')
-rw-r--r--sys-libs/libcap/ChangeLog6
-rw-r--r--sys-libs/libcap/Manifest6
-rw-r--r--sys-libs/libcap/files/libcap-1.10-syscall.patch23
-rw-r--r--sys-libs/libcap/libcap-1.10-r2.ebuild9
4 files changed, 36 insertions, 8 deletions
diff --git a/sys-libs/libcap/ChangeLog b/sys-libs/libcap/ChangeLog
index c6b2167774d9..f109f295cc29 100644
--- a/sys-libs/libcap/ChangeLog
+++ b/sys-libs/libcap/ChangeLog
@@ -1,12 +1,16 @@
# ChangeLog for sys-libs/libcap
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.4 2003/08/24 02:52:26 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.5 2003/08/27 06:10:52 cretin Exp $
23 Aug 2003; <rac@gentoo.org> libcap-1.10-r2.ebuild:
Add amd64 support
*libcap-1.10-r2 (17 Aug 2003)
+ 27 Aug 2003; Stefan Jones <cretin@gentoo.org> :
+ Add patch which removes the wrapping of the syscall, glibc wraps all syscalls
+ for you. Now the library can be built with -fPIC on all platforms.
+
17 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> libcap-1.10-r2.ebuild:
remove -ansi from WARNINGS in the Make system as it seems to break non-x86
diff --git a/sys-libs/libcap/Manifest b/sys-libs/libcap/Manifest
index 8b14d3389331..97a722e4e8e3 100644
--- a/sys-libs/libcap/Manifest
+++ b/sys-libs/libcap/Manifest
@@ -1,8 +1,8 @@
MD5 0d560a0490338d2cae9ac8a1ae245462 libcap-1.10.ebuild 1678
-MD5 40adf1e9b8c4814924325df3b6fc4c5b libcap-1.10-r2.ebuild 1717
+MD5 0682ed3d09e833b910dbbadc985f3f0c libcap-1.10-r2.ebuild 1720
MD5 97a20b01e5cd724deecf7f8eab0a6d84 libcap-1.10-r1.ebuild 1734
-MD5 b8bf4d8d0b4ab5032cc5433465a8245a ChangeLog 1038
-MD5 140c8c8b46bdca0f752416c7bbd1d689 files/libcap-1.10-syscall.patch 506
+MD5 b5511783261b294830f67e433e769cca ChangeLog 1041
+MD5 71909af5e49cebc3b10f1fbee9a0afca files/libcap-1.10-syscall.patch 633
MD5 8f279ebf325d1b8efb6ad3c3a0d8cb5d files/libcap-1.10-python.patch 3353
MD5 f55c8f8c068940da50e21f4d4b840422 files/digest-libcap-1.10-r1 63
MD5 f55c8f8c068940da50e21f4d4b840422 files/digest-libcap-1.10-r2 63
diff --git a/sys-libs/libcap/files/libcap-1.10-syscall.patch b/sys-libs/libcap/files/libcap-1.10-syscall.patch
new file mode 100644
index 000000000000..3ef01c3cd73c
--- /dev/null
+++ b/sys-libs/libcap/files/libcap-1.10-syscall.patch
@@ -0,0 +1,23 @@
+--- libcap-1.10/libcap/cap_sys.c.jj 2003-08-24 19:03:35.524759616 -0700
++++ libcap-1.10/libcap/cap_sys.c 2003-08-24 19:03:48.406801248 -0700
+@@ -10,7 +10,7 @@
+ #include "libcap.h"
+ #define __LIBRARY__
+ #include <linux/unistd.h>
+-
++/*
+ _syscall2(int, capget,
+ cap_user_header_t, header,
+ cap_user_data_t, data)
+@@ -18,7 +18,7 @@
+ _syscall2(int, capset,
+ cap_user_header_t, header,
+ const cap_user_data_t, data)
+-
++*/
+ /*
+ * $Log: libcap-1.10-syscall.patch,v $
+ * Revision 1.1 2003/08/27 06:10:53 cretin
+ * Added -fPIC for prelink to work, and fixed compile error
+ *
+ * Revision 1.1.1.1 1999/04/17 22:16:31 morgan
diff --git a/sys-libs/libcap/libcap-1.10-r2.ebuild b/sys-libs/libcap/libcap-1.10-r2.ebuild
index b8fde1814536..502db1727669 100644
--- a/sys-libs/libcap/libcap-1.10-r2.ebuild
+++ b/sys-libs/libcap/libcap-1.10-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r2.ebuild,v 1.2 2003/08/24 02:52:26 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r2.ebuild,v 1.3 2003/08/27 06:10:53 cretin Exp $
inherit base
@@ -24,7 +24,8 @@ S=${WORKDIR}/${P}
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/libcap-1.10-python.patch
+ epatch ${FILESDIR}/libcap-1.10-python.patch
+ epatch ${FILESDIR}/libcap-1.10-syscall.patch
sed -i 's|WARNINGS=-ansi|WARNINGS=|' Make.Rules
}
@@ -38,8 +39,8 @@ src_compile() {
CFLAGS="${CFLAGS} -I/usr/include/python${PYTHONVER}"
fi
- # all 64 bit platforms need to get -fPIC
- use alpha || use mips || use amd64 && append-flags -fPIC
+ # all platforms need to get -fPIC for shared libraries
+ append-flags -fPIC
emake COPTFLAG="${CFLAGS}" DEBUG="" ${myflags} || die
}