summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-18 14:30:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-18 14:30:06 +0000
commit45c607b4827ada09f1ec8746a7dafa4eda435dbd (patch)
tree83e6ea9295ff0d201fd9d47db8a37368ab65355b /sys-libs/libcxx
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-45c607b4827ada09f1ec8746a7dafa4eda435dbd.tar.gz
gentoo-2-45c607b4827ada09f1ec8746a7dafa4eda435dbd.tar.bz2
gentoo-2-45c607b4827ada09f1ec8746a7dafa4eda435dbd.zip
bump a new snapshot
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/ChangeLog8
-rw-r--r--sys-libs/libcxx/libcxx-0.0_p20130218.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 11c625a15bf9..558d0e8ae6e8 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.10 2013/02/18 13:34:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.11 2013/02/18 14:30:06 aballier Exp $
+
+*libcxx-0.0_p20130218 (18 Feb 2013)
+
+ 18 Feb 2013; Alexis Ballier <aballier@gentoo.org>
+ +libcxx-0.0_p20130218.ebuild:
+ bump a new snapshot
18 Feb 2013; Alexis Ballier <aballier@gentoo.org>
-libcxx-0.0_p20120911.ebuild:
diff --git a/sys-libs/libcxx/libcxx-0.0_p20130218.ebuild b/sys-libs/libcxx/libcxx-0.0_p20130218.ebuild
new file mode 100644
index 000000000000..897cdf50796d
--- /dev/null
+++ b/sys-libs/libcxx/libcxx-0.0_p20130218.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-0.0_p20130218.ebuild,v 1.1 2013/02/18 14:30:06 aballier Exp $
+
+EAPI=4
+
+ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
+
+[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
+
+inherit cmake-utils ${SCM} base flag-o-matic
+
+DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
+HOMEPAGE="http://libcxx.llvm.org/"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else
+ SRC_URI=""
+fi
+
+LICENSE="|| ( UoI-NCSA MIT )"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE=""
+
+RDEPEND="sys-libs/libcxxrt"
+DEPEND="${RDEPEND}
+ sys-devel/clang
+ app-arch/xz-utils"
+
+PATCHES=( "${FILESDIR}/multilib.patch"
+ "${FILESDIR}/cxxrt.patch" )
+DOCS=( "CREDITS.TXT" )
+
+src_prepare() {
+ base_src_prepare
+}
+
+src_configure() {
+ append-cppflags "-I/usr/include/libcxxrt -DLIBCXXRT"
+ # Needs to be built with clang. gcc-4.6.3 fails at least.
+ # TODO: cross-compile ?
+ export CC=clang
+ export CXX=clang++
+ cmake-utils_src_configure
+}
+
+# Tests fail for now, if anybody is able to fix them, help is very welcome.
+src_test() {
+ cd "${S}/test"
+ LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/lib:${LD_LIBRARY_PATH}" \
+ CC="clang++" \
+ HEADER_INCLUDE="-I${S}/include" \
+ SOURCE_LIB="-L${CMAKE_BUILD_DIR}/lib" \
+ ./testit || die
+}
+
+pkg_postinst() {
+ elog "This package (${PN}) is mainly intended as a replacement for the C++"
+ elog "standard library when using clang."
+ elog "To use it, instead of libstdc++, use:"
+ elog " clang++ -stdlib=libc++"
+ elog "to compile your C++ programs."
+}