summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2009-07-11 11:12:37 +0000
committerDavid Shakaryan <omp@gentoo.org>2009-07-11 11:12:37 +0000
commit2a696936d528fee80dd8c70b6bca04979dd45a94 (patch)
treed76ad2779c72dd57245b35ba8804c15a2e073daa /sys-libs/libixp
parentAdd conky_no_x11.conf from upstream git to fix compilation without X. (diff)
downloadgentoo-2-2a696936d528fee80dd8c70b6bca04979dd45a94.tar.gz
gentoo-2-2a696936d528fee80dd8c70b6bca04979dd45a94.tar.bz2
gentoo-2-2a696936d528fee80dd8c70b6bca04979dd45a94.zip
Version bump. (bug #268693)
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libixp')
-rw-r--r--sys-libs/libixp/ChangeLog9
-rw-r--r--sys-libs/libixp/libixp-0.5.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/sys-libs/libixp/ChangeLog b/sys-libs/libixp/ChangeLog
index 76e1b3b3f571..3e26c8bda81c 100644
--- a/sys-libs/libixp/ChangeLog
+++ b/sys-libs/libixp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libixp
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/ChangeLog,v 1.9 2007/11/19 03:59:15 omp Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/ChangeLog,v 1.10 2009/07/11 11:12:37 omp Exp $
+
+*libixp-0.5 (11 Jul 2009)
+
+ 11 Jul 2009; <omp@gentoo.org> +libixp-0.5.ebuild:
+ Version bump. (bug #268693)
19 Nov 2007; David Shakaryan <omp@gentoo.org> libixp-0.2-r1.ebuild:
Fix small version mistake in blocker dependency.
diff --git a/sys-libs/libixp/libixp-0.5.ebuild b/sys-libs/libixp/libixp-0.5.ebuild
new file mode 100644
index 000000000000..1f2069dae91b
--- /dev/null
+++ b/sys-libs/libixp/libixp-0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/libixp-0.5.ebuild,v 1.1 2009/07/11 11:12:37 omp Exp $
+
+DESCRIPTION="Standalone client/server 9P library"
+HOMEPAGE="http://libs.suckless.org/libixp"
+SRC_URI="http://code.suckless.org/dl/libs/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "/^PREFIX/s|=.*|= ${D}/usr|" \
+ -e "/^ ETC/s|=.*|= ${D}/etc|" \
+ -e "/^CFLAGS/s|=|+=|" \
+ -e "/^LDFLAGS/s|=|+=|" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+}