summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-03-15 13:14:59 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-03-15 13:14:59 +0000
commit891c1b59952c7a40da01cb1680af5b0dba036468 (patch)
tree4fa745fe8c0f5c8c3afb37158ab7ad91667bf986 /sys-libs/libsafe
parentRespect AR, wrt bug #456150. Thanks to Agostino Sarubbo for discovering this ... (diff)
downloadgentoo-2-891c1b59952c7a40da01cb1680af5b0dba036468.tar.gz
gentoo-2-891c1b59952c7a40da01cb1680af5b0dba036468.tar.bz2
gentoo-2-891c1b59952c7a40da01cb1680af5b0dba036468.zip
Revision bump: EAPI 5, epatch_user, use readme.gentoo eclass, respect LDFLAGS, wrt bug #338209
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'sys-libs/libsafe')
-rw-r--r--sys-libs/libsafe/ChangeLog8
-rw-r--r--sys-libs/libsafe/libsafe-2.0_p16-r3.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-libs/libsafe/ChangeLog b/sys-libs/libsafe/ChangeLog
index 3717dc76c763..9f5b188a80ef 100644
--- a/sys-libs/libsafe/ChangeLog
+++ b/sys-libs/libsafe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libsafe
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/ChangeLog,v 1.11 2013/02/03 12:44:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/ChangeLog,v 1.12 2013/03/15 13:14:59 pinkbyte Exp $
+
+*libsafe-2.0_p16-r3 (15 Mar 2013)
+
+ 15 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> +libsafe-2.0_p16-r3.ebuild:
+ Revision bump: EAPI 5, epatch_user, use readme.gentoo eclass, respect
+ LDFLAGS, wrt bug #338209
03 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #22900
diff --git a/sys-libs/libsafe/libsafe-2.0_p16-r3.ebuild b/sys-libs/libsafe/libsafe-2.0_p16-r3.ebuild
new file mode 100644
index 000000000000..685bf2859245
--- /dev/null
+++ b/sys-libs/libsafe/libsafe-2.0_p16-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/libsafe-2.0_p16-r3.ebuild,v 1.1 2013/03/15 13:14:59 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib readme.gentoo toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="Protection against buffer overflow vulnerabilities"
+HOMEPAGE="http://www.research.avayalabs.com/gcm/usa/en-us/initiatives/all/nsr.htm&Filter=ProjectTitle:Libsafe&Wrapper=LabsProjectDetails&View=LabsProjectDetails"
+SRC_URI="http://www.research.avayalabs.com/project/libsafe/src/${MY_P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="To use this you have to put the library
+as one of the variables in LD_PRELOAD.
+Example in bash:
+export LD_PRELOAD=libsafe.so.${PV%%.*}"
+
+src_prepare() {
+ filter-flags -fomit-frame-pointer
+
+ sed -i \
+ -e 's:gcc:$(CC):' \
+ -e "/^CCFLAGS/s:= -O2:= ${CFLAGS}:" \
+ -e "/^LDFLAGS/s:=:+=:" \
+ -e "s:\$(LIBPRELUDE_CFLAGS)::" \
+ -e "s:\$(LIBPRELUDE_LIBS)::" \
+ src/Makefile || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" libsafe
+}
+
+src_install() {
+ # libsafe stuff
+ into /
+ dolib.so src/libsafe.so.${PV/_p/.}
+ dosym libsafe.so.${PV/_p/.} /$(get_libdir)/libsafe.so
+ dosym libsafe.so.${PV/_p/.} /$(get_libdir)/libsafe.so.${PV%%.*}
+
+ # Documentation
+ doman doc/libsafe.8
+ dohtml doc/libsafe.8.html
+
+ dodoc README
+ readme.gentoo_create_doc
+ # use prelude && dodoc LIBPRELUDE
+ # use mta && dodoc EMAIL_NOTIFICATION
+}