summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-06 23:07:45 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-06 23:07:45 +0000
commit56d1abde18fe997f060d3ab22a202b29492b6b8f (patch)
tree3b6b830361c6d825a3491fccf335d7b970f7aa95 /sys-libs/libseccomp
parentClean up the ebuild. Add a dep on mercurial, and use-deps on other Python pac... (diff)
downloadgentoo-2-56d1abde18fe997f060d3ab22a202b29492b6b8f.tar.gz
gentoo-2-56d1abde18fe997f060d3ab22a202b29492b6b8f.tar.bz2
gentoo-2-56d1abde18fe997f060d3ab22a202b29492b6b8f.zip
Version bump #450642 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/ChangeLog9
-rw-r--r--sys-libs/libseccomp/libseccomp-1.0.1.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/sys-libs/libseccomp/ChangeLog b/sys-libs/libseccomp/ChangeLog
index 823340ba09e1..0ccd3771f345 100644
--- a/sys-libs/libseccomp/ChangeLog
+++ b/sys-libs/libseccomp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libseccomp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libseccomp/ChangeLog,v 1.4 2012/11/12 21:21:36 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libseccomp/ChangeLog,v 1.5 2013/01/06 23:07:45 vapier Exp $
+
+*libseccomp-1.0.1 (06 Jan 2013)
+
+ 06 Jan 2013; Mike Frysinger <vapier@gentoo.org> +libseccomp-1.0.1.ebuild:
+ Version bump #450642 by Agostino Sarubbo.
12 Nov 2012; Mike Frysinger <vapier@gentoo.org> libseccomp-1.0.0.ebuild:
Setup correct AR/CC values #442864 by Alphat-PC.
diff --git a/sys-libs/libseccomp/libseccomp-1.0.1.ebuild b/sys-libs/libseccomp/libseccomp-1.0.1.ebuild
new file mode 100644
index 000000000000..99987d0fcb37
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libseccomp/libseccomp-1.0.1.ebuild,v 1.1 2013/01/06 23:07:45 vapier Exp $
+
+# Note: USE=static-libs isn't great -- only PIC objects are provided.
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="http://sourceforge.net/projects/libseccomp/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs tools"
+
+src_prepare() {
+ sed -i \
+ -e "/^SUBDIRS_BUILD/s:=.*:= src $(usex tools tools ''):" \
+ Makefile || die
+ tc-export AR CC
+ export GCC=${CC}
+}
+
+src_test() {
+ emake SUBDIRS_BUILD='tools tests'
+ cd tests
+ ./regression
+}
+
+src_install() {
+ default
+ use tools && dobin tools/{bpf_{disasm,sim},sys_{inspector,resolver}}
+ use static-libs && dolib.a src/libseccomp.a
+}