summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-02-05 11:13:11 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-02-05 11:13:11 +0000
commit34a238e072a9680fd4e30c6052dfb8b0d6fd3eb0 (patch)
treeeb337cd68934e91d813b1edc283a36dd8dd06d21 /sys-libs/libselinux
parentNew upstream release. (diff)
downloadgentoo-2-34a238e072a9680fd4e30c6052dfb8b0d6fd3eb0.tar.gz
gentoo-2-34a238e072a9680fd4e30c6052dfb8b0d6fd3eb0.tar.bz2
gentoo-2-34a238e072a9680fd4e30c6052dfb8b0d6fd3eb0.zip
New upstream release.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libselinux')
-rw-r--r--sys-libs/libselinux/ChangeLog10
-rw-r--r--sys-libs/libselinux/libselinux-2.0.94.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index ff02504b5f76..3d07916a0b20 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libselinux
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.66 2010/09/29 22:58:55 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.67 2011/02/05 11:13:11 blueness Exp $
+
+*libselinux-2.0.94 (05 Feb 2011)
+
+ 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
+ +libselinux-2.0.94.ebuild:
+ New upstream release.
29 Sep 2010; Mike Frysinger <vapier@gentoo.org> libselinux-2.0.85.ebuild,
+files/libselinux-2.0.85-headers.patch:
diff --git a/sys-libs/libselinux/libselinux-2.0.94.ebuild b/sys-libs/libselinux/libselinux-2.0.94.ebuild
new file mode 100644
index 000000000000..64c4f34df16b
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.0.94.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.0.94.ebuild,v 1.1 2011/02/05 11:13:11 blueness Exp $
+
+EAPI="2"
+IUSE="ruby"
+RUBY_OPTIONAL="yes"
+
+inherit eutils multilib python
+
+SEPOL_VER="2.0.41"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20100525/devel/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ dev-lang/swig
+ ruby? ( dev-lang/ruby )"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
+ ruby? ( dev-lang/ruby )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_prepare() {
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ emake LDFLAGS="-fPIC ${LDFLAGS}" all || die
+ emake PYLIBVER="python$(python_get_version)" LDFLAGS="-fPIC ${LDFLAGS}" pywrap || die
+
+ if use ruby; then
+ emake rubywrap || die
+ fi
+}
+
+src_install() {
+ python_need_rebuild
+ make DESTDIR="${D}" PYLIBVER="python$(python_get_version)" install install-pywrap || die
+
+ if use ruby; then
+ emake DESTDIR="${D}" install-rubywrap || die
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)
+}