summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-09 03:08:36 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-09 03:08:36 +0000
commit83c7c211556491a1dd08f6ae00f3c7b5969eb52f (patch)
tree48ba217bc5ee55cfa10c67167e99dba908662ef1 /sys-libs/libstdc++-v3
parentstable on ppc64, bug #57676 (Manifest recommit) (diff)
downloadgentoo-2-83c7c211556491a1dd08f6ae00f3c7b5969eb52f.tar.gz
gentoo-2-83c7c211556491a1dd08f6ae00f3c7b5969eb52f.tar.bz2
gentoo-2-83c7c211556491a1dd08f6ae00f3c7b5969eb52f.zip
~hppa loving
Diffstat (limited to 'sys-libs/libstdc++-v3')
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild31
1 files changed, 3 insertions, 28 deletions
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
index 965ad4e45b47..3de1fe6baa85 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild
@@ -1,34 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.18 2004/08/03 04:12:56 morfic Exp $
-
-IUSE="nls"
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild,v 1.19 2004/08/09 03:08:36 vapier Exp $
inherit eutils flag-o-matic libtool
-# Compile problems with these (bug #6641 among others)...
-#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
-
-# Recently there has been a lot of stability problem in Gentoo-land. Many
-# things can be the cause to this, but I believe that it is due to gcc3
-# still having issues with optimizations, or with it not filtering bad
-# combinations (protecting the user maybe from himeself) yet.
-#
-# This can clearly be seen in large builds like glibc, where too aggressive
-# CFLAGS cause the tests to fail miserbly.
-#
-# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
-# knows what he is talking about:
-#
-# People really shouldn't force code-specific options on... It's a
-# bad idea. The -march options aren't just to look pretty. They enable
-# options that are sensible (and include sse,mmx,3dnow when apropriate).
-#
-# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
-# you do not like it, comment it, but do not bugreport if you run into
-# problems.
-#
-# <azarah@gentoo.org> (13 Oct 2002)
do_filter_flags() {
declare setting
@@ -95,7 +70,8 @@ HOMEPAGE="http://gcc.gnu.org/libstdc++/"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-* amd64 ~mips ~x86 ppc64"
+KEYWORDS="-* ~x86 ~mips ~hppa amd64 ppc64"
+IUSE="nls"
if [ "${CHOST}" == "${CCHOST}" ]
then
@@ -248,4 +224,3 @@ src_install() {
mkdir -p ${D}/etc/env.d/
echo "LDPATH=\"${LOC}/lib/libstdc++-v3/\"" >> ${D}/etc/env.d/99libstdc++
}
-