summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-01 17:00:08 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-01 17:00:08 +0000
commit160615333ac7b8232376814ba9b983b8d22b1863 (patch)
tree7cd896a48b8fdcac8cecee3fd964979779b84ec7 /sys-libs/libtrash
parentDon't reset configured vi symlink (diff)
downloadgentoo-2-160615333ac7b8232376814ba9b983b8d22b1863.tar.gz
gentoo-2-160615333ac7b8232376814ba9b983b8d22b1863.tar.bz2
gentoo-2-160615333ac7b8232376814ba9b983b8d22b1863.zip
Version bumped.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-libs/libtrash')
-rw-r--r--sys-libs/libtrash/ChangeLog7
-rw-r--r--sys-libs/libtrash/files/digest-libtrash-2.63
-rw-r--r--sys-libs/libtrash/libtrash-2.6.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-libs/libtrash/ChangeLog b/sys-libs/libtrash/ChangeLog
index 7bd6d41bb64b..34d8d327f52d 100644
--- a/sys-libs/libtrash/ChangeLog
+++ b/sys-libs/libtrash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libtrash
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/ChangeLog,v 1.8 2007/02/09 08:39:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/ChangeLog,v 1.9 2007/05/01 17:00:08 matsuu Exp $
+
+*libtrash-2.6 (01 May 2007)
+
+ 01 May 2007; MATSUU Takuto <matsuu@gentoo.org> +libtrash-2.6.ebuild:
+ Version bumped.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sys-libs/libtrash/files/digest-libtrash-2.6 b/sys-libs/libtrash/files/digest-libtrash-2.6
new file mode 100644
index 000000000000..fd48bcb14d3b
--- /dev/null
+++ b/sys-libs/libtrash/files/digest-libtrash-2.6
@@ -0,0 +1,3 @@
+MD5 0c81112bbc37047ab90800f4429788f3 libtrash-2.6.tgz 94964
+RMD160 b91e3da2651f5af0d463489e4dc3c55e47451087 libtrash-2.6.tgz 94964
+SHA256 28e12a00ac134c8a2022a439c8d2ffa5809dfb82f58bec2d32eb19154904bebc libtrash-2.6.tgz 94964
diff --git a/sys-libs/libtrash/libtrash-2.6.ebuild b/sys-libs/libtrash/libtrash-2.6.ebuild
new file mode 100644
index 000000000000..cbc3b235f74a
--- /dev/null
+++ b/sys-libs/libtrash/libtrash-2.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/libtrash-2.6.ebuild,v 1.1 2007/05/01 17:00:08 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="provides a trash can by intercepting certain calls to glibc"
+HOMEPAGE="http://pages.stern.nyu.edu/~marriaga/software/libtrash/"
+SRC_URI="http://pages.stern.nyu.edu/~marriaga/software/libtrash/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.4-gentoo.patch
+ sed -i \
+ -e "/^INSTLIBDIR/s/lib/$(get_libdir)/" \
+ -e "/^CFLAGS/s/$/ ${CFLAGS}/" \
+ ${S}/src/Makefile || die
+
+ # now let's unpack strash too in cash anyone is interested
+ cd cleanTrash
+ tar -zxf ./strash-0.9.tar.gz
+}
+
+src_compile() {
+ make CC="$(tc-getCC)" || die "Error Making Source...Exiting"
+}
+
+src_install() {
+ dodir /etc /usr/$(get_libdir)
+ make DESTDIR="${D}" install || die "Error Installing ${P}...Exiting"
+
+ dosbin cleanTrash/ct2.pl
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/cleanTrash.cron
+
+ dodoc CHANGE.LOG README libtrash.conf TODO config.txt
+
+ docinto cleanTrash
+ dodoc cleanTrash/README cleanTrash/cleanTrash
+
+ # new strash installation stuff
+ dosbin cleanTrash/strash-0.9/strash
+ docinto strash
+ dodoc cleanTrash/strash-0.9/README
+ doman cleanTrash/strash-0.9/strash.8
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use this you have to put the trash library as one"
+ einfo "of the variables in LD_PRELOAD."
+ einfo "Example in bash:"
+ einfo "export LD_PRELOAD=/usr/$(get_libdir)/libtrash.so"
+ einfo
+ einfo "Also, see /etc/cron.daily/cleanTrash.cron if you'd like to turn on"
+ einfo "daily trash cleanup."
+ einfo
+}