summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-06-27 22:15:27 +0000
committerAron Griffis <agriffis@gentoo.org>2005-06-27 22:15:27 +0000
commit78f5ce46e4097c544a2b0adff3f6d715254ebb4f (patch)
treeff0a6fb6d80ce69d74cf7e1e0515f438a61b3821 /sys-libs/readline/files
parentVersion bumped to new version that finally fixes the deaded "No more processe... (diff)
downloadgentoo-2-78f5ce46e4097c544a2b0adff3f6d715254ebb4f.tar.gz
gentoo-2-78f5ce46e4097c544a2b0adff3f6d715254ebb4f.tar.bz2
gentoo-2-78f5ce46e4097c544a2b0adff3f6d715254ebb4f.zip
Fix parallel build
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-libs/readline/files')
-rw-r--r--sys-libs/readline/files/readline-5.0-parallel.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-libs/readline/files/readline-5.0-parallel.patch b/sys-libs/readline/files/readline-5.0-parallel.patch
new file mode 100644
index 000000000000..eccb903f0f85
--- /dev/null
+++ b/sys-libs/readline/files/readline-5.0-parallel.patch
@@ -0,0 +1,28 @@
+--- readline-5.0/shlib/Makefile.in.old 2003-12-10 12:02:47 -0500
++++ readline-5.0/shlib/Makefile.in 2005-06-27 18:06:02 -0400
+@@ -145,7 +145,10 @@
+
+ all: $(SHLIB_STATUS)
+
+-supported: $(SHARED_LIBS)
++# Since the libs share some objects, make sure they're built separately
++# and not in parallel
++supported:
++ set -e; for x in $(SHARED_LIBS); do $(MAKE) $$x; done
+
+ unsupported:
+ @echo "Your system and compiler (${host_os}-${CC}) are not supported by the"
+--- readline-5.0/Makefile.in.old 2004-04-22 16:44:37 -0400
++++ readline-5.0/Makefile.in 2005-06-27 18:05:29 -0400
+@@ -145,7 +145,10 @@
+
+ everything: all examples
+
+-static: $(STATIC_LIBS)
++# Since the libs share some objects, make sure they're built separately
++# and not in parallel
++static:
++ set -e; for x in $(STATIC_LIBS); do $(MAKE) $$x; done
+
+ libreadline.a: $(OBJECTS)
+ $(RM) $@