summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-11-03 01:47:54 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-11-03 01:47:54 +0000
commit86fd9e6ec6d9e647b2ce1c0f05d88e6afc1cb0c1 (patch)
tree2902332a1eeaa02a6534ce8c315f231877ed7223 /sys-libs/slang
parentAdd flickr ebuild (yes again for my blog). (diff)
downloadgentoo-2-86fd9e6ec6d9e647b2ce1c0f05d88e6afc1cb0c1.tar.gz
gentoo-2-86fd9e6ec6d9e647b2ce1c0f05d88e6afc1cb0c1.tar.bz2
gentoo-2-86fd9e6ec6d9e647b2ce1c0f05d88e6afc1cb0c1.zip
Version bumped, bug #237144. Added EAPI=2.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'sys-libs/slang')
-rw-r--r--sys-libs/slang/ChangeLog7
-rw-r--r--sys-libs/slang/slang-2.1.4.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index 5295e933c263..e4d85d682c3c 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/slang
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.92 2008/06/12 13:32:03 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.93 2008/11/03 01:47:54 matsuu Exp $
+
+*slang-2.1.4 (03 Nov 2008)
+
+ 03 Nov 2008; MATSUU Takuto <matsuu@gentoo.org> +slang-2.1.4.ebuild:
+ Version bumped, bug #237144. Added EAPI=2.
12 Jun 2008; Samuli Suominen <drac@gentoo.org> slang-2.1.3-r1.ebuild:
arm stable
diff --git a/sys-libs/slang/slang-2.1.4.ebuild b/sys-libs/slang/slang-2.1.4.ebuild
new file mode 100644
index 000000000000..d29056700e98
--- /dev/null
+++ b/sys-libs/slang/slang-2.1.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.1.4.ebuild,v 1.1 2008/11/03 01:47:54 matsuu Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="a portable programmer's library designed to allow a developer to create robust portable software."
+HOMEPAGE="http://www.s-lang.org"
+SRC_URI="ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cjk pcre png readline"
+
+RDEPEND="sys-libs/ncurses[-minimal]
+ pcre? ( dev-libs/libpcre )
+ png? ( media-libs/libpng )
+ cjk? ( dev-libs/oniguruma )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ !=sys-libs/slang-2.1.2"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.2-slsh-libs.patch
+ epatch "${FILESDIR}"/${PN}-2.1.3-uclibc.patch
+}
+
+src_configure() {
+ local myconf
+
+ if use readline; then
+ myconf="${myconf} --with-readline=gnu"
+ else
+ myconf="${myconf} --with-readline=slang"
+ fi
+
+ econf \
+ $(use_with cjk onig) \
+ $(use_with pcre) \
+ $(use_with png) \
+ ${myconf} || die
+}
+
+src_compile() {
+ emake -j1 elf static || die "emake elf static failed."
+
+ cd slsh
+ emake -j1 slsh || die "emake slsh failed."
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install-all || die "emake install-all failed."
+
+ rm -rf "${D}"/usr/share/doc/{slang,slsh}
+
+ dodoc NEWS README *.txt doc/{,internal,text}/*.txt
+ dohtml doc/slangdoc.html slsh/doc/html/*.html
+}